Links nicht anklickbar in html email - warum?

  • Thunderbird-Version:
    17.08
    Betriebssystem + Version:
    WIN7
    Kontenart (POP / IMAP):
    POP
    Postfachanbieter (z.B. GMX):
    Eigene Domain


    Hi,


    ich kann bei manchen eMails die ich erhalte keine Links anklicken
    Hier der Quelltext der eMail.
    Thunderbird ist als Standardprogramm ausgewählt, habe es eben gerade nochmal gemacht, keine Änderung.
    Bei Text eMails kann ich die Links anklicken. Oder wenn ich mir diese eMail an mich selbst weiterleite, dann geht das auch, da ich im TXT Format senden und nicht html.
    Hab ich was falsch eingestellt irgendwo?


    Hier der Quelltext der betreffenden eMAil:


    Code
    1. X-Mailer: PHPMailer 5.2.4 (http://code.google.com/a/apache-extras.org/p/phpmailer/)
    2. MIME-Version: 1.0
    3. Content-Transfer-Encoding: 7bit
    4. Content-Type: text/html;
    5. charset="UTF-8"
    6. Sie haben neue Emails in Ihrem Postfach<br>Von: : Decz Decz, 05-09-2013 / 16:35:50<br><br>Zum lesen hier klicken zum einloggen (http://dieser-link-laesst-sich-nicht-anklicken/wp-login.php)
  • Hallo,
    was erscheint denn bei Überfahren mit der Maus über den Link? Siehst du dann etwas unten in der Statusbar?
    Schon mal den betr. Ordner repariert?
    Ordner reparieren: Rechtsklick auf den Ordner, Eigenschaften, Allgemein, "Reparieren".
    Poste mal die Größe des Ordners:
    Rechtsklick auf den Ordner, aus dem gelöscht werden sollte, dann > Eigenschaften > Allgemein > "Größe auf Datenträger"
    Dort kann man ablesen, wie groß der Ordner ist mit wie vielen Mails. Die Anzahl der Mails ist aber in diesem Fall uninteressant.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    es geht darum, dass die Links nicht anklickbar sind, d.h nicht als Hyperlinks angezeigt werden.
    Ich sehe das auch hier gelegentlich, insbesondere bei Mails, die mit Outlook in HTML geschrieben wurden.
    Dazu habe ich gerade ein Beispiel gefunden, wobei ich allerdings den Mail-Client nicht im Quelltext identifizieren konnte.


    Darstellung in "Original HTML" :



    ________________________________


    Darstellung in "Reiner Text":



    _______________________________


    Im Quelltext finde ich :
    Content-Type: text/html; charset="utf-8"
    MIME-Version: 1.0
    Content-Transfer-Encoding: base64

  • Ja, dass verstehe ich auch nicht. Alle Einstellungen sind OK. Ich erhalte ja auch Newsletter etc. im HTML Format und die Links kann ich ja auch anklicken. Wie gesagt nur manche sind nicht anklickbar.

  • Das Problem der nicht-anklickbaren Pseudo-Hyperlinks tritt anscheinend häufig genug auf, dass ein Software-Entwickler schon eine Erweiterung dafür geschrieben hat: "Text Link" https://addons.mozilla.org/en-…nderbird/addon/text-link/
    Ich habe es getestet an dem Beispiel der in meinen screen shots gezeigten Nachricht, es funktioniert:
    Doppelklick auf einen in der Ansicht "Original HTML" nicht-anklickbaren Link und schon öffnet sich Firefox mit der verlinkten Seite ;)

  • Hallo,


    so wie ich das sehe ist das ein Problem, das beim Erstellen der E-Mail verursacht wird: Einmal wird der Link html-konform als richtiger Link in den Quelltext eingebunden:

    Code
    1. <a href="http://www.thunderbird-mail.de">http://www.thunderbird-mail.de</a>


    und dann passiert es auch manchmal, dass die URL lediglich als Text in den Quelltext geschrieben wird:

    Code
    1. http://www.thunderbird-mail.de


    Kann man sehen, wenn man Strg+u drückt.


    Wenn die Nachrichtenansicht auf "Original HTML" gestellt ist, wird nur der erste Link in Thunderbird "klickbar angezeigt", der zweite ist einfacher Text (passiert also nichts, wenn man drauf klickt).


    Vielleicht hilft das von Mapenzi verlinkte AddOn, das kenne ich nicht.


    Grüße, Ulrich

  • Zitat von "losgehts"

    Hallo,


    so wie ich das sehe ist das ein Problem, das beim Erstellen der E-Mail verursacht wird: Einmal wird der Link html-konform als richtiger Link in den Quelltext eingebunden:


    Vollkommen einverstanden ! ;)

    Zitat

    Kann man sehen, wenn man Strg+u drückt.


    Nicht unbedingt. Wenn ich z.B. für die obige Mail den Quelltext anzeige, dann gehen die Hyperlinks - ob sie nun HTML-konform eingebunde wurden oder nicht - völlig unter in einem Buchstaben/Zahlen-Salat und können nicht identifiziert werden.
    Der gesamte Inhalt (Text) der Nachricht sieht so aus:


  • Hallo Mapenzi,


    ja, da hast du natürlich recht. Ich hatte nicht an die mime-codierten emails gedacht.


    Toll, dass du das AddOn gefunden hast (habe es jetzt nicht ausprobiert). Das hilft hai2003 wahrscheinlich mehr, als meine Erklärungsversuche :top: .


    Grüße, Ulrich