Riesenproblem mit der Formatierung udn Schrfitdarstellung

  • Ich habe sein geraumer Zeit echte Probleme mit der Darstellung der Schrift und der Formatierung.
    (siehe angehängten Screenshot)


    Viele meiner Kunden beschweren sich immer wieder, dass meine Emails wie Kraut und Rüben aussehen.
    Das mysteriöse ist, dass nicht ale Mails so aussehen, sondern nur "die meisten" ....


    Die Umlaute werden nicht dargestellt, die Schriftgröße ist unterschiedlich, manchmal sind auch farbige Texte dazwischen,
    obwohl ich nie mit bunter Schrift arbeite......


    ich versuche dem entgegen zu arbeiten indem ich bevor ich ein Mail abschicke per Ansicht---> Zeichenkodierung den Text
    von Westlich auf Unicode ändere, meist haut es hin, oft aber auch nicht.


    Ich behelfe mich momentan damit, dass ich sämtliche Mails kopiere und als WORD-Datei richtig formatiert als Anhang mitliefere.
    Aber das geht so auf Dauer nicht....




    Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Thunderbird-Version: 31.5
    * Betriebssystem + Version: Mac OSX 10.5.9
    * Kontenart (POP / IMAP):
    * Postfachanbieter (z.B. GMX):

  • graba :


    Aber dann kann ich doch nicht das darstellen.
    Außerdem ist das MEINE geschäftliche Adresse,
    die kann ich gerne zeigen, das macht mir nix aus.


    Meine Email ist: post@doubles.de

  • Hallo,
    hast du das Problem auch, wenn du Nachrichten an dich selbst versendest, bzw mal in den Ordner "Gesendet" schaust?

    Zitat

    die Schriftgröße ist unterschiedlich, manchmal sind auch farbige Texte dazwischen,
    obwohl ich nie mit bunter Schrift arbeite......


    Zitat

    ich versuche dem entgegen zu arbeiten indem ich bevor ich ein Mail abschicke per Ansicht---> Zeichenkodierung den Text
    von Westlich auf Unicode ändere, meist haut es hin, oft aber auch nicht.


    Die Zeichenkodierung hatmit der reinen Formatierung nichts zu tun. Du könntest sie ja auch dauerhaft auf Unicode stellen, es wird sich aber vermutlich nichts ändern.
    Ich weiß nicht, ob dir klar ist, dass es einen Standard für HTML in Mails nicht gibt. Daher ist es in der Regel so, dass versendete Mails nur dann genauso aussehen wie man sie kreiert hat, wenn der Mailklient (und manchmal auch das BS) des Empfängers die gleichen sind. Es müsste also Thunderbird auf dem MAc verwenden. Alles andere ist Glücksache.
    Man kann im Quelltext (Strg+U) einer Mail meistens erkennen, von welchem Mailprogramm gesendet wurde.
    Dort steht dann z.B.

    Code
    1. X-Mailer: Microsoft Outlook 14.0


    oder

    Code
    1. User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20121026 Thunderbird/16.0.2


    Der von dir genannte Weg über einen Anhang scheint mir der einzige zuverlässige zu sein.
    Oder - und das sage ich nur ungern - du musst dir einen anderen Mailklienten aussuchen.

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Hallo,


    mich würde noch interessieren, wo der screen shot gemacht wurde: auf dem PC eines Empfängers oder auf deinem Mac, wenn du die gesendete Mail öffnest?
    Und welche Schriftart wurde beim Erstellen dieser Mail benutzt?


    Gruß

  • mrb :


    Vielen Dank, deien Antwort ist aufschlussreich aber frustrierend. ich wollte bewusst Outlook nicht nehmen, nun merke ich dass ich wojhl der Depp bin, dass ich so lange mit dem schönen TB gearbeitet habe.


    Nun ist nur die Frage, alles auf Outlook umbauen, wie bekomme ich meine 16.000 Kontakte dahin. ich habe alle Kontakte als ldif gespeichert udn auch schon Tests gemacht mit dem MoreFunctionsForAdressbook...... aber bin da noch nicht weiter gekommen.


    Ist das echt der einzige Weg??? Und wie mach ich es am besten? Weiß tdu da auch Rat?


    Oder noch besser: Gibt es in der Nähe von Mülheim/Ruhr jemanden, der mir gegen Bezahlung LIVE helfen könnte?

  • Mapenzi :
    ich arbeite seit 30 Jahren ausschließlich mit MAC.
    Als Schriftart verwende ich grundsätzlich im Web die VERDANA.

  • Als Schriftart verwende ich grundsätzlich im Web die VERDANA.


    OK.
    Trotzdem würde mich noch interessieren, ob du den oben gezeigten screen shot auf deinem Mac gemacht hast oder ob er auf dem Rechner eines Empfängers gemacht wurde. Mit anderen Worten: siehst du die fehlerhafte Darstellung von Umlauten auch in deinen gesendeten HTML-Mails?


    Ich schlage folgenden Test vor:
    bevor eine HTML-Mails abschickst, speichere sie zunächst als Entwurf ab und zeige sie dann über einen Klick auf "Bearbeiten" in einem neuen Verfassen-Fenster an, um zu überprüfen, ob dann auch die Umlaute wie in deinem screen shot dargestellt werden.
    Wir hatten hier kürzlich so einen Fall .... ;)

  • Mapenzi :


    Achso, na klar den habe ich bei mir gemacht, also auffem Mac.
    Ja ich sehe diesen text dann auch so.


    ich mach imemr folgendes (aus "Verzweiflung"):
    Wenn ich auf ein Mail antworte, ändere ich erst die Codierung in Unicode,
    dann sehe ich die Antwort meines Kudnen auf mein mail wieder ohne Fehler.
    Und hoffte, dass das Mal so bleibt ....
    aber offensichtlich wenn ich die Antwort verschickt habe, sieht mein Kunde das doch wieder falsch.
    (Das habe ich bemerkt, als mich mehrere Kunden auf das besch ..... Ansicht drauf aufmerksam gemacht haben)


    Test:
    Habe das Mail empfangen, da drin sehe ich die Fehler. (Siehe ersten Screenshot)


    Dann unkorrgiert an mich selbst verschickt Fehler sind geblieben (zweiter Screenshot)


    Dann in Unicode umgewandelt, dann an mich selbst zurückgeschickt (dritter Screenshot)
    jetzt ist kein Fehler drin aber andere Farben.

  • ZUr INfo:

    Zitat

    Wenn ich auf ein Mail antworte, ändere ich erst die Codierung in Unicode,


    Wo genau tust du das?


    Mich würde der Quelltext (Strg+U) der Mail mit den Farben interessieren, weil ich mir den HTML-code mal anschauen wollte.
    Könntest du einen kurzen Abschnitt hier posten, den von dem der Screenshot stammt?
    Verwende dabei den Tag "Code" (<>).
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw


  • Achso, na klar den habe ich bei mir gemacht, also auffem Mac.


    Wenn das bei dir schon so aussieht in der gesendeten Mail, dann kann es natürlich auch nicht bei den Empfängern korrekt dargestellt werden!


    Zitat

    Test:
    Habe das Mail empfangen, da drin sehe ich die Fehler. (Siehe ersten Screenshot)


    Das ist bei mir genau so, allerdings nur, wenn ich in Ansicht > Zeichencodierung "Westlich" wähle statt "Unicode" (siehe screen shot).
    Wenn ich eine solche Mail mit diesen komischen Zeichen weiterleite, wird wie bei dir der Fehler reproduziert.
    Bei mir steht die Zeichencodierung aber bei jedem TB-Start automatisch für alle Ordner auf Unicode, und damit habe ich schon lange keine Hieroglyphen mehr gesehen statt Umlauten.


    Vielleicht solltest du mal in den Einstellungen > Ansicht > Erweitert etwas mit den Zeichencodierungen spielen (Unicode statt Westlich) und dann testen, ob das Problem der beim Versenden von HTML-Mails falsch dargestellten Umlaute und Sonderzeichen weiterhin besteht.

  • @Mapenzi,


    ist das eine Besonderheit auf dem Mac?
    Es ist ja normalerweise so, dass man unt er "Ansicht" nicht die Mail bzw. die Zeichenkodierung in der Mail ändert sondern nur in der momentanen und temporären Darstellung.
    Ändern muss man dort sowieso nur etwas, wenn das Mailprogramm des Versenders falsch deklariert hat.
    Es sei denn, Thunderbird ist falsch eingestellt, und das geht nur noch mit Rechtsklick auf den Ordner > Eigenschaften > Allgemein dort darf für die Zeichenkodierung kein Haken gesetzt sein.
    Warum sollte aber ein Zusammenhang mit dem anderen Problem (Farbsetzung) bestehen? Kann ich eigentlich nicht glauben.
    Ein Problem kann allerdings richtig daraus entstehen, wenn geantwortet oder weitergeleitet wird, dass konnte ich aber aus dem Ausgangspost des TE nicht entnehmen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Super Idee, das hat geklappt.


    Aber ein witziger Nebeneffekt tritt jetzt auf:
    Alle, die vorher richtig waren, wurden durch die Umstellung auf Unicode anders, also falsch.
    Da muss ich eben per Hand zurück auf Westlich stellen.


    Ich werde ab Morgen mit der UNICODE- Voreinstellung mal arbeiten.
    Schaun wir mal ob das besser ist.


    Danke noch mal für die Tipps und schönen Abend.


    Jochen

  • Zitat

    Da muss ich eben per Hand zurück auf Westlich stellen.


    Das geht aber, wenn du das unter Ansicht änderst- wie ich schon schrieb - nur temporär. Beim nächsten Öffnen der Mail hast du wieder die ursprüngliche Kodierung.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • ist das eine Besonderheit auf dem Mac?
    Es ist ja normalerweise so, dass man unt er "Ansicht" nicht die Mail bzw. die Zeichenkodierung in der Mail ändert sondern nur in der momentanen und temporären Darstellung.


    Das ist auf dem Mac nicht anders, und wenn man für eine empfangene Mail die Zeichenkodierung geändert hat, wird sie nach TB-Neustart wieder in der Standard-Kodierung angezeigt.


    Zitat

    Ändern muss man dort sowieso nur etwas, wenn das Mailprogramm des Versenders falsch deklariert hat.


    Es wundert mich allerdings, dass bei Jochen die Benachrichtigungen von noreply@thunderbird-mail.de falsch dargestellt werden, während sie bei mir richtig angezeigt werden.


    Zitat

    Es sei denn, Thunderbird ist falsch eingestellt, und das geht nur noch mit Rechtsklick auf den Ordner > Eigenschaften > Allgemein dort darf für die Zeichenkodierung kein Haken gesetzt sein.


    Das müsste Jochen mal überprüfen.
    Meine Einstellungen in "Allgemein" sind unten im screen shot zu sehen.


    Zitat

    Warum sollte aber ein Zusammenhang mit dem anderen Problem (Farbsetzung) bestehen? Kann ich eigentlich nicht glauben.
    Ein Problem kann allerdings richtig daraus entstehen, wenn geantwortet oder weitergeleitet wird, dass konnte ich aber aus dem Ausgangspost des TE nicht entnehmen.


    Wenn ich den Ausgangspost richtig verstanden habe, entstehen die Probleme im Laufe eines Schriftwechsels.
    Das heißt, wenn er wie in seinem Beispiel mit der Benachrichtigungs-Mail vor dem Weiterleiten oder Antworten von Unicode auf Westlich umstellt, wird das Problem der Darstellung der Umlaute dann beim Empfänger auftreten, .... usw.
    Was die Schriftfarben in beantworteten oder weitergeleiteten Mails anbetrifft, muss man berücksichtigen, dass TB in Reintext die jeweiligen Antwort-Zitat-
    Blöcke in unterschiedlichen Farben darstellt (siehe screen shot).


    Im selben Zusammenhang: ich habe noch nie verstanden, warum bei mir das automatische Erkennen der Zeichenkodierung deaktiviert ist!

  • Zitat

    Meine Einstellungen in "Allgemein" sind unten im screen shot zu sehen.


    So sollte die Einstellung auch sein. Ist der Haken dort gesetzt, kann Thunderbird die richtige Zeichenkodierung nicht mehr erkennen.

    Zitat

    Das heißt, wenn er wie in seinem Beispiel mit der Benachrichtigungs-Mail vor dem Weiterleiten oder Antworten von Unicode auf Westlich umstellt, wird das Problem der Darstellung der Umlaute dann beim Empfänger auftreten, .... usw.


    Eigentlich sollte man das nicht machen, sondern in dem charset antworten, wie ihn der Absender eingestellt hat.

    Zitat

    Im selben Zusammenhang: ich habe noch nie verstanden, warum bei mir das automatische Erkennen der Zeichenkodierung deaktiviert ist!


    Ist sie nicht. In frühere Versionen war das Menü auch anders und besser verständlich.
    Das automatische Erkennung bezog sich darauf, wenn eine Mail mit 2 unterschiedlichen Zeichensätzen geschrieben wurde. Thunderbird hat dann beide erkannt und richtig dargestellt. Wie gesagt, das war einmal so und ob das noch heute so funktioniert, weiß ich nicht. Das ist kaum zu testen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • es ist echt zum verzweifeln..


    Egal wie ich das in den Einstellungen einstelle, es sieht bei fast jedem Mail anders aus.


    Muss ich mich echt nach langen langen glücklichen Jahren von TB verabschieden, oder gbt es eine Lösung????


    In den Einstellungen hab ich das umgestgellt.....
    Nutzt nix, da ist dann ein Mail was richtig aussieht, das nächste schaut schon weider anders aus.....


    Dann stelle ich in Mail direkt um. z.B. von westlich auf Unicode. oder andersrum
    Auch da schaut ein Mail ok aus, das nächste schon wieder nicht.


    Schriftgröße unetrschiedlich..... Umlaute sichtbar oder auch mal nicht .....


    Ich schreib schon in jedes Mail und lege ne Datei als Anhang bei:
    Sollte die Formatierung dieses Mails nicht richtig sein, nutzen Sie die WORD-Datei die ich als Anhang
    mitgeschickt habe.


    und wie das beim kunden aussieht ..... ich möchte es gar nicht wissen....wie peinlich.

  • Zitat

    Nutzt nix, da ist dann ein Mail was richtig aussieht, das nächste schaut schon weider anders aus.....


    Zitat

    Dann stelle ich in Mail direkt um. z.B. von westlich auf Unicode. oder andersrum


    Wenn das unter "Ansicht" geschieht, ist das Verhalten absolut normal, da hier nur temporär für die gerade markierte Mail umgestellt wird. BEi einer anderen Mail beginnt dann das Spiel von vorne.
    WIe du es beschriebst, ist das typisch für falsche Einstellungen in Thunderbird.
    Zunächst entferne den unteren Haken, den ich im Screenshot sehe. Man zwinbgt dem Versender nicht deine eigene Zeichenkodierung auf.
    1) öffne die erweiterte Konfiguration (Extras > Einstellungen > Erweitert > Allgemein > "Konfiguration bearbeiten")
    und gibt indas obige Suchfeld mailnews.force_charset_override ein, der Wert muss auf "false"(!) stehen-.
    2) Überprüfe unter Extras > Einstellungen > Ansicht > Formatierung > Schriftarten > Erweitert, ob du für Westlich und Unicode (im Dropdownmenü ganz oben auswählen) die gleichen Schrifteinstellungen hast.
    3) Dann kontrolliere alle beteiligten Ordner mit Rechtsklick > Eigenschaften > Allgemein, ob dort im unteren Kästchen evtl. ein Haken gesetzt ist. Das darf er nicht.


    Und wenn diese Maßnahmen keinen Erfolg bringen, ist dein Profil verstellt/beschädigt und du solltest ein neues anlegen, denn darin werden nur die Orignaleinstellungen verwendet.
    4 Ein neues Profil erstellen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • mrb :
    WHOUWW !!!!!!!!!


    Mensch war diese Abhandlung gut!
    ich habe alles nach deinen Vorgaben überprüft.
    Es waren tatsächlich etliche Einstellungen anders als du beschrieben hast.


    Neustart gemacht und siehe ...... alle Mails sehe jetzt normal aus.


    Was soll ich dazu sagen?
    DU HAST DIR NEN BIERCHEN VERDIENT!


    Nochmals vielen Dank an dich und auch an alle anderen,
    das hier ist echt ein sinnvolles und hilfreiches Forum.


    D A N K E !!!!


    Gruß Jochen

  • Noch was:


    Sag mal, wieso ist denn TB sooo umständlich und kompliziert aufgebaut?
    Da kommt doch ein normaler User wie ich nie richtig klar, wenn es nicht solche Spezis wie euch geben üwrde.


    Oder sind andere Mailclients auch so umständlich zu programmieren??


    Was ist an TB denn so besonders oder so anders, dass solche grundsätzlichen Einstellungen
    so falsch gemacht werden können....???


    Denn als ich TB installiert habe, habe ich nie (bewusst) irgendwo was (falsch) umgestellt.