TB lädt immer und sofort ALLES von Imap-Konto runter - Einstellungen egal...



  • * Thunderbird-Version: 45.4.
    * Betriebssystem + Version: Win 7 prof 64 bit
    * Kontenart (POP / IMAP): IMAP
    * Postfach-Anbieter (z.B. GMX): 1&1
    * Eingesetzte Antiviren-Software: KAS
    * Firewall (Betriebssystem-intern/Externe Software):
    * Router-Modellbezeichnung (bei Sende-Problemen):


    Hallo, ich habe keine Ahnung, ob ich hier richtig bin, aber ich komme einfach nicht weiter. Auch tagelanges Googlen hat leider keine Antwort für mich. Das Problem: TB lädt immer alles von einem IMAP-Konto automatisch herunter, also ganze Mail und auch Anhänge. Dabei dachte ich, die Einstellungen so vorgenommen zu haben, damit das erst bei Anklicken der Mail passiert. Nun lädt TB aber schon bei Abruf alles runter.


    Ich habe:alle

    • Haken weg beim Benachrichten von Nachrichten
    • Haken bei "Nachrichten auf diesem Computer bereithalten" weg
    • Allerdings dann bei "erweitert" den Haken mal bei Posteingang gesetzt, dann auch wieder nicht, keine Änderung
    • Haken bei "Nachrichten unabhängig vom Alter runterladen" gesetzt (gar keine Haken setzten geht hier ja nicht)

    Ich hätte gern, dass TB die Mail nur bei manuellem Abruf anzeigt (Header) und dann erst beim Anklicken dieses Headers die Mail runterlädt. So könnte ich sie ohne vorher runterladen zu müssen mit Rechtklick löschen (Spam). Also eigentlich das, was Grundeinstellung von IMAP ist/sein sollte. Was mache ich da falsch?


    Wäre toll, wenn mir da jemand helfen könnte!


    Vielen Dank!

  • Hallo und willkommen im Forum!
    Das von dir beobachtete Verhalten ist untypisch für IMAP und Thunderbird, wenn du - und das hast du ja - das "Bereithalten von Nachrichten" deaktiviert hast.
    Klickt man also auf den Posteingangsordner (oder auch auf "alle abrufen"), werden dir nur die neuen Header heruntergeladen mehr nicht. Die Mail mit Anhang erfolgt dann erst auf einen Klick auf den betr. Header. Aber selbst, wenn das "Bereithalten von Nachrichten" aktiviert wäre, dürften zunächst nur die Header heruntergeladen werden.
    Es sei denn, du hast gar kein IMAP-Konto sondern POP, dort werden immer alle Mails bei Abruf heruntergeladen. Überprüfe daher die Kontoart in den Konten/Servereinstellungen unter "Servertyp" (im rechten Fenster links ganz oben) noch einmal.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    vielen Dank für Deine Antwort! Ich sehe das auch so, sehr ungewöhnlich, so sollte es ja gerade nicht sein. Aber es ist definitiv ein IMAP-Konto, die Einstellung lautet "Servertyp IMAP" und der Server "imap.1und1.de". Siehe auch Anhänge. Dass TB immer alles und sofort ungefragt runterlädt merke ich daran, dass mein "speedmonitor" den Download-Verkehr anzeigt. Außerdem ist dann die Email auch mit großem Anhang sofort da, wenn ich draufklicke. Da lädt also nicht erst noch was runter.





    Ich werde jetzt mal das ganze Konto löschen und neu anlegen. Mal sehen was dann passiert.


    Lieben Dank!

  • Nach dem Entfernen des IMAP-Kontos, lösche auch die entspr. Konten-Ordner im Thunderbird-Profil\ImapMail. Da wird sich nämlich ganz schön viel Müll angesammelt haben, weil du ja davor das "Bereithalten von Nachrichten" noch aktiviert hattest.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • So, alles gemacht: Konto gelöscht, Imap-Ordner in "q01m4y3o.default" (so heißt der bei mir) gelöscht, Konto neu eingerichtet. Resultat: Gleiches Phänomen.


    Ich habe inzwischen auch mal einen Freund gefragt, wie das bei ihm ist. Gar nicht so leicht, überhaupt jemanden zu finden, der sich wenigstens ein klein bißchen damit auskennt. Er dachte, bei ihm laufe alles richtig, die Mail seines IMAP-Kontos würden erstmal nicht runtergeladen, erst recht keine Anhänge. Bis........ja bis ich ihn fragte, ob er mal den Speedmonitor installieren könnte, um zu sehen, ob da Traffic ist. Und siehe da, auch bei ihm lädt TB sofort ungefragt alles runter, und das nicht erst beim Abfragen, sondern ganz unaufgefordert.


    Langsam glaube ich, ich habe etwas grundsätzlich mißverstanden. Wenn ich doch erheblichen Download-Traffic im Speedmonitor sehe, sobald ich mir selbst oder sonst wer eine Mail auf das Imap-Konto geschickt hat, ohne dass ich irgend etwas gemacht habe und die Mail samt Anhang, egal wie riesengroß, sofort da ist, wenn ich sie anklicke, heißt das doch, dass sie vorher runtergeladen wurde. Genau das soll ja nicht sein. Wo ist mein Denkfehler?


    Nochmal herzlichen Dank für den Versuch einer Klärung, es kann doch nicht so schwer sein...


    Grüße!

  • Hallo zusammen,
    so wie ich das verstehe werden bei IMAP die Mails sofort wenn sie auf dem Server ankommen zu Thunderbird geschickt.
    Das ist bei mir auf dem Smartphone genau so, ich brauchen nicht auf herunterladen klicken, sondern sie werden sofort angeboten.
    Ob dabei direkt alles herunter geladen wird weiß ich nicht, aber man kann ja eine Größe angeben ab wann die Mails nicht mehr herunter geladen werden.


    Es gibt auch einen Namen für diese Funktion, leider fällt er mir im Moment nicht ein.
     
    Gruß
     EDV-Oldi

  • Hallo,

    So, alles gemacht: Konto gelöscht, Imap-Ordner in "q01m4y3o.default" (so heißt der bei mir) gelöscht, Konto neu eingerichtet. Resultat: Gleiches Phänomen.

    Ich schlage vor, dass du einen Test in einem neuen Profil durchführst, in dem du nur das betreffende IMAP-Konto einrichtest und sofort in den Konten-Einstellungen > Sync & Speicherplatz das Bereithalten der Nachrichten auf dem Computer deaktivierst. Dann müsstest du eine Mail mit einem Anhang von mehreren MB an diese Adresse schicken und unten in der Statusleiste beobachten, was nach dem Empfang passiert.


    Ich habe eben mal einen Test durchgeführt, indem ich eine Mail mit einem Anhang von ungefähr 6 MB an mein IMAP-Konto gesendet habe, in dem das Bereithalten auf dem Computer und der automatische Abruf beim Start sowie alle x Minuten deaktiviert sind.
    Beim Start von TB im Profil mit diesem IMAP-Konto wurde diese Testmail sofort in der Nachrichten/Themenliste angezeigt. Als ich auf diese Mail klickte, wurde sie im Nachrichten- (oder Vorschau-) Bereich geöffnet, und ich konnte anhand des blauen Ladebalkens in der Statusleiste sehen, dass das Laden des Anhangs ungefähr 5 Sekunden in Anspruch nahm (bei einer Download-Geschwindigkeit von ungefähr 17 Mbit/sec meiner ADSL-Verbindung).
    Das Ergebnis entspricht also dem, was ich erwartet hatte.



    Gruß

  • Hallo,


    ich habe ebenfalls gerade ein paar Tests durchgeführt. Mein Ergebnis entspricht dem, was auch Mapenzi bereits berichtet hat. Ist das Bereithalten aktiviert, wird die E-Mails automatisch nach dem Push komplett heruntergeladen. Habe ich das Bereithalten deaktiviert, werden nur die Header geladen.


    Ich habe zwar keinen Speedmonitor aber den Ladebalken im TB und vor allem einen Switch auf dem Schreibtisch, der mir eindeutig anzeigt, ob Daten fließen oder nicht.


    Gruß


    Susanne

  • Hallo allerseits,


    so, ich habe Neuigkeiten. Danke für den Tipp, doch mal ein neues Profil anzulegen. Wahrscheinlich war das zwar nicht die direkte Lösung, sie hat mich aber dahin geführt. Ich habe also ein neues Profil angelegt, ganz rein und clean, ohne Plugins etc. und siehe da, das IMAP-Konto verhielt sich plötzlich wie es soll. Dann habe ich in diesem neuen Profil die Plugins nacheinander installiert. Mit Theme & Font-Changer ging noch alles. Auch mit der Einfach-Version von Send-later-Button. Dann aber, nach Installation des Magic SLR passierte es: TB lädt wieder sofort alles runter, lediglich durch Anklicken des Posteingangs, also nicht erst bei Klick auf die Nachricht (Header).


    Ich weiß nicht, ob es der enizige Grund für dieses Verhalten war bzw. ist, aber da muss der Fehler liegen. Manche Plugins bzw. die Kombination dieser scheint das Prinzip eines IMAP-Kontos ad absurdum zu führen. Ich wusste das nicht und ich denke, so geht es vielen. Vielleicht hilft diese Information ja dem einen anderen bzw. vielleicht können sich die Programmierer diesem Problem mal annehmen. Bis dahin verzichte ich auf Magic SLR (was ich auch nur für den Button "Alles senden" meinte zu brauchen) und kann in einem neuen Profil meine Email-Konten ab jetzt hoffentlich IMAP-konform einrichten.


    Allen hier im Forum ganz herzlichen Dank für Euer Engagement!


    Liebe Grüße!

  • Hallo Gwetschgenmark,


    Bis dahin verzichte ich auf Magic SLR (was ich auch nur für den Button "Alles senden" meinte zu brauchen) und kann in einem neuen Profil meine Email-Konten ab jetzt hoffentlich IMAP-konform einrichten.


    dazu folgender Lektüre-Hinweis: Abrufen/Senden-Schaltfläche (reduziertes MagicSLR). Dort den Kasten Hinweis beachten.


    Gruß
    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • Manche Plugins bzw. die Kombination dieser scheint das Prinzip eines IMAP-Kontos ad absurdum zu führen.

    Eine kurze Klarstellung: es handelt sich nicht um "Plugins" sondern um "Erweiterungen".
    Im Gegensatz zu Plugins werden Erweiterungen im Profil von TB installiert und gespeichert.