Es werden keine Anhänge angezeigt bei Ansicht 'Reiner Text'

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: Problem entdeckt bei V60.3.1, keine Besserung nach Aktualisierung auf V60.4.0
    • Betriebssystem + Version: Win10 Pro (1809)
    • Kontenart (POP / IMAP): IMAP
    • Postfach-Anbieter (z.B. GMX): vivaldi.net
    • Eingesetzte Antiviren-Software: Windows Defender
    • Firewall (Betriebssystem-intern/Externe Software): intern
    • Router-Modellbezeichnung (bei Sende-Problemen): (Fritz!Box 7590 mit FritzOS 7.01)
    • Ansichteinstellung (Menü Ansicht --> Nachrichteninhalt): Reiner Text


    Hallo,


    in einem erst seit kurzem aktiv genutzten IMAP-Konto werden Anhänge weder in der Auflistung der Mails noch unten in der Mail selber angezeigt. Das fiel mir gestern erstmals auf, weil ein im Text erwähnter Anhang nicht dabei zu sein schien. Gerade habe ich den TB von vorher Version 60.3.1 auf V60.4.0 aktiviert, aber das Problem besteht unverändert.


    Ich lasse alle Mails aller Konten (derzeit 12, davon 3 POP3 und 9 IMAP) seit Jahren als "Reiner Text" anzeigen. Änderung dieser Einstellung zu "Vereinfachtes HTML" und auch zu "Original HTML" (und anschließender TB-Neustart) ändert dieses Verhalten und etwaige Anhäge werden wieder ausgewiesen, allerdings erst bei Auswahl einer betroffenen Mail in der Liste und nicht einfach so bei Öffnen des Mailordners.

    Zurückschalten auf "Reiner Text" entfernte ohne Neustart das Büroklammersymbol bei der gerade aktiven Mail und nach Neustart auch bei jeder anderen, wenn man sie auswählt.


    Installiert ist u.a. Thunders AddOn "Allow HTML Temp" (*): Klicke ich bei markierter Mail dort drauf, wird der Anhang an beiden erwähnten Stellen sofort (wieder) angezeigt - und bei Doppelklick retour. Alles sehr seltsam.

    Vor allem ist das verunsichernd, denn wenn ich bei Rein-Text-Anzeige bleibe, kann ich ohne Blick auf die Größe der Mail (die Spalte blende ich immer ein) und ohne Test nie sicher sein, ob mir ein vorhandener Anhang "unterschlagen" wird.


    Weitere AddOns:

    - CardBook

    - CompactHeader

    - Display Mail User Agent

    - DKIM Verifier
    - Enigmail

    - Get/Send-Button

    - Lightning


    Zum Thema gefunden habe ich bereits den Thread Anhänge werden sporadisch nicht angezeigt, dessen letzter Eintrag dasselbe Problem beschreibt. Eine Lösung wurde seinerzeit leider nicht gefunden.


    Noch ein Detail: Sämtliche betroffenen Anhänge sind DOCX-Dateien. Vor 2 Wochen kamen auf dem Konto Mails mit angehänten ZIP-Dateien an, die durchaus angezeigt wurden (mit V60.3.1 auf Win10 1803). Ich teste eben über kreuz, ob und bei welcher Einstellung diese ZIP-Anhänge nun auch verschwinden oder wieder auftauchen, aber das hat mir den kleinen grünen Statusbalken (Laden von Nachrichten) in einen minutenlangen wilden Tanz versetzt, so dass ich da weder verlässlich noch zeitnah berichten kann :-/
    Kurzform: auch die ZIP-Anhänge scheinen in gleicher Weise vom Problem betroffen zu sein und werden je nach Einstellung "gemeldet" oder eben nicht. Damit hängt es wohl nicht am Dateityp des Anhangs.


    Als Workaround wechsele ich jetzt erstmal zur Anzeige "Vereinfachtes HTML" für den Nachrichtentext. Aber wie und warum das auch auf die Darstellung der Ordnerinhalte wirkt, verstehe ich nicht.


    Vielleicht hat jemand eine Idee oder gar Lösung, denn ich mag die "ruhigere" einheitliche Anzeige des Textmodus´, wenn nicht jeder Hugendubel mir seine manchmal kruden Ideen zur Textgestaltung (riesige Buchstaben, schreiende Farben, geringer Kontrast, unmotivierte Einrückungen/Textausrichtungen usw.) aufdrängeln kann. Allein die tägliche GMX-Spamverdachtmail ist in HTML schon viel unübersichlicher und ein paar andere testweise geöffnete Mails im gleichen Account ebenfalls :-/
    Andere Accounts fasse ich jetzt noch nicht an, sonst brauche ich eine riesige Testmatrix und die präzise Beschreibung könnte ebenfalls ...... spannend werden.


    MfG

    Drachen



    *) unverzichtbar vor allem bei ebay-Mails: die sind im Textmodus einfach nur komplett leer, weil die ***** keinen ReinText-Teil generieren und mitschicken.

  • Hallo Drachen,


    ich habe leider genau das gleiche Problem, ungefähr seit der gleichen Zeit. Bei mir betrifft es nicht nur docx, sondern auch pdf.

    Aufgefallen ist mir noch, dass diese unsichtbaren Anhänge immer von Apple-Usern geschickt werden.

    Seitdem arbeite ich gezwungenermaßen auch in der HTML-Ansicht X(

    Wenn es da was Neues gäbe, würde mich das interessieren!


    Grüße,

    Rut

  • Hallo zusammen,


    ich würde zunächst die Erweiterung Allow HTML Temp installieren.

    Das ändert zwar jetzt nichts an Eurem bestehenden Problem, bringt aber den Vorteil, dass Ihr weiterhin im Rein-Text-Modus arbeiten könnt und per Schalter nur bei tatsächlichen Bedarf auf eine HTML-Ansicht umschalten müsst.


    Gruß

    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • Hallo,

    Aufgefallen ist mir noch, dass diese unsichtbaren Anhänge immer von Apple-Usern geschickt werden.

    Weißt du auch, welcher E-Mailclient von diesen Apple-Usern benutzt wird?

    Thunderbird?

    Apple Mail?

    Ein anderes Programm?


    Gruß

  • Hallo Feuerdrache, wie geschrieben nutze ich das doch längst ...


    Hallo Rut_May, interessante Beobachtung, werde ich verfolgen. Das AddOn ‚Display Mail User Agent‘ zeigt die Clients der Absender meistens an .. :-)



    MfG

    Drachen

  • ich würde zunächst die Erweiterung Allow HTML Temp installieren.

    Das ändert zwar jetzt nichts an Eurem bestehenden Problem, bringt aber den Vorteil, dass Ihr weiterhin im Rein-Text-Modus arbeiten könnt und per Schalter nur bei tatsächlichen Bedarf auf eine HTML-Ansicht umschalten müsst.

    Mit der Erweiterung habe ich früher vor dem Auftauchen des Problems gerne gearbeitet. Jetzt aber nützt es nicht viel, weil ich dann jede Mail mit Klick auf den Allow HTML - Button kontrollieren muss, ob vielleicht ein Anhang da ist. Am meisten stört mich, dass in der Listenansicht die Klammer "nach Anhängen sortieren" fehlt.

    Weißt du auch, welcher E-Mailclient von diesen Apple-Usern benutzt wird?

    Die benutzen alle Apple Mail.

    Ansonsten bin ich wirklich sehr zufrieden mit dem TB, dieser bug allerdings nervt, v.a. weil es ja früher gut funktioniert hat...


    Viele Grüße,

    Rut

  • Hallo Rut_May ,


    dieser bug allerdings nervt

    ich kann keinen Bug feststellen!


    Sende Dir selbst eine Mail mit verschiedenen Anhängen, .docx und .pdf-Dateien, mit welchem Ergebnis?


    Viel Glück

    Herbert


    PS: Add-on u.a. 'Allow HTML Temp' und 'Display Mail User Agent'

    Windows 7 Pro (64-bit)

    Thunderbird 60.8.0 (64-bit) - Einstellung 'Reintext'

  • Hallo,

    Frage zur Info:

    wird denn unter Ansicht->Nachrichteninhalt bei "alle Teile des Inhalts" etwas angezeigt?

    Und im Quelltext (Strg+U) der Mails sind die Anhänge deutlich als sehr viele Reihen verschiedenster Zeichen zu erkennen.

    Poste die Deklaration einer solchen Mail.

    Die sieht etwa so aus:


    Sieht der bei dir ähnlich aus?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ansicht->Nachrichteninhalt bei "alle Teile des Inhalts"

    Das habe ich gar nicht, nur Original/Vereinfachtes HTML und Reiner Text


    Ich versuche mal, die entsprechenden Zeilen einer Mail mit unsichtbarem Anhang zu posten:


  • Das habe ich gar nicht, nur Original/Vereinfachtes HTML und Reiner Text

    Normalerweise wird "alle Teile des Inhalts" gar nicht angezeigt im Menü Ansicht > Nachrichteninhalt.

    Dazu muss man erst im Konfigurations-Editor den Wert der Einstellung "mailnews.display.show_all_body_parts_menu" von "false" auf "true" umstellen.

  • @rut-May,

    groß ist der Unterschied bei mir nicht:


    Code
    1. This is a multi-part message in MIME format.
    2. --------------5F9AA9C88225EFEF7D12B727
    3. Content-Type: text/html; charset=utf-8
    4. Content-Transfer-Encoding: 7bit
    5. --------------5F9AA9C88225EFEF7D12B727
    6. Content-Type: application/vnd.openxmlformats-officedocument.wordprocessingml.document; name="xxx Begleitschreiben.docx"
    7. Content-Transfer-Encoding: base64
    8. Content-Disposition: attachment; filename="xxx Begleitschreiben.docx"

    Bis auf das Content-Transfer-Encoding, welches bei dir "quoted printable" ist. Das aber dürfte nur eine Auswirkung auf die Lesbarkeit haben, nicht auf die Anhänge.

    Aber "x-unix-mode=0644;" könnte Verursacher sein. Da ich keinen Mac habe, aber eher spekulativ.

    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Mapenzi ,


    jetzt erinnere ich mich wieder, das geändert zu haben, es gab ja in einer kurzen Periode bei einer bestimmten Version Probleme mit den Anzeigen der Anhänge und es wurde empfohlen, den Eintrag zu ändern. Danke!

    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ich habe als Test mit Apple Mail mehrere Nachrichten mit verschiedenen Anhängen (JPEG, MP3, PDF) gesendet und auf dem selben Mac in Thunderbird empfangen.

    In allen in Thunderbird empfangenen Mails sind die Anhänge sichtbar.

    Hier Auszüge aus den Quelltexten:


    Audio Datei:



    PDF Datei:



    JPEG Datei:


  • Mit deaktivierten Addons im abgesicherten Modus noch mal getestet, das Problem ist immer noch da.

    Ca. 40 betroffene Apple-Mails enden im Quelltext so:

    HTML: Unsichtbare Anhänge
    1. <html><head><meta http-equiv="Content-Type" content="text/html; charset=us-ascii"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class=""><div style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class=""><div class=""><div class=""></div></div></div></body></html>
    2. --Apple-Mail=_2ABE6ED1-4B74-48CF-9601-9968B4BDFB29--
    3. --Apple-Mail=_BB01B598-8C92-4206-8D82-21FA612A2AD6--

    2 Emails von denselben Sendern zeigen seltsamerweise die Anhänge an, diese enden ohne HTML-Code, einfach nur mit

    --Apple-Mail=_40EC363D-6EDB-4D55-8192-C89C030F401A----


    Aber ob das eine Bedeutung hat... Ansonsten ist mir nichts weiter aufgefallen, wobei das keine große Bedeutung hat, ich kenne mich da gar nicht aus.

    Meine Windowsinstallation hier ist inzwischen schon 8 Jahre alt, da wird halt irgendwas kaputtkonfiguriert worden sein. Euch jedenfalls vielen Dank für die Anteilnahme!


    Viele Grüße,

    Rut


    ps: Den TB einfach mal neu drüberzuinstallieren ohen anschließende Einstellungsorgie sollte doch gefahrlos möglich sein, oder?

  • Den TB einfach mal neu drüberzuinstallieren ohen anschließende Einstellungsorgie sollte doch gefahrlos möglich sein, oder?

    Die selbe Version von TB einfach "drüber zu bügeln" birgt überhaupt keine Gefahr, ändert aber auch nichts in gefühlten 95% aller Fälle, da das Problem sich in den weitaus meisten Fällen im Profil befindet und nicht im Programm selber.

    Der definitive Test ist also der in einem neuen, jungfräulichen Profil, ohne irgend etwas aus dem alten Profil zu importieren bzw. wieder zu verwerten.

  • Rut_May

    und

    Drachen


    wenn ihr möchtet, könntet ihr mir ein paar dieser Mails an meine Mailadresse für diese Zwecke weiterleiten. Die Mailadresse poste ich euch, wenn ihr mir eine kurze Nachricht per Konversation schicken würdet.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • mrb : ich komme gern drauf zurück, wenn mir wieder so eine Mail auffällt und der Anhang nicht gerade eine Rechnung o.ä. ist :)


    Ich hatte das seit dem letzten Dezember etwas aus den Augen verloren, nachdem es sieben Monate lang keine Antwort gab - deswegen weiß ich auch nicht mehr, welche Mails seinerzeit betroffen waren, und kann auch nicht gezielt nachsehen, ob deren zum Versenden genutzter Client angezeigt wird.


    MfG

    Drachen

  • Hallo,


    meines Wissens sendet Apple Mail standardmäßig Anhänge eingebunden.


    Fotos gesendet mit iphone Mail als User Agent, im Quelltext steht Apple Mail.

    Mit dem Add-on Allow HTML Temp:

    Original HTML: Im Nachrichtenbereich wird die Klammer (Anhang) nicht angezeigt, da die Fotos in der Mail eingebunden vorhanden und nur per Rechtsklick Grafik speichern unter möglich ist.

    Reiner Text: Die Klammer wird angezeigt und Alle speichern


    Das Verhalten mit anderen Anhängen, wie .docx-Dateien ist mir nicht bekannt.


    Gruß

    Herbert