Thunderbird Link zu verschiedenen Firefox Profilen senden

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 60.4.0
    • Betriebssystem + Version: Windows 10 Pro 64 bit
    • Kontenart (POP / IMAP): beides
    • Postfach-Anbieter (z.B. GMX): mail.de
    • Eingesetzte Antiviren-Software: Antivir
    • Firewall (Betriebssystem-intern/Externe Software): Windows Firewall
    • Router-Modellbezeichnung (bei Sende-Problemen): Kabelrouter

    Ich benutze Firefox mit zwei Profilen. Eines privat, das andere beruflich. Von Thunderbird aus möchte ich meine Emaillinks wahlweise zum privaten oder beruflichen Profil senden.


    Ich nutze schon dies hier: http://kb.mozillazine.org/Chan…e_web_browser_invoked_by_ (siehe Screenshot) um Links aus Emails an verschiedene Browser zu senden.

    Gibt es eine Möglichkeit dieses Tool so zu ändern, das es auch die Links zu verschiedenen Firefox Profilen sendet?

  • Hallo,

    ich habe auch mehrere FF-Profile, die ich aber über mehre Deskto- Icons aufrufe, indem ich die Verknüpfung über Rechstklick > Eigenschaften aufrufe in der oberen Zeile nach einem Leerzeichen -p [profilname] anfüge. Vielleicht klappt das ja auch so mit deinem Add-on.

    Den Profilnamen entnimm aus der Datei profiles .ini

    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ja, ich habe mir zwei Desktop Icons von Firefox erstellt, eins so wie du beschrieben hast und umbenannt, das andere Profil auch.


    Aber der "network.protocol-handler" reagiert nicht auf unterschiedliche Profile.


    Ich habe den dem kleinen Fenster (siehe Screenshot #1) "andere Anwendung auswählen" gedrückt und habe das Firefox Desktop Icon ausgewählt, welches ich als Standardprofil beschriftet habe, wählte ich das zweite Profil aus, sendete Thunderbird den Link trotzdem zum Standard Profil.


    Übrigens handelt es sich hierbei nicht um ein Addon, sondern um eine Änderung in den Thunderbird about:config Einstellungen:


    Ich habe "network.protocol-handler.warn-external.http" und "network.protocol-handler.warn-external.https" auf true gesetzt, um die Links aus Emails an verschiedene Browser zu schicken. (siehe Screenshot)


    Ich habe mir das anhand des Mozilla Knowledge Artikels erarbeitet, welchen ich unter #1 verlinkt habe.

  • anhand des Mozilla Knowledge Artikels

    Hallo :)


    zu Deiner Info: mozillaZine ist wie dieses Forum kein offizielles Angebot von Mozilla.

    Gibt es eine Möglichkeit dieses Tool so zu ändern, das es auch die Links zu verschiedenen Firefox Profilen sendet?

    Hast Du es einmal wie im Abschnitt "OpenWith" beschrieben versucht?

    If you wanted to use profile XYZ you'd enter -P XYZ -no-remote as the command line arguments.

    HTH

    Gruß Ingo

  • Ja, ich habe es auch mit Open With probiert, auch dieses Addon erkennt meine verschiedenem Profile nicht.


    Edited once, last by stardepp ().

  • [Open With]

    auch dieses Addon erkennt meine verschiedenem Profile nicht.

    Hallo :)


    hm, Du hast aber schon, wie im Artikel beschrieben, im Addon für jedes Profil einen entsprechenden Eintrag angelegt?


    Gruß Ingo

  • Quote

    Hallo :)


    hm, Du hast aber schon, wie im Artikel beschrieben, im Addon für jedes Profil einen entsprechenden Eintrag angelegt?


    Gruß Ingo



    Ja, ich habe in "Öffnen mit" beide Profile versucht einzufügen, aber dieses Addon übernimmt die Profile leider nicht.



    Edited once, last by graba: Zitat überarbeitet ().


  • Jetzt habe ich es gefunden. Aber der Link öffnet nur das richtige Profil, wenn Firefox geschlossen war. Ist Firefox geöffnet kommt eine Fehlermeldung:





    Wie kann dann also ein Link von Thunderbird im geöffneten Firefox senden, ohne das diese Fehlermeldung erscheint?

  • Aus dem Bauch heraus würde ich ja sagen, dass Firefox dies selbst "abfangen" müsste. Wenn das gewünschte Profi schon offen ist, dann soll es halt weiter benutzt werden. Was passiert denn eigentlich wenn Firefox mit Profil "A" offen ist und jetzt ein Link mit Profil "B" geöffnet werden soll? Geht dann eine zweite Instanz von Firefox auf, in der Profil "B" genutzt wird?

  • Ist Firefox geöffnet kommt eine Fehlermeldung

    Hallo :)


    logisch, Deine Befehlszeile ist doch völlig falsch. Wie kommst Du denn darauf? Der KB-Artikel sagt doch ganz eindeutig

    If you wanted to use profile XYZ you'd enter -P XYZ -no-remote as the command line arguments.

    In Deinem Fall wäre das also für die beiden Profile aus Deinem Screenshot

    Code
    1. -P default -no-remote

    (ist das das berufliche Profil?) bzw.

    Code
    1. -P "Tom privat" -no-remote

    Ich gehe dabei jetzt davon aus, dass Du "Tom privat" wegen des Leerzeichens in Anführungszeichen setzen musst. Selbst ausprobiert habe ich das aber nicht. Die Anführungszeichen sollten zumindest nicht schaden.

    Wie kann dann also ein Link von Thunderbird im geöffneten Firefox senden, ohne das diese Fehlermeldung erscheint?

    Indem Du die Befehlszeile, d.h. die Parameter richtig angibst. Das hat übrigens nichts mit dem Addon zu tun. Genauso müsste die Befehlszeile auch in einer Verknüpfung oder bei Start - Suchen bzw. Ausführen (Win-R) aussehen, siehe z.B. den Artikel Command line arguments.


    Gruß Ingo

  • Indem ich bei dem Befehl Anführungszeichen setze ändert sich nichts. Wenn Firefox Profil A geöffnet ist, dann kann ich mit dem Link aus Thunderbird Firefox Profil B öffnen, ohne Probleme.


    Aber ich möchte ja auch gern Links aus Thunderbird zu Firefox Profil B senden können, wenn Firefox Profil B schon geöffnet war.

    Edited once, last by stardepp ().

  • Die Option -no-remote deaktiviert bei Thunderbird wie auch bei Firefox die Möglichkeit, eine bereits laufende Anwendung zu erkennen oder mit ihr zu interagieren. Ein so gestartetes Browserfenster kann also von anderen Prozessen aus keine Links empfangen. Das ist unabhängig von der Methode, mit der der Prozess gestartet wird.


    Siehe Dokumentation:

    Quote

    -no-remote

    Do not accept or send remote commands; implies -new-instance. [...] instances created with this parameter do not accept or send remote commands [...]. That means that such instances won't be re-used. Also when using this argument a new instance is created in any case.

  • Indem ich bei dem Befehl Anführungszeichen setze ändert sich nichts.

    Hallo :)


    logisch. Das habe ich auch nicht behauptet. Sondern

    Deine Befehlszeile ist doch völlig falsch.

    Es liegt nicht (nur) an den Anführungszeichen. Wie kommst Du denn darauf, dass Du die Angaben würfeln und in beliebiger Reihenfolge angeben kannst? Und wo kommt die Angabe "Beruflich" her? Laut Deinem Screenshot hast Du doch kein solches Profil. Die korrekten Parameter stehen übrigens in meinem Beitrag.

    Die Option -no-remote [...]

    Richtig. Aber nicht in der Syntax, wie sie stardepp laut seinem Screenshot angibt. Wenn ich keinen Augenkrebs habe, lautet die Befehlszeile bei ihm

    Code
    1. -P -no-remote Tom - Beruflich

    Wie soll so etwas funktionieren?


    Gruß Ingo

  • Das heißt man müsste auf -no-remote verzichten?

    Hallo :)


    zunächst würde ich eine syntaktisch korrekte Befehlszeile angeben. Dann sehen wir weiter. Laut dem KB-Artikel funktioniert es ja. Ich habe es allerdings nicht selbst ausprobiert.

    Die Parameter verstehe ich leider nicht.

    Das ist an sich nicht schlimm. Du schaust Dir einfach das Beispiel im KB-Artikel an und gibst das exakt so bei Dir ein.

    If you wanted to use profile XYZ you'd enter -P XYZ -no-remote as the command line arguments.

    Dabei ersetzt Du lediglich den Platzhalter "XYZ" für den Profilnamen mit dem Namen Deines Profils. Oder, noch einfacher, warum probierst Du es nicht einfach mit den oben von mir genannten?


    Gruß Ingo

  • deine oben genannten hatte ich doch schon ausprobiert. Im Mozillazine Artikel steht das gleiche wie du beschrieben hast.


    C: \ Program Files (x86) \ Mozilla Firefox \ firefox.exe" -Tom - Privat -no-remote ....an diesem Punkt waren wir schon.

    "C: \ Program Files (x86) \ Mozilla Firefox \ firefox.exe" -privater -new-tab" dieser Befehl aus dem Mozillazine Artikel erzeugt nur ein neues Fenster mit viel Fehlertabs und im letzten Tab wird der korrekte link geöffnet.