ASCII-fremde Zeichen im Adressbuch

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 60.8.0 (32bit)
    • Betriebssystem + Version: W10.0.18362
    • Kontenart (POP / IMAP): IMAP
    • Postfachanbieter (z.B. GMX): regionaler
    • Sync-Add-on für Online-Adressbuch?: nein
    • Eingesetzte Antivirensoftware: Comodo
    • Firewall (Betriebssystem-intern/Externe Software): Comodo


    Mit der Suche nach "ASCII-fremde" konnte ich nichts relevantes in Sektion "Adressbuch" finden. (Zwei Fundstellen halfen mir nicht weiter.)

    Ich erhalte diese Fehlermeldung bei jedem Start von Thunderbird (bzw. beim Aufwecken aus dem Hybernate)


    Ich habe mehrfach den Adressbuch - Eintrag "Österreicher" gelöscht und habe den Eindruck als würde er jeweils wieder neu erstellt, nach jedem Löschen wurde er nicht mehr angezeigt. Nach jeder neuen Fehlermeldung war der Eintrag wieder da.

    Bitte also um Hilfe, selbst komme ich nicht mehr weiter.

    "Power User"

  • Hallo,

    auch wenn es offiziell Webseiten und Mailadressen mit Umlauten und Sonderzeichen gibt, ist die Umsetzung weltweit aber noch lange nicht erfolgt, so dass es empfehlenswert ist, nicht damit zu arbeiten - also keine für seine Webseite oder Mailadresse anzufordern und falls doch, immer eine Alternativnamen zu haben ohne Ascii-fremde Zeichen.

    Wenn die immer wieder erscheint, könnte es sein, dass du mehrere Einträge in verschiedenen Adressbüchern hast, bzw. Die Mailadressen aus Listen gelöscht hast, so dass sie noch im Ursprungsadressbuch vorhanden sind. Denke auch daran, dass "Gesammelte Adressen" ebenfall ein Adressbuch ist und die Adresse dort ebenfalls stehen könnte.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Edited once, last by mrb ().

  • Danke.

    Wenn es "mehrere Einträge" gäbe, müssten die doch alle in der Suchliste für "Österreicher" (siehe Link oben) getrennt aufscheinen. Nach dem Löschen ist dort der einzige Eintrag weg (er stammt tatsächlich aus "Gesammelte Adressen" und verschwindet auch ebendort).


    Offenbar läuft m. E. beim Löschen das Sammeln für "Gesammelte Adressen") im Hintergrund und trägt diesen Verweis (auf eine vor Thread-start schon gelöschte Liste) erneut ein.

    Zusätzlich habe ich alle A-Bücher getrennt durchsucht, es gibt keine weiteren Einträge "Österreicher".

    In abook.mab ist der Zeichenstring "Österreicher" nicht enthalten.

    Beende ich TB und rufe nur das A-Buch auf, ist der String nicht enthalten, es erscheint keine Fehlermeldung. Auch das Starten von "Verfassen" aus dem Adressbuch bringt keine Fehlermeldung.

    Erst der "normale" Start mit dem Befehl "C:\Program Files (x86)\Mozilla Thunderbird\thunderbird.exe" über den normalen Link "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Mozilla Thunderbird.lnk" führt den erneuten Eintrag aus und "Österreicher" steht wieder in den " "Gesammelte(n) Adressen".

    BTW: Zwei W7 Maschinen mit vor dem Problem exakt gleichen "abook.mab" und denselben TB-Versionen machen keine Probleme.


    Welcher Adressteil ist der in der Meldung genannte "lokale Teil"?

    Gibt es eine Möglichkeit, nur die "lokale(n) Teil(e)" nach "ASCII-fremde(n)" Zeichen zu durchsuchen?

    Aber vor allem: Wie hindere ich TB daran, diesen Eintrag immer wieder neu zu schreiben? (Gibt es eine (Klartext-) Liste der letzten Aufrufe?)

    "Power User"

  • Hallo,

    wie viele Profile hast du?

    Profile verwalten (Anleitungen)

    Hast eine portable Thunderbird-Version?

    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Welcher Adressteil ist der in der Meldung genannte "lokale Teil"?

    Dein Kontakt enthält wohl "Österreicher" in einem der E-Mail-Adressfelder.


    Der lokale Teil ist in der Regel alles vor dem "@" (für Sonderfälle siehe RFC 5322 3.4.1). Eine E-Mail kann aber auch ausschließlich an einen lokalen Teil gesendet werden (als Domain wird dann die "lokale" Domain ergänzt). Thunderbird interpretiert daher "Österreicher" als E-Mail-Ziel innerhalb der lokalen Domain – und verschluckt sich am Sonderzeichen.


    "Gesammelte Adressen" [...] "abook.mab"

    Das Adressbuch "Gesammelte Adressen" befindet sich nicht in abook.mab, sondern in history.mab. Versuche es mal, letztere zu löschen / umzubenennen / aus einem anderen Profil zu kopieren?

  • Hallo,

    wie viele Profile hast du?

    Profile verwalten (Anleitungen)

    Hast eine portable Thunderbird-Version?

    Gruß

    * eines "default"

    * keine portable V., lokal installiert

    Habe history.mab gelöscht (vorher gesichert), das brachte leider nicht die erhoffte Problembewältigung.

    Jetzt gibt es nach dem normalen Start mit der genannten Fehlermeldung in "Gesammelte Adressen" nur noch diesen einen, offensichtlich allein problematischen, Eintrag.

    TB verhält sich hier wie ein Taschenspieler, der immer wieder dasselbe aus dem Hut zaubert. ;)


    Ich kann optisch keine Adresse finden, die ASCII fremde Zeichen enthalten würde.

    Dieses immer wieder gemeldete "Österreicher" war mal vorhanden als Mailliste, wurde aber nach dem ersten Auftreten der Meldung sofort von mir in "Oesterreicher" geändert.

    "Power User"

  • Dieses immer wieder gemeldete "Österreicher" war mal vorhanden als Mailliste, wurde aber nach dem ersten Auftreten der Meldung sofort von mir in "Oesterreicher" geändert.

    Das macht mich jetzt etwas stutzig. Du hast wirklich einen Kontakt, dessen E-Mail-Adresse "Oesterreicher" (ohne Domain) sein soll? Es wäre dann sinnvoller, die lokale Domain von Hand zu ergänzen (also "Oesterreicher@example.com", wenn "example.com" deine lokale Domain ist).


    Unabhängig davon: wenn Du die history.mab erneut löscht und Thunderbird dann im abgesicherten Modus startest, wird der Kontakt dann ebenfalls sofort beim Start sichtbar? Gibt es Fehlermeldungen in der Fehlerkonsole (Menü|Extras|Entwickler-Werkzeuge|Fehlerkonsole)?

  • Wie im Zitat in deinem Post angeführt, gab (!) es eine Mailliste, die vorher "Österreicher" und nach der ersten Fehlermeldung nun "Oesterreicher" hieß bzw. heißt.

    * Habe im Abges. Mod. gestartet, TB zeigt dasselbe Verhalten, der Eintrag "Österreicher" in "Gesammelte Adressen" ist wieder vorhanden.

    Ja, da ist folgende Fehlermeldung angeführt!

    "Power User"

  • Wie im Zitat in deinem Post angeführt, gab (!) es eine Mailliste, die vorher "Österreicher" und nach der ersten Fehlermeldung nun "Oesterreicher" hieß bzw. heißt.

    Ich hatte nur gefragt, da auf deinem ersten Screenshot ein Kontakt (eben keine Liste) mit der entsprechenden E-Mail-Adresse angezeigt wurde. Es klang mir so, als hättest du diesen Kontakt bearbeitet.


    Die Fehlermeldung aus der Konsole hat mit dem Problem vermutlich nichts zu tun. Ich hatte auf einen konkreteren Fehler gehofft...
    Viel fällt mir dann auch nicht mehr ein. Eventuell könnte man noch den Virenscanner deinstallieren, für den Fall dass irgendeine Funktion im alten Profil herumspukt.


    Ansonsten: mit einem neuen Profil (siehe Profilmanager in Lexikon) lässt sich Thunderbird vollständig neu einrichten. Dein altes Profil bleibt dabei erhalten, sodass Du bei Bedarf weiterhin die bisherigen Einstellungen einsehen oder Daten exportieren kannst. Und wenn der mysteriöse Kontakt auch im neuen Profil auftreten sollte, weißt zu zumindest, dass die Ursache außerhalb von Thunderbird liegt.

  • In abook.mab ist der Zeichenstring "Österreicher" nicht enthalten.

    Hallo,


    spontane Idee: hast du mal nur nach "sterreicher" gesucht, also ohne das leidige Ö? Falls das Ö bereits im Adressbuch durch irgendwelche ANSI- oder UTF8-Codes o.ä. ersetzt wird, kann die Suche nach "Österreicher" nichts ergeben.


    MfG

    Drachen

  • Hier wird einem super gehilft. Danke euch allen für die Bemühungen.

    @generalsync: Hatte ich einfach missverstanden, als ob du was überflüssiges fragen würdest. Sorry.

    Drachen : Danke für die Idee, habs erfolglos geprüft.


    "Eventuell könnte man noch den Virenscanner deinstallieren, für den Fall dass irgendeine Funktion im alten Profil herumspukt."


    Ich habe den Eintrag "Österreicher" in "Gesammelte Adressen" nochmals gelöscht und "history.mab" gelöscht. Alles mit DEAKTIVIERTEN VIRUS-ÜBERWACHUNGs-Funktionen. Kein Erfolg.


    M. E. weist das Symptom nicht auf ext. Einflüsse hin, u. a. deshalb, weil unter zwei W7-Maschinen mit mehrheitlich identischen Applikationen keine Probs auftauch(t)en. Ich gehe wohl einen anderen Weg:

    Deinstallieren von TB auf der "kranken" Maschine und Entfernen aller ersichtlichen Reste.

    Neuinstallation und Übernehmen von "abook.mab" aus einem anderen PC.


    Was haltet Ihr davon, ich warte noch auf eure Meinung(en)?


    PS, 5.9.: Auf einer der beiden anderen (W7) Maschinen gibt es trotz weiter existierender Mailliste "Österreicher" keinen Eintrag in "Gesammelte Adressen" mit "Österreicher". (Auch keine Fehlermeldung)

    "Power User"

    Edited once, last by Kanitfastan ().

  • Deinstallieren von TB auf der "kranken" Maschine und Entfernen aller ersichtlichen Reste.

    Neuinstallation und Übernehmen von "abook.mab" aus einem anderen PC.

    Ich würde TB aus Faulheit drauf lassen und nur ein neues Profil nutzen – es spricht aber auch nichts dagegen, alles neu zu installieren. Es ist nur wichtig, dass das alter Profil nicht weitergenutzt wird (auch bei einer Deinstallation bleiben Profile erhalten, der Schritt ist also immer notwendig!).

  • Habe endlich Zeit dafür gefunden:

    Das neue Profil hat geholfen. Die Fehlermeldung (s.o.) taucht nicht mehr auf.

    Danke an alle und besonders an generalsync!

    "Power User"