Nach Umzug von W10->Ubuntu keine Passwörter mehr

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 60.9.0 (32bit) -> 60.3.0 (64 bit)
    • Betriebssystem + Version: W10.0.18362.418 -> Ubuntu 18.04 LTE Desktop
    • Kontenart (POP / IMAP): POP/SMTP
    • Postfach-Anbieter (z.B. GMX): 1&1


      • Eingesetzte Antiviren-Software: keine
      • Firewall (Betriebssystem-intern/Externe Software): keine
      • Router-Modellbezeichnung (bei Sende-Problemen): Mikrotik


    Ich möchte meine Mails von W10 auf Ubuntu umziehen. Nach Thunderbird Installation auf Ubuntu funktioniert dieser korrekt wenn die Konten neu eingerichtet werden. Allerdings möchte ich meine bisherigen Mails mitnehmen. Dazu habe ich den Profilordner von

    c:\Benutzer\AppData\Romaning\Thunderbird\Profiles\xxx.default

    auf

    home/snap/thnuderbird/common/.thunderbird/xxx.default

    kopiert


    Nach Eintrag des kopierten Verzeichnisnamens in profiles ini erscheinen auch alle Mails und Konten korrekt. Allerdings wird jedesmal nach den Passwörtern gefragt und diese lassen sich auch nach neuer Eingabe nicht abspeichern. Zugriff auf den Mailserver funktioniert indes und die Passwörter haben vor dem kopieren der Windows Dateien auch funktioniert. Im Profil gibt es eine Datei prefs.js wo noch absolute Windows Pfade c:\\users\jv\AppData\.... eingetragen sind. Was habe ich alles falsch gemacht ?

  • graba

    Approved the thread.
  • Nach einer kurzen Nacht gibt es 2 Workarounds die funktionieren:


    1) Nacheditieren von prefs.js mit c:\users\jv\appdata... in /home/jv/...


    2) Neu erstellen aller Accounts inkl. Passworteingabe und dann reinkopieren der Mail Verzeichnisse ohne übergeordnete /.thunderbird Verzeichnisse. In diesem Fall ändert sich der Name von Profilverzeichnis in einen neuen Zufallsnamen was aber nicht zu stören scheint

  • Das hatte ich auch beim Kopieren von Windows auf Linux Mint.

    Die Antwort und die Lösung sind einfach aber ich habe auch sehr, sehr lange gesucht:

    Es ist die Datei pcks11.txt in jedem Profil (nicht in den Konten).

    Da hat Windows einen kryptischen Pfad (so mit ~ Tilden und Verkürzungen) reingeschrieben.

    Das erinnert ein bisschen an DOS und 8.3. Zeiten.

    Grund sind wohl die Pfad-Umleitungen und das ganze ~ roaming usw, wo einem Ordner

    vorgegaukelt werden, die eigentich woanders sind.


    Lösung: Lösche die pcks11.txt und Linux wird sie dir neu anlegen (woher auch immer TB die Info trotzdem hat.

    wahrscheinlich aus einer anderen Konfigurationsdatei). Dann gehen die Paßwörter wieder.

    Meines Wissens ist das bisher auch das einzige Problem beim Profil-Import Windows->Linux.

    Alles andere hat bisher funktioniert, ich mache das regelmäßig. Toi toi toi