AllowHTML verhindert HTML in RSS-Feeds

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version (konkrete Versionsnummer): 78.2.2
    • (Betroffene) Thunderbird-Erweiterung + Version: AllowHTMLtemp
    • Betriebssystem + Version: Windows 10

    Hallo zusammen,


    war das vor ein paar Stunden nicht noch anders? Ich bin mir ganz sicher, dass ich meines RSS-Feeds gestern und heute morgen noch in der gewohnt dargestellten Browseransicht (also HTML) gelesen habe.


    Jetzt nicht mehr. Und auch der Button im Header ist verschwunden bzw. die Schaltfläche im Kopf von TB ausgegraut. Bin ich nun irre oder hat sich da was geändert? Wie kann ich RSS-Feeds wieder vernünftig lesen (Reintext ist echt nicht leserfreundlich)? Gerne natürlich auch erst nach einem manuellem Klick auf einen Button.


    Update: Ja, heute kam ein Update für AlowHTMLtemp. Ich vermute, das es damit zu tun hat!?


    Gruß

    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten. Außerdem sind sie käuflich.


    Windows 10 Home (64 Bit) | Thunderbird 78 (64 Bit) | Firefox (64 Bit) | Avira Free Security Suite | Fritzbox 7490 | Posteo / web.de | CardBook | Lightning | PGP

    Android 9 Pie | K9-Mail | OpenKeychain | | iOS 13 | Apple Mail

  • Ja, 6.1.1 und laut TB ist es heute aktualisiert worden.

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten. Außerdem sind sie käuflich.


    Windows 10 Home (64 Bit) | Thunderbird 78 (64 Bit) | Firefox (64 Bit) | Avira Free Security Suite | Fritzbox 7490 | Posteo / web.de | CardBook | Lightning | PGP

    Android 9 Pie | K9-Mail | OpenKeychain | | iOS 13 | Apple Mail

  • Und auch der Button im Header ist verschwunden bzw. die Schaltfläche im Kopf von TB ausgegraut.

    Ich habe AHT schon ewig so programmiert, dass es bei Feeds einfach deaktiviert ist. Ich weiß gerade nicht mehr wieso ich dies so gemacht hatte, aber es gab gute Gründe dafür. Deshalb ist der Button in der Hauptsymbolleiste grau und im Header-Bereich "verschwunden" (im Prinzip genau so wie bei Mails, die keinen HTML-MIME-Part besitzen). Dennoch wird bei Feeds das HTML dargestellt, wenn man es als "Webseite" anzeigen lässt.

  • Dennoch wird bei Feeds das HTML dargestellt, wenn man es als "Webseite" anzeigen lässt.

    Und das mache ich wie? Ich habe jetzt gerade kein TB zur Hand und kann nicht ausprobieren.


    Mein Problem ist wohl auch, dass ich bisher nur Caschys Blog abonniert hatte und der lief immer gut. Nun weite ich das ganze aus, zusammen mit einer neuen TB-Version und einem neuen Profil - da trifft man auf ganz neue Probleme und der Fehler kann ja sonst irgendwo im Detail stecken.


    Gruß

    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten. Außerdem sind sie käuflich.


    Windows 10 Home (64 Bit) | Thunderbird 78 (64 Bit) | Firefox (64 Bit) | Avira Free Security Suite | Fritzbox 7490 | Posteo / web.de | CardBook | Lightning | PGP

    Android 9 Pie | K9-Mail | OpenKeychain | | iOS 13 | Apple Mail

  • Wie so Vieles, ist auch die Einstellung für die Darstellung der Feeds komplex und irgendwie undurchschaubar - jedenfalls für mich, da ich mich längere Zeit nicht mehr damit beschäftigt hatte. Vermutlich stolperst Du auch darüber.


    Im Menü Ansicht → Feed-Artikel kann man folgende Kombinationen einstellen:


    1. Webseite
    2. Zusammenfassung
      → Original-HTML
      → Vereinfachtes HTML
      → Reintext
    3. Standardformat
      → Original-HTML
      → Vereinfachtes HTML
      → Reintext

    Die Menüpunkte für Original/Vereinfacht/Reintext erscheinen nur bei Nummer 2 und 3. Ich vermute, dass "Webseite" immer das vollständige "originale" HTML darstellt. Bei Nummer 2 und 3 wirkt sich die Einstellung bezüglich Original/Vereinfacht/Reintext leider gegenseitig auf die Darstellung für normale E-Mails aus, da diese Einstellung nicht separat gespeichert wird.


    Du hast also bestimmt für E-Mails Reintext oder Vereinfachtes HTML eingestellt. Dieses wird dann auch auf die Feed-Artikel angewendet. Da mein "Zeige HTML" Button Dir für Feeds nicht zur Verfügung steht, ist das ein Problem für Dich.


    Ich schaue mir die Tage nochmal an, warum ich vor langer Zeit den Button bei Feeds deaktiviert hatte und überlege mir, ob diesen (mit passender Funktion) für Feeds wieder beleben kann.

  • Hallo,

    die Einstellung Webseite war es. Damit funktioniert es wieder.


    Probiere mal diese Version:

    allow-html-temp_6.1.2.xpi

    Damit wird unter der Einstellung Zusammenfassung bei Caschys Blog Bilder riesig angezeigt, HueBlog dagegen zeigt nicht alle Bilder an und der Zeilenumbruch funktioniert nicht wie in der Webseitenansicht.


    Gruß

    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten. Außerdem sind sie käuflich.


    Windows 10 Home (64 Bit) | Thunderbird 78 (64 Bit) | Firefox (64 Bit) | Avira Free Security Suite | Fritzbox 7490 | Posteo / web.de | CardBook | Lightning | PGP

    Android 9 Pie | K9-Mail | OpenKeychain | | iOS 13 | Apple Mail

  • Damit wird unter der Einstellung Zusammenfassung bei Caschys Blog Bilder riesig angezeigt, HueBlog dagegen zeigt nicht alle Bilder an und der Zeilenumbruch funktioniert nicht wie in der Webseitenansicht.

    Ist Dir überhaupt bewusst, dass diese verschiedenen Einstellungen (Webseite, Zusammenfassung, Standardformat) gar nicht vom Add-on kommen, sondern von Thunderbird selbst? Die Darstellung ist halt so wie sie ist. Mit Version 6.1.2 bzw. der wohl morgen fertigen 6.1.3 kannst Du halt nur "wieder" ganz simpel das HTML in der Darstellung "Zusammenfassung" bzw. "Standardformat" erlauben lassen. Mache Dir bzw. macht Euch bewusst, dass mein Add-on überhaupt nichts selbst mit dem HTML-Code macht. Es Schaltet nur automatisiert die Einstellungen bequem im Hintergrund so um, wie man es von Hand gar nicht hinbekommen würde.

  • Version 6.2.1 wartet auf Freischaltung auf ATN. Diese Version bringt den Button für Feed-Nachrichten (nur, wenn diese nicht sowieso als Webseite dargestellt werden). Außerdem wurde die Information unten in der Statusleiste angepasst, sodass man dort für Feeds jetzt die in Thunderbird gewählte Darstellungsart für Feeds sieht ("Webseite" / "Zusammenfassung" / "Standardformat") und zusätzlich die notwendige Information über den gewählten HTML-Modus (genauso wie bei E-Mails) sehen kann:


  • Ist Dir überhaupt bewusst, dass diese verschiedenen Einstellungen (Webseite, Zusammenfassung, Standardformat) gar nicht vom Add-on kommen, sondern von Thunderbird selbst?

    Ja, aber ich sollte ja die Version 6.2.2 testen und das habe ich gemacht und Feedback gegeben. Für mich wäre der Hinweis mit der Webseitenansicht in Version 6.2.1 völlig ausreichend gewesen, denn damit funktioniert es so wie es soll. Danke dafür.


    Gruß

    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten. Außerdem sind sie käuflich.


    Windows 10 Home (64 Bit) | Thunderbird 78 (64 Bit) | Firefox (64 Bit) | Avira Free Security Suite | Fritzbox 7490 | Posteo / web.de | CardBook | Lightning | PGP

    Android 9 Pie | K9-Mail | OpenKeychain | | iOS 13 | Apple Mail