Thunderbird 78.3.1 - PGP Schlüssel speichern funktioniert nicht

If you suddenly cannot receive any more emails

Please read the notes on the latest two most common causes of problems!

Please click here!

This red box disappears when you click on the X in the top right corner.

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version (konkrete Versionsnummer:( 78.3.1
    • Betriebssystem + Version: WIN 10 prof.
    • Kontenart (POP / IMAP): IMAP
    • Postfachanbieter (z.B. GMX):
    • PGP-Software / PGP-Version:
    • Eingesetzte Antivirensoftware: Avira
    • Firewall (Betriebssystem-intern/Externe Software):


    Ich habe bisher meine PGP-Schlüssel via Enigmail verwendet und mit Kleopatra verwaltet, diese auch von Kleopatra exportiert. Nun kann ich die Schlüssel im neuen Thunderbird nicht mehr importieren. Entweder das "bin-am-tun-Ringerl" läuft endlos beim Importversuch, oder es kommt die Meldung, dass der Schlüssel nicht korrekt sei, was bei jedem geheimen und öffentlichen Schlüssel der Fall ist. Wenn ich den Vorgang abbreche, wird der Schlüssel jedoch angezeigt und ich kann die Schlüssel-Eigenschaften aufrufen, die korrekt angezeigt werden. Wenn ich Thunderbird schließe und wieder öffne, sind keine Schlüssel mehr gespeichert, alle weg. Das Fenster der Schlüsselverwaltung ist leer. Der gleiche Effekt tritt ein, wenn ich direkt mit Thunderbird neue Schlüsseln erzeuge. Sie werden angezeigt aber offenbar nicht richtig gespeichert, denn nach einem Neustart von Thunderbird sind sie wieder weg. Avira auszuschalten habe ich bereit erfolglos versucht. Hat wer eine Idee, wo ich nach dem Fehler suchen könnte?

    LG Günther

  • graba

    Approved the thread.
  • Grias di Günther,


    Kringerl klingt heimisch in meinen Ohren :)

    Schaugst erst amoi hier bzgl. gegenwärtig noch vorhandener Einschränkungen. Falls die in deinem Fall nicht zutreffen, dann versuche es einmal testweise mit einem Profil, das du mit der 78 erstellst.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Grias di Susi,

    ich bin deinem Tipp gefolgt und habe ein neues Profil angelegt. Ich habe meine Nutzerdaten eingegeben und über IMAP mit dem Server synchronisiert. Leider ist das Ergebnis fatal. Ich habe die falschen Betreffs, oft mehrfach, zu anderen Emails, alles durcheinander. Es geht um ein paar tausend E-Mails. Ich habe die Standardansicht, also links die Struktur, rechts oben die Header (Betreffe, Absender, ...) und rechts unten die konkrete E-Mail. Was rechts oben angezeigt wird, ist komplett verkehrt. Die E-Mails selbst scheinen korrekt zu sein.

    Nach dieser Synchronisation habe ich wieder mit dem alten Profil gestartet. Es hat sich nun mit dem Server genauso deppert synchronisiert. Alles durcheinander. Bis zum PGP testen bin ich noch gar nicht gekommen. Wenn ich über Webmail auf meinen Account schaue, schaut alles ganz okay aus.

    Hast du oder jemand anderer aus dem Forum eine Idee dazu.

    Günther

  • Servus Günther,


    das Fehlerbild deutet in die Richtung beschädigter Indexdateien. Allerdings passt einiges in deiner Beschreibung überhaupt nicht dazu. Weshalb du mich auch ein wenig verwundert siehst.


    Wenn im Webmail alles normal aussieht, aber im Thunderbird nicht, dann spricht das für einen lokalen Fehler im Profil des Thunderbird. In Zusammenhang mit einem neuen Profil habe ich davon aber noch nicht gehört. Ich bin aber nicht mehr oft hier unterwegs. Vielleicht habe ich da ein "Feature" verpasst.


    Auch, dass auch dein bisheriges Profil plötzlich von dem Problem betroffen ist, will mir nicht ins Bild passen. Aus welchem Grund sollte das alte Profil plötzlich auch den Fehler zeigen? Rätselhaft.


    Eine mögliche Ursache könnte in der Größe der zugehörigen Mailboxen-Dateien liegen. Schreibst du doch von mehreren tausend Mails. Wenn die alle in einem oder wenigen Ordner liegen und/oder du den Posteingang nicht regelmäßig komprimiert hast, kann das ein Problem sein. Das sollte es dann aber erst recht bereits zuvor im alten Profil gewesen sein.

    Schau ggf. in die Doku zum Thema komprimieren. Da du aber ein neues Profil angelegt hast, dürften darin eigentlich keine Leichen vorhanden sein. Aber schau es dir trotzdem einmal an.


    Prüfe also zunächst die Größe der Mailboxen auf der Festplatte. Offiziell gibt es die 4GB-Grenze schon lange nicht mehr. Die Erfahrung zeigt aber, dass große Mailboxen zu Fehlern tendieren. Besonders gefährdet ist, aufgrund der vielen Zugriffe, der Posteingang.

    Bevor du dich wunderst, weil du ja IMAP verwendest: Auch bei IMAP legt der Thunderbird gemäß seiner Standardeinstellungen lokale Kopien an, unter /Imapmail/... . Das hat schon so manch einem die Mails gerettet.


    Wenn deine Mailboxen, insbesondere der Posteingang, größer als, sagen wir mal, ein Gig sind, dann solltest du die Mails entsprechend auf Unterordner verteilen. Das machst du beim gegenwärtig unklaren Zustand am besten per Webmail.


    Zurück zu den Indexdateien. Erstelle in jedem Fall zunächst Backups beider kompletten Profile. Dann wähle für jeden betroffenen Ordner aus dem Thunderbird heraus die Funktion "Ordner reparieren".

    Alternativ, beende Thunderbird. Gehe in den Ordner des neuen 78-Profils und lösche dort die zu den Mailbox-Dateien gehörenden *.msf-Dateien. Das sind die Indexdateien. Sie werden beim nächsten Start des Thunderbird neu erstellt.


    Wenn das alles nicht hilft, erstelle nochmals ein neues Profil. Bevor sich das IMAP-Konto synchronisiert deaktiviere das lokale Bereithalten der Mails.


    Pfiat di


    Susanne


    Noch eine Ergänzung. Sollte sich herausstellen, dass das Problem durch eine zu große Mailbox-Dateien verursacht wurde, dann kannst du das dauerhaft verhindern, indem du das Speicherformat auf Maildir umstellst. Dann wird pro E-Mail eine Datei erzeugt und keine stetig wachsensende mbox-Datei.
    Falls das für dich eine Option ist, dann lies dazu zunächst unbedingt zuvor die Doku. Die Unterstützung von Maildir ist, soweit ich weiß, im Thunderbird offiziell immer noch experimentell. Ich benutze es seit etwa zwei oder drei Jahren völlig problemlos.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

    Edited once, last by Susi to visit ().

  • Ui Susanne,

    eben habe ich das Update auf 78.3.2 eingespielt. Nun funktioniert PGP wie es soll (ohne detailliert zu testen). Für meine E-Mails habe ich ein Backup. Alles wird gut.

    Vielen Dank für deine große Mühe mir zu helfen!!


    A Neidei für di!
    Günther