Problem beim Bearbeiten von Entwürfen


  • Thunderbird-Version (konkrete Versionsnummer:( 78.2.2

    Betriebssystem + Version: Windows 10

    Kontenart (POP / IMAP): IMAP

    Postfachanbieter (z.B. GMX): Privat PGP-Software / PGP-Version: OpenPGP

    Eingesetzte Antivirensoftware: n.a.
    Firewall (Betriebssystem-intern/Externe Software): n.a.


    Ich habe ein großes Problem mit dem Bearbeiten von ENTWÜRFEN nach der Migration von Enigmail und meinen OpenPGP Schlüsseln!!! Obwohl ich die Verschlüsselung standardmäßig abgeschaltet habe, werden die Entwürfe anscheinend verschlüsselt gespeichert: Im Betreff steht dann nur "..." und jeglicher Text ist unwiederbringlich verloren ;(;(;(:cursing:. Es kommt keine Abfrage des Passworts und ich sehe keine Möglicheit, die gespeicherten Entwürfe wieder zu bearbeiten (auch am Smartphone mit K9 und installierter Krypromodulen!). Was ist da los. Ich muss doch die Verschlüsselung irgendwo in den Einstellungen komplett abschalten können, vor allem für die Speicherung von Entwürfen!?


    Haben andere noch die Erfahrung oder Lösungen?


    LG 2bein


    Edit: Ich habe obigen Beitrag aus dem ursprünglichen Thread abgetrennt. graba, Gl.-Mod.

    Edited 2 times, last by 2bein ().

  • Hallo 2bein,


    bei mir funktioniert es -

    TB 78.2.2 64bit, Win10, Migration von Enigmail ist abgeschlossen, Enigmail inzwischen komplett deinstalliert.


    ich denke es verhält sich so, wie es soll. Ich nutze imap, und die Entwürfe werden verschlüsselt auf dem Server abgelegt, der Betreff ist geschützt, deshalb die 3 "..." (also bei mir verhält es sich so wie es soll..)


    Funktioniert das openpgp denn ansonsten bei dir normal? also kannst du verschlüsselte emails verschicken?

    die Abfrage der Passphrase ist ja momentan in der neuen openpgp Lösung anscheinend nicht vorgesehen...

  • (Danke an den Moderator für das Abzweigen des Themas!)


    OpenPgp funktioniert normal. Jetzt, nachdem ich nochmal den Schlüssel abgewählt und wieder angeklickt habe, kann ich nun neue gespeicherten Mails wieder in TB bearbeiten, aber ich habe weiter das Problem, das ich diese Entwürfe NICHT in K9-Mail in Android bearbeiten kann (Schlimmer noch, wenn ich das versuche, ist der Betreff und Text komplett weg). Die Entwürfe in K9 erscheinen als NICHT-verschlüsselt, aber es sind Unterschrift und Schlüssel als ANHANG dran - da ist doch was faul beim Abspeichern der Entwürfe, oder warum kann K9 das nicht erkennen???


    Auch aus diesem Grund will ich die Entwürfe NICHT verschlüsselt speichern oder zumindest die Möglichkeit haben, dies individuell abzuwählen. Wie gesagt, ich habe die Verschlüsselung standard-mäßig ABgeschaltet. Gibt es keine Möglichkeit, das Speichern von Entwürfen dahingehend zu beeinflussen? OK workaround ist, dass ich den Schlüssel in den Einstellungen komplett deaktiviere, aber das kann es ja auch nicht sein.


    Ich habe leider seit ich PGP benutze (bin seit den Anfängen von PGP dabei) VIEL mehr Zeit verschwendet in die Konfiguration meiner email-Clienten oder Add-Ons als dass ich für das Verfassen von verschlüsselten Mails benötigt habe (auch mangels Empfänger mit Schlüsseln). Jetzt hatte ich so sehr gehofft, dass TB das mit der Integration schafft und habe schon wieder unverständliche Probleme...



    Nachtrag: Jetzt ist das Problem noch schlimmer, nachdem ich in einem Konto die Schlüssel gelöscht habe (OpenPGP und S/MIME, in S/MIME stand nur mein Name drin!?). Jetzt kann ich gar keinen Entwurf mehr speichern, es kommt die Fehlermeldung "Beim Speichern des Entwurfs trat ein Fehler auf. - Die konfigurierte Schlüssel-ID '0x0...' wurde nicht in Ihrem Schlüsselbund gefunden". Was soll das, ich habe keinen Schlüssel mehr konfiguriert - wo nimmt Thunderbird diesen Schlüssel her???

    Edited once, last by 2bein ().

  • Es ist halt ein gutes Stück "Neuland" ;)


    Mal auf Verdacht:


    Du verwendest anscheinend OpenPGP und S/MIME. Kann es sein, dass die Entwürfe, die du in K-9 nicht lesen kannst, S/MIME verschlüsselt sind? K-9 unterstützt das nicht.

    Du kannst im Thunderbird die bevorzugte Methode einstellen. Dort hat es auch einen Punkt "automatisch". Von dem weiß ich nicht, was gewählt wird, wenn für ein Konto beide Varianten zur Verfügung stehen. Stelle das mal fix auf auf PGP.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Hallo Susanne,


    K-9 unterstützt das nicht.


    K-9 Mail unterstützt das schon. In Verbindung mit ciphermail.


    Allerdings kann man eine S/MIME verschlüsselte E-Mail nur in ciphermail verfassen und von dort versenden. Insofern können von K-9 Mail Entwürfe nicht gelesen werden, womit Du also wieder recht hast. ;)


    Gruß

    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • Es ist halt ein gutes Stück "Neuland" ;)

    Ja, das scheint so, leider auch nach über 15 Jahren PGP ;(;(;(. Mein Problem ist nach vielem rumprobieren so vielschichtig und verwirrend geworden (s. auch Nachtrag oben), dass ich es hier kaum beschreiben kann, was ich aber unten nochmal ausführlich versuchen will. Das HAUPTPROBLEM ist dennoch ersichtlich bei mir: Es gibt es wohl KEINE Möglichkeit, die Verschlüsselung von Entwürfen abzuschalten (wohlgemerkt nach einer evtl. fehlerhaften Migration von Enigmail), ob meine Schlüssel nun stimmen oder nicht. Und das ist für mich wohl nun ein Zwang zum Downgrade (falls eine komplette Neuinstallation nicht hilft), da ich Entwürfe am Handy weiterbearbeiten können muss.


    So, nun zu den Details, die vielleicht zur Eingrenzung des Problems helfen, falls jemand das überhaupt reproduzieren kann:


    Ich habe im Moment einen PGP-Schlüssel mit 3 Identitäten/email-Adressen, Hauptidentität X und Alias Y und Z. Dazu waren im alten TB 3 Konten angelegt

    A) Konto Identität X mit OpenPGP und S/Mime Schlüssel (dienstlich)

    B) Konto Identität Y mit OpenPGP

    C) Konto Identität Z mit OpenPGP


    Nach der Migration erscheint in den Einstellungen "Ende-zu-Ende-Verschlüsselung" zu Konto A die Möglichkeit, im Abschnitt "OpenPGP" 2 Felder mit Radiobuttons zur Auswahl von "Keiner" oder "0x0...". Manchmal erscheint beim Öffnen der Optionen kein Feld ausgewählt, auch nach einer vorigen Auswahl (Schon das riecht nach Bug)! Wenn ich nun den "0x0..." Schlüssel auswähle und weiter unten "Automatische Auswahl" oder "OpenPGP bevorzugen" wähle, werden die Entwürfe verschlüsselt (wohlgemerkt, Verschlüsselung ist deaktiviert in den Optionen des Nachrichtenfensters). Wenn ich nun "Keiner" auswähle, werden die Entwürfe NICHT verschlüsselt, das ist wie erwartet!

    Im Abschnitt S/Mime ist der vorhandene Schlüssel erfolgreich eingetragen/migriert. Wenn ich unten "S/MIME" bevorzugt auswähle, werden die Entwürfe auch NICHT verschlüsselt (ich kann sie in K9 problemlos bearbeiten). Soweit kann ich mit diesem Konto arbeiten zumindest, aber es kann sein, dass der Grund für die nicht-verschlüsselung nur ist, dass das S/MIME-Kryptographie-Modul (Dongle) beim Speichern des Entwurfs nicht aktiv ist :/.


    Bei Konto B sieht es in den Einstellungen seltsam anders aus. Hier habe ich NICHT die Radiobutton Auswahl ob "Keiner" oder einen gültigen Schlüssel! Obwohl anscheinend kein Schlüssel migriert wurde (Problem Nebenidentität ist nicht Konto-Adresse?), wurden die Entwürfe verschlüsselt, und ich konnte sie nicht mehr öffnen bzw. waren leer (lokal und auf einem anderen Clienten). Nachdem ich den Schlüssel manuell importiert habe, ist aber trotzdem keine Radiobutton-Auswahl erschienen, um diesen Schlüssel wieder abzuwählen (seltsam, oder?). Ich kann auch diesen Schlüssel nicht mehr entfernen (Das ist noch seltsamer!!!). [Nebenbemerkung: Die Konten-Adresse Y entspricht nicht der Hauptidentität X des Schlüssels, aber der Nebenidentität Y, dass TB hier Probleme hat habe ich hier auch schon bei Susi gelesen und sollte unbedingt behoben werden.]

    Dennoch, verschlüsselte Entwürfe konnte ich nun zumindest lokal wieder (weiter)bearbeiten (nicht in K9, K9 sieht nur ein verschlüsseltes Attachment, das liegt wohl an K9).

    So, im Abschnitt "S/MIME" sollte eigentlich ja kein Schlüssel migriert werden, aber da steht nun unter "Persönliches Zertifikat für Verschlüsselung" MEIN NAME. Dann kann ich unten auch "S/MIME" als bevorzugte Verschlüsselung auswählen, und seltsam: dann werden die Entwürfe NICHT verschlüsselt.

    So, Problem mit diesem Workaround: Wenn ich in S/MIME das seltsame Zertifikat "Leere" (kein Name mehr im Feld), dann kann ich unten auch nicht mehr S/MIME-Bevorzugung auswählen, und meine Entwürfe werden zwangsweise verschlüsselt.


    Noch seltsamer: Nach mehrerem hin und herklicken (beenden und neustart von TB) erscheint auf einmal wieder unter S/MIME wie von Geisterhand mein Name in dem Feld des Persönlichen Verschlüsselungszertifikat und ich kann S/MIME wieder bevorzugt auswählen, die Entwürfe werden dann nicht verschlüsselt (es sei denn ich wähle OpenPGP-Bevorzugung oder Automatisch).


    Konto C verhält sich wie B.


    Ebenso das gleiche Verhalten auf meinem Laptop und auf einem alten Windows 7-Rechner... Sorry für das ganze Gelaber, aber ich musste das von der Seele reden, bin sehr traurig, dass meine 15-jährige Hoffnung für eine Jedermann-Verschlüsselungs-Implementierung schon wieder zurückgedrängt wird. Wenn es hier schon solche Probleme gibt, warum soll ich meiner Frau und Kinder denn noch beibringen, wozu man überhaupt Schlüssel generiert und es dann kaum jemand nutzt ||



    Kann es sein, dass die Verschlüsselungseinstellungen nicht sauber von Konto zu Konto getrennt sind? Oder hat die Enigmail-Migration was total durcheinander gewürfelt in der config? Wenn ich Zeit finde, werden ich eine Komplette Neuinstallation ohne Enigmail-Migration probieren...:wall:


    Schönes Wochenende!

  • Lösen kann ich dein Problem nicht, aber ein paar Hinweise hätte ich. Den wichtigsten vorweg: Mit einfachen Schlüssel, ohne weitere Substruktur, funktioniert es. Ich kann meine mit der 78 PGP-verschlüsselten Entwürfe auch in K-9 lesen. Dazu musste ich nichts tun außer beim automatischen Import die Passphrasen einzugeben.


    Ich habe im Moment einen PGP-Schlüssel mit 3 Identitäten/email-Adressen, Hauptidentität X und Alias Y und Z.

    [...]

    Oder hat die Enigmail-Migration was total durcheinander gewürfelt in der config?

    Wie gesagt, die aktuelle Version hat noch Probleme mit strukturierten Schlüsseln. Es wäre daher nicht verwunderlich, wenn die meisten deiner Probleme damit zusammenhingen. Abhilfe ließe sich in diesem Fall schaffen, indem du zu jeder Adresse ein eigenes, einfaches Paar erzeugst. Das würde ich aber in einem Profil durchführen, weil mach all den Versuchen der Zustand deines Zertifikatsspeichers im Thunderbird nicht genau bekannt ist.

    Das S/MIME-Zertifikat würde ich im Anlauf auch weglassen und zunächst testen, ob du PGP zum Laufen bekommst.


    Das ist ärgerlich, ich weiß, weil du im Erfolgsfall neue Schlüsselpaare verwenden müsstest. Mit dem Rattenschwanz, den das hinter sich her zieht.


    Derzeit gibt es auch die Möglichkeit, in der Version 78 weiterhin GnuPG zu verwenden. Das wäre der erste Versuch, den ich machen würde.


    Last but not least könntest du auch noch auf der 68 bleiben und hoffen, dass das demnächst gefixt wird. Den genannten Test würde ich in jedem Fall machen. Einfach um zu sehen, ob dort das Problem liegt.


    Wenn ich unten "S/MIME" bevorzugt auswähle, werden die Entwürfe auch NICHT verschlüsselt

    Soweit ich weiß, ist das normal. Mit S/MIME speicher der Thunderbird die Entwürfe nicht verschlüsselt.


    Nachdem ich den Schlüssel manuell importiert habe, ist aber trotzdem keine Radiobutton-Auswahl erschienen, um diesen Schlüssel wieder abzuwählen (seltsam, oder?).

    Ich habe die Release Notes gestern nur überflogen und noch nicht genau gelesen. In der 78.3 wurde ein Bug gefixt, der ganz entfernt in diese Richtung deutet. Ich vermute aber eher einen Zusammenhang mit der Schlüsselstruktur, s.o. .

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Hallo 2Bein, habe das gleiche Problem, dass trotz abgeschaltetem PGP die Entwürfe verschlüsselt wurden, dann nicht mehr entschlüsselbar waren und ich dann die Keys gelöscht habe und nun gar nichts mehr als Entwurf abspeichern kann.


    Hast du das Problem inzwischen gelöst - also eine Möglichkeit zur Deaktivierung der Entwurfs-Verschlüsselung gefunden?
    Der Button in den Konteneinstellungen, wo man das früher einstellen konnte, existiert jedenfalls nicht mehr.


    TB ist für mich gerade komplett unnutzbar, wenn ich keine Entwürfe abspeichern kann. (in allen meinen Konten)

  • Ich habe den Schlüssel wieder importiert und kann zumindest die Entwürfe wieder (verschlüsselt) abspeichern. Hilft das vielleicht kurzfristig?


    Ich hab in bugzilla mit den Leuten etwas diskutiert https://bugzilla.mozilla.org/show_bug.cgi?id=1666846


    Herausgekommen ist nur, dass es so gewollt ist, dass die Entwürfe verschlüsselt werden (kein Bug, sondern by Design!). Vielleicht bauen Sie irgendwann noch einen Schalter wieder ein (wie es ja eigentlich bei Enigmail vorhanden war).


    Bei mir ist wahrscheinlich durch den Import der Enigmail-Einstellungen in TB78 und meinem strukturierten Schlüssel einiges schief gelaufen, sodass ich TB und meine Konten komplett neu aufsetzen werden muss (ohne PGP). Bei sind auch die Keys bzw. OpenPGP nicht mehr deaktivierbar und wen ich die Schlüssel lösche, bleiben die Entwürfe verschlüsselt oder es kommt zu der oben genannten Fehlermeldung beim abspeichern (wie gesagt, re-import des Keys hat geholfen). In der Arbeit benutze ich zusätzlich SMIME, und da kann ich OpenPGP und auch die Verschlüsselung an sich völlig abwählen. Daheim ohne SMIME-Zertifikat geht das nicht, auch nicht für OpenPGP!? Also alles etwas komisch, sodass ich bei Gelegenheit eine Neuinstallation probieren werde, aber mit OpenPGP werden die Entwürfe wohl default verschlüsselt ohne Möglichkeit, das zu ändern.


    Ich habe allerdings in den Einstellungen... Konfiguration bearbeiten... (ganz unten) eine Einstellung gefunden "mail.identity.id#.autoEncryptDrafts" und diese auf "false" gestellt. Hilft aber nichts. Erst wenn ich "mail.identity.id#.mimePreferOpenPGP" auf 0 stelle, wird die Verschlüsselung komplett abgestellt, ist aber derselbe Effekt, den ich oben beschrieben habe. Hier kann man evtl noch andere Schalter probieren, wenn man eh damit rechnen muss, TB und die Konten neu zu installieren - hab aber grad leider keine Zeit.

  • Vielleicht bauen Sie irgendwann noch einen Schalter wieder ein (wie es ja eigentlich bei Enigmail vorhanden war).

    Das ist bereits in Arbeit. Den Release Notes der 83 beta ist zu entnehmen, dass es dort schon implementiert ist.

    Also alles etwas komisch, sodass ich bei Gelegenheit eine Neuinstallation probieren werde,

    Wie oben erwähnt, ist in deinem Fall vermutlich die Schlüsselstruktur zumindest Teil des Problems. Eine Neuinstallation des Programms würde das Problem nicht lösen. Du müsstest wohl in jedem Fall die Schlüssel neu erstellen, ohne Substruktur.

    Da der Import der alten Schlüssel einen unbekannten Status hinterlassen hat, würde ich zunächst ein neues Profil anlegen und dort dann die neuen Schlüsselpaare erstellen.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Ah sehr gut, das sind gute Neuigkeiten. Neue Schlüsselpaare will ich (noch) nicht erstellen, die muss ich ja alle wieder zertifizieren/signieren lassen :/

  • Neue Schlüsselpaare will ich (noch) nicht erstellen, die muss ich ja alle wieder zertifizieren/signieren lassen

    Da bin ich mir jetzt nicht ganz sicher, aber soweit ich weiß, funktioniert das mit der 78 eh nicht. Das könnte dann auch ein weiterer Haken deiner Schlüssel sein, dass sie von anderen signiert wurden.


    Hab's gefunden:

    https://support.mozilla.org/de…-support-the-web-of-trust

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

    Edited once, last by Susi to visit ().

  • Moin,

    ist ja schön, wenn sie den Button bald wieder anbieten wollen, aber wenn die ganzen anderen Problemen mit Schlüsselstrukturen nicht behoben werden, hilft das letztlich auch nicht viel.
    Ich habe jedenfalls keine Lust für 7 Mailkonten 7 verschiedene Schlüsselpaare zu erstellen und verwalten. Das ist auch absolut sinnfrei.


    Ich hoffe das wird bald alles wieder nutzbar, so wie es lief. Warum Menschen ständig an funktionierender Software herummanipulieren müssen und running systems zerstören müssen, wird mir aber immer ein Rätsel bleiben.

  • Gibt es denn hier schon Neuigkeiten?


    Ich habe das gleiche Problem.


    Wann weiß ich denn eigentlich ob die Einstellungen bereits migriert wurden?

    Das Menü "Enigmail-Einstellunen migrieren" ist ja immer noch da, obwohl das bereits gemacht wurde. Sehr verwirrend!

    Edited 2 times, last by c303 ().

  • Ich habe das gleiche Problem.

    In diesem Thema berichtest du von Problemen mit den Umbrüchen in Entwürfen. Demnach kannst du die Entwürfe zur Bearbeitung öffnen.


    Hier ging es um

    ich sehe keine Möglicheit, die gespeicherten Entwürfe wieder zu bearbeiten

    Wieso meinst du, du hättest das gleiche Problem?

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Ich verstehe nicht.


    Es gibt zwei Probleme:


    1.) die Entwürfe werden verschlüsselt gespeichert obwohl das nicht so sein soll

    2.) Die Entwürfe werden "zerstückelt"

  • Naja, deinen Angaben zufolge kannst du die Entwürfe sehen, öffnen und bearbeiten. Das ist doch etwas ganz anderes als:

    ich sehe keine Möglicheit, die gespeicherten Entwürfe wieder zu bearbeiten (auch am Smartphone mit K9 und installierter Krypromodulen!).

    Daher die Nachfrage.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Früher wo es noch Enigmail gab, gab es auch eine Option für die Entwürfe.


    Weiß nur nicht mehr ob in Enigmail oder in Thunderbird.


    Aber ich habe das selbe Problem, auch schon zu Zeiten von Enigmail.


    Vielen Dank!


    Viele Grüße


    Revan335

  • Aber ich habe das selbe Problem, auch schon zu Zeiten von Enigmail.

    In diesem Thema ging es leider etwas durcheinander. Es wurde von mehreren "Probleme" berichtet. Wenn du nach einer Lösung suchst, dann eröffne besser dein eigenes Thema. Beantworte dort die Eingangsfragen und beschreibe dein Problem etwas genau als nur mit "das selbe".

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Entschuldige.


    Es geht um das Problem des Erstellers.

    Aber wenn ich das richtig gelesen hab wird die Option das man Entwürfe auch nicht verschlüsseln kann in einer neuen Version V ? wieder eingebaut. Warum auch immer diese entfernt wurde.


    Sowie auch das man die verschlüsselten Entwürfe dann auch mit K-9 Mail und OpenKeyChain bearbeiten kann ohne einen leeren Entwurf zu bekommen der dann natürlich den Inhalt dessen löscht/killt.

    Zu Enigmail Zeiten war dies schon ziemlich kacke/doof wenn man vergessen hatte die Option für Entwürfe verschlüsseln zu deaktivieren. Was unterwegs etwas schwierig ist, da Thunderbird ja am PC und nicht am Mobile Device ist.


    Vielen Dank!


    Viele Grüße


    Revan335