Enigmail: kein GnuPG, immer S/MIME

  • Hi,


    Vorbemerkung:

    Betriebssystem ist Ubuntu 20.04, frisch installiert auf einem neuen PC (kein Upgrade)

    Thunderbird ist 68.10.0


    Vorgang:

    Die Keys wurden vom alten PC in eine Datei übertragen, sowohl private als auch public keys. Auf dem neuen PC wurde in Thunderbird das Add-on Enigmail installiert. Darüber wurden die Keys eingespielt.


    Problem:

    Schreibe ich eine neue Mail und wähle als Empfänger jemanden aus, dessen public key ich habe, werde ich immer aufgefordert, die entsprechenden Zertifikate zu installieren. Im Menü wird auch immer S/MIME angezeigt, in den Einstellungen ist Enigmail/Open PGP ausgewählt. Was kann ich da machen, um via Enigmail verschlüsselte Mails schreiben/empfangen zu können?


    Schönen Gruß

    AugustQ

  • graba

    Approved the thread.
  • Hallo,


    mich hatte das in TB 68 auch gestört, daß da immer S/Mime in der menüleiste stand, obwohl ich das gar nicth hatte - geht es darum?



    in TB78 wurde das korrigiert, die Fläche heißt hier nur noch allgemein "Sicherheit".

    enigmail sendet mir aber trotzdem die emails richtig verschlüsselt raus in TB68, in den Standard-einstellungen ("verschlüsseln, wenn möglich").


    so sieht es aus, wenn noch keine empfängeradresse im "an"-Feld steht:


    und so, wenn eine mit gültigem Schlüssel erkannt wurde:



    Dabei ist es wichtig, was für das Konto eingestellt ist (openpgp muß für das Konton aktiviert sein):



    werde ich immer aufgefordert, die entsprechenden Zertifikate zu installieren.


    was genau passiert da? evtl. ein Screenshot?


    evtl. muß man das Schlüsselvertrauen nach dem Import nochmal überprüfen / neu setzen.


    Viel Erfolg!

  • Im Menü wird auch immer S/MIME angezeigt, in den Einstellungen ist Enigmail/Open PGP ausgewählt.

    Die Einstellung, die du vermutlich meinst, ist die, in der man festlegen kann, dass GnuPG verwendet werden soll, wenn es sowohl einen Schlüssel als auch ein S/MIME-Zertifikat gibt.

    Das Problem ist aber vermutlich ganz simpel. Du hast S/MIME ausgewählt, und deshalb fragt der Thunderbird nach einem S/MIME Zertifikat, welches du nicht installiert hast. Wenn du die GnuPG-Verschlüsselung wählst, wird das nicht passieren.


    Bei mir gibt es im Verfassenfenster zusätzlich zu dem Button "S/MIME" drei weitere: zum Verschlüsseln, Signieren und Betreff schützen - alles mit Enigmail/GnUPG. Ich nehme an, diese Buttons habe ich mir vor langer Zeit dort angelegt. Also schau mal, ob du die Symbolleiste des Verfassenfenster anpassen kannst. Ansonsten kannst du es jeweils über das Menü Enigmail einstellen.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Danke für die Hinweise. Ich werde das noch einmal prüfen. Allerdings ist dies nicht mein Rechner sondern der eines Bekannten. Wir müssen jetzt erst mal sehen, wann wir wieder zusammen kommen.


    Ich melde mich wieder.

    AugustQ

  • ich habe einige Hardcopies angehängt, mit denen ich das Problem darstellen möchte.


    Ein Bild stammt aus dem Kopf, wenn ich eine Mail schreiben will.


    Das andere Bild sagt mir, daß ich Zertifikate einrichten soll. Dabei will ich doch GnuPG verwenden, das auf dem alten Computer auch lief.

  • es sieht erstmal nichts falsch aus.

    Hat nichts mit dem Problem zu tun. Den Haken bei "Standardmäßig verschlüsseln" würde ich aber herausnehmen. Erfahrungsgemäß benutzen nur sehr wenige PGP. Da stört das nur.


    Was habe ich da falsch gemacht?

    Wie oben erwähnt, versuchst du anscheinend immer noch, über S/MIME zu verschlüsseln. Das ist der Fehler. Schau im Verfassenfenster in das Menü unter "Enigmail". Ich würde fast wetten, dort ist unter Protokoll "S/MIME" ausgewählt.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • damit in Enigmail S/MIME ausgewählt sein kann, müssen auch Zertifikate installiert sein ?



    bei mir ist das nicht der Fall, deshalb ist diese Option ausgegraut.


    Die Fehlermeldung, die AugustQ beschrieben hat ("Sie müssen ein oder mehrere persönliche Zertifikate einrichten..." läßt sich aber genau reproduzieren durch Klicken auf den S/Mime Button und dann auswählen von "Nachricht verschlüsseln".

    von daher dürfte es auch nichts mit Schlüssel Vertrauen usw. zu tun haben, wie ich oben vermutet habe.


    hier in Windows siehts etwas anders aus, aber der Text schein gleich zu sein.



    Hat nichts mit dem Problem zu tun. Den Haken bei "Standardmäßig verschlüsseln" würde ich aber herausnehmen. Erfahrungsgemäß benutzen nur sehr wenige PGP. Da stört das nur.

    wir sind ja in TB68 mit gnupg/enigmail.

    da sollte das keine Schmerzen verursachen, hier funktionieren ja die Empfängerregeln / PRR (Per Recipient Rules).


    VG

    Edited once, last by stefan327 ().

  • damit in Enigmail S/MIME ausgewählt sein kann, müssen auch Zertifikate installiert sein ?

    Kann sein. Ich habe welche. August vielleicht auch. Fall nicht, bliebe natürlich


    Klicken auf den S/Mime Button

    Das wäre dann aber schon hard core. Das ganze Thema wäre unnötig. Wenn man auf S/MIME klickt, sollte man sich nicht wundern, dass man S/MIME bekommt. Kann ich mir aufgrund des Betreffs deshalb nicht vorstellen.
    Wie man die Buttons für GPG bekommt habe ich oben erwähnt. Leider hat August sich dazu nicht geäußert.

    hier in Windows siehts etwas anders aus, aber der Text schein gleich zu sein.

    Dadurch, dass der Begriff "Zertifikat" in der Meldung vorkommt, ist es eindeutig. August versucht, S/MIME zu verwenden.


    da sollte das keine Schmerzen verursachen,

    Wenn der Haken gesetzt ist, dann ist beim Verfassen die Verschlüsselung zunächst automatisch aktiv.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)