Nach TB-Update auf 91.2.1 geht Email-Senden nicht mehr + Adressbuch ist leer

  • Der TB funktionerte seit Jahrzehnten stets problemlos und wurde im Laufe der Zeit über mehrere Rechner umgezogen.


    Nach dem letzten Update von 78.14.0 auf 91.2.1 funktioniert das Senden nicht mehr.


    Beim Klicken auf Senden oder alternativ Strg-Eingabe zeigt sich keinerlei Reaktion (außer der kurzen Klick-Animation der Sendentaste selber).

    Gleichermaßen auch "später Senden" über das Menü oder Hotkey geht auch nicht und verhält sich gleich.

    Es können danach sämtliche Felder weiter bearbeitet werden (Adresse, Betreff, Text).

    Auch zusätzliche CC, BCC, Anhänge, Ein/Ausschalten der Empfangsbestätigung (MDN) oder Rechtschreibung ändern nichts ...

    Speichern funktioniert problemlos, auch inkl. Anhängen.


    Außerdem wirkt das Adressbuch komplett leer!

    (vorher waren sehr zahlreiche gesammelte Adressen in mehreren Adressbüchern vorhanden)


    Add-Ons sind alle mittleweile deaktiviert!
    (seit mehrmaligem FB- und Rechner-Neustart)

    Es waren zuvor noch aktiv:

    Manually sort folders

    Signature Switch

    und in der Liste noch seit alter Zeit deaktiviert

    Folder Pane View Switcher

    Reminderfox

    und in der Liste unter Fehlerbehebungs-Informationen tauchen zusätzlich auch noch

    Amazon, Bing, DuckDuckGo, Ecosia, Google, LEO Eng-Deu, Wikipedia (de)

    auf, woher auch immer die sich installiert haben sollen?

    Und "German Dictionary" vorhin installiert nach anderen Fehler-Reports, hat aber auch nichts geändert.


    Fehlerbehebungsmodus sowie Start-Cache-Löschen wurden auch bereits ausgeführt.



    Und noch die Systemdaten:


    • Thunderbird-Version: 91.2.1 (Build 20211020014537) - Update von 78.14.0

    • Betriebssystem + Version: Win-10-Pro (10.0 Build 19043), HP Elite X2 1013 G3, i7-8550

    • Kontenart (POP / IMAP): Beides

    • Postfachanbieter: Diverse (eigener Server bei all-inkl.de / outlook.de / yahoo.de)

    • Eingesetzte Antivirensoftware: Avira, HP Wolf Security (sure click)

    • Firewall (Betriebssystem-intern/Externe Software): Windows Defender

    • Router-Modellbezeichnung (bei Sende-Problemen): Fritzbox 6591 Cable (Vodafone)


    Danke im Voraus für die Bearbeitung!

    LG, Thomas

  • Go to Best Answer
  • Thunder

    Approved the thread.
  • Er kommt aus diesem Beitrag,

    Da ich die Vermutung habe das es bei Ihm etwas anders ist und wir mit den Antworten durcheinander kommen, habe ich ihn darum gebeten einen neuen Beitrag zu verfassen.

    Gruß EDV-Oldie getippt auf dem Smartphone

  • Nachtrag:

    Heute Update auf Version 91.3.0 gemachht - keinerlei Änderung oder Verbesserung zum vorigen Status


    Und - was mir noch aufgefallen ist.

    Adressbuch wirkt zwar leer - aber bei Eingabe einer eMail-Adresse bringt er die ganzen vorgeschlagenen Adressen. Also sind sie vom Prinzip her richtig erkannt, können nur im Adressbuch nicht dargestellt werden.

  • Hast du mal irgendwelche Dateien in dem Profil selbst hin und her kopiert? Könnte es einen Grund geben, warum das Profil korrupt ist?


    Hast du irgendwelche besonderen Prefs angelegt?


    Bitte lösche mal ReminderFox und FolderPaneSwitcher, die sind nicht mehr kompatibel.

    Fragt dich Thunderbird beim Starten, ob du im online oder offline Modus arbeiten willst?


    Du sagst, selbst im Fehlerbehebungsmodus (Neustart mit deaktivierten Add-ons und deaktiviertem user.css) geht das nicht?

    Geht es in einem neuen leeren Test-Profil? (thunderbird.exe -p) Wenn ja, siehst du in deinem Profil Fehlermeldungen auf der Konsole, die du in dem Test-Profil nicht siehst?


    Hast du ein Backup deiner Adressbücher (gesichertes TB78 Profil)? Es gibt nur die beiden Standard Adressbücher (Persönlich und Gesammelt) und beide sind leer?

  • Ich denke mal, Daten im Profil selber hin- und herkopiert, das kann ich ausschließen.

    (älteste Datein in dem Verzeichnis sind übrigens von 2002).

    Das Profil heißt "thu".

    Es gab nur schon ein weiteres Profil "default" - dem Verzeichnis nach höchstwahrscheinlich von 2011, das bei neuer Rechnerinstallation vermutlich zuerst angelegt wurde, bevor ich dann mein altes Profil "thu" wieder dazukopiert und eingebunden habe.


    Beim Start mit dem nahezu leeren "default"-Profil klappt das EMail-Senden,

    gleichermaßen bei einem komplett neu angelegten "test"-Profile.

    Adressbücher sind dort auch zu sehen.


    Was meinst Du mit "besonderen Prefs"?

    eigentlich bin ich mir keiner Schuld bewusst, dass ich da im Laufe der Jahre irgendetwas massgebliches umgestellt haben sollte?

    "Sofort-Rechtschreibprüfung" ist aktiviert, ebenso "Lokale Adressbücher"

    Im übrigen interessant: Wenn ich in die Einstellungen gehe, erscheint bei "Adressen beim Senden automatisch hinzufügen" zur Auswahl die Liste meiner 5 Adressbücher.


    Ich habe alle 4 Add-Ons gelöscht und danach auch nochmals im Fehlerbehebungsmodus gestartet. Alles nix ...

    (ist es richtig, dass ich bei Fehlerbehebungsmodus die beiden Kästchen nicht anklicken muss, sondern nur, wenn ich sie dauerhaft deaktiviert lassen will?)

    Was ist der deaktiverte user.css ...? Ich meine, das stand bei mir nicht?


    Thunderbird fragt mich NICHT, ob ich online/offline arbeiten will.


    Nein, ich habe kein Backup der Adressbücher vor dem Update.

    Aber das erstaunliche ist ja, dass die Adressen alle bei Eingabe in der To-Zeile angezeigt werden, ebenso die Existenz der Adressbücher in den Einstellunge (s.o.).


    Bei Aufruf des Adressbuches kommen nicht leere Adressbücher, sondern es kommen genauer gesagt überhaupt keine!

    Das linke Fenster, wo die Adressbücher stehen sollten, ist komplett leer, und im oberen Fenster steht: "Kontakte externer Adressbücher werden erst nach einer Suche angezeigt" und etwas tiefer "Dieses Adressbuch zeigt Kontakte erst nach einer Suche an". Im unteren Fenster stehen die Titel, wie Name, EMail-Adresse, etc ...

    Suche über die Suchzeile bringt keine Erfolg,

    Suche über's Menü bringt KEIN Suchfenster, wie im neuen Testprofil.


    Ansonsten deckt sich der Effekt m.E. identisch mit denen aus dem anderen Thread.

    Bei mir ist es z.B. auch, dass bei Antworten/Weiterleiten die Senden-Taste grau bleibt, nur bei Neuversand schwarz - nur bei Betätigung tut sich dann nichts weiter (bis auf das kurze abdunkeln zwischendurch).

  • > Was meinst Du mit "besonderen Prefs"?


    Besondere Einstellungen, die du in den erweiterten Einstellungen von Thunderbird gesetzt hast. Eine Übersicht findest du unter Hilfe -> Weitere Informationen zur Fehlerbehebung -> Wichtige modifizierte Einstellungen


    > Ich habe alle 4 Add-Ons gelöscht und danach auch nochmals im Fehlerbehebungsmodus gestartet. Alles nix ... (ist es richtig, dass ich bei Fehlerbehebungsmodus die beiden Kästchen nicht anklicken muss, sondern nur, wenn ich sie dauerhaft deaktiviert lassen will?)


    Korrekt, einfach nur "Im Abgesicherten Modus weiterarbeiten" anklicken.


    > Was ist der deaktiverte user.css ...? Ich meine, das stand bei mir nicht?

    Der abgesicherte Modus schaltet mehr aus als nur die Add-ons, was genau weiß ich selbst gar nicht so genau, aber wohl auch eigene benutzerdefinierte Anpassungen der Oberfläche


    > Thunderbird fragt mich NICHT, ob ich online/offline arbeiten will.


    Ok.


    > Nein, ich habe kein Backup der Adressbücher vor dem Update.


    Mist. Deine Adressbücher scheinen einen Schaden zu haben. Gibts die irgendwo anders gesichert?

    Ich würde mich bei der weiteren Fehlersuche auf die Adressbücher konzentrieren. Das ist aber nicht mein Spezialgebiet.


    1. Bitte eine Sicherung des Profils machen, sodass wir rumspielen und ein paar Dinge ausprobieren können.

    Frage an die Gemeinschaft:
    - wurde von 78 auf 91 das Adressbuch-Format angepasst, oder war das von 68 auf 78?

    - welche Dateien sind das alte System und welche Dateien sind das neue System? Neu ist eine abook.sqlite oder gibts da jeweils eine pro Adressbuch?


    thuppertz : Hast du eine eine abook.sqlite im Profilordner? Was passiert, wenn du (bei ausgeschaltetem Thunderbird!) deine abook.sqlite in no_abook.sqlite umbenennst und dann Thunderbird startest?

  • thuppertz : Hast du eine eine abook.sqlite im Profilordner? Was passiert, wenn du (bei ausgeschaltetem Thunderbird!) deine abook.sqlite in no_abook.sqlite umbenennst und dann Thunderbird startest?

    Ich habe da eine

    - abook.mab.bak (31.10.2020 - also schon 1J alt ...)

    - abook.sqlite

    - abook.v2.sqlite


    Soll ich beide letzteren gleichzeitig umbenennen?

  • abook.mab.bak - erstellt: 28.5.2019 (23:06:37), geändert: 31.10.2020 (16:12:36)


    abook.sqlite - erstellt: 2.11.2020 (12:05:31), geändert: 2.11.2021 (02:11:19)

    abook.v2.sqlite - erstellt: 2.11.2020 (02:03:34), geändert: 2.11.2021 (01:39:17)

    Aus Update-Chronik:

    78,14.0 - 7.9.2021 (17:53:59)

    91.2.1 - 23.10.2021 (15:50:12)

    91.3.0 - 3.11.2021 (15:23:42)


    Aber erstaunlicherweise wird es noch schlimmer ...

    ich sehe nämlich gerade, dass ich am 31.10. noch EMails versandt habe.

    Aber, aus der Erinnerung heraus, war der Neustart des TB wegen dem Update auch erst ungefähr am 31.10.
    (ich hab' nämlich davor die Woche krank im Bett gelegen und dabei selbst den Notebook quasi ignoriert ... ;) )

    Kann es sein, dass in der Update-Chronik das frühere Datum steht, nicht das des Neustarts?

    Ansonsten habe ich aber nichts am Computer verändert, nichts neues installiert, o.ä.


    Dazwischen wäre nur noch das Windows "Funktionsupdate für Windows 10, Version 21H1", installiert am 29.05.2021 ... ?

  • Frage an die Gemeinschaft:
    - wurde von 78 auf 91 das Adressbuch-Format angepasst, oder war das von 68 auf 78?

    Hallo, trifft wohl beides zu.

    Einmal von .mab zu .sqlite und als Beobachtung werden .sqlite aus TB 78.14 in TB 91.x wohl noch einmal geändert,

    weil alte abook.sqlite im selben Profilordner zu abook.v2.sqlite umbenannt werden.

    Ich habe 3 Adressbücher und die werden so umbenannt:

    1. Adressbuch = abook.sqlite -> abook.v2.sqlite

    2. Adressbuch = abook-1.sqlite -> abook-1.v2.sqlite

    3. Adressbuch = abook-2.sqlite -> abook-2.v2.sqlite


    Die Umbenannten liegen dann unbenutzt herum und tragen ihr ursprüngliches Erstellungsdatum.

    Die neuen (konvertierten?) heissen dann wieder

    1. Adressbuch = abook.sqlite

    2. Adressbuch = abook-1.sqlite

    3. Adressbuch = abook-2.sqlite

    Gruß, Bastler

  • Das MAB kannst du erstmal so lassen, das ist ein Backup, wahrscheinlich vom Update 68 -> 78.

    Die v2 ist ein Backup beim Update der sqlite Variante.

    Mein Vorschlag (Alle Änderungen am Profil bei ausgeschaltetem TB!):
    - beide sqlite files sichern und aus dem TB profil Ordner entfernen
    - TB Neustart sollte dir hoffentlich ein funktionierenden TB geben


    Danach mal probieren die v2 als abook.sqlite ins Profil zu kopieren, was passiert?

  • Hat leider überhaupt keine Änderung gebracht!

    Adressbuch nach wie vor mit komplett leeren Fenstern,

    Senden ging auch noch nicht,

    aber die Adressvorschläge aus meinen anderen Adressbüchern kamen nach wie vor auch noch bei Eingaben in der To:-Zeile.


    Jetzt hat TB (natürlich) eine neue abook.sqlite mit aktueller Uhrzeit und nur 256 kB angelegt (zuvor 640).

  • Mein Beitrag hätte evtl. hilfreich sein können. :/

    Ich selbst habe keine Probleme mit egal welcher TB-Version, 78.x 91.x oder Beta.

    Alle funktionieren klaglos.

    Gruß, Bastler

  • > aber die Adressvorschläge aus meinen anderen Adressbüchern kamen nach wie vor auch noch bei Eingaben in der To:-Zeile.

    Wo soll TB die den her haben? Ich bin ratlos.


    Was passiert wenn du die gesicherte abook.sqlite in dein neues (funktionierendes) Profil kopierst?

  • Ich habe noch mehrere Adressbuchdateien gefunden (zumindest bei den *.bak kann man sie ja im Klartext lesen)


    impab.mab.bak

    impab-1.mab.bak


    history.mab.bak

    history.mab-1.bak

    history.mab-2.bak

    history.mab-3.bak

  • aber die daraus resultierenden *.sqlite habe ich gerade alle aus dem Verzeichnis eliminiert.

    Wiederum keine grundlegende Änderung, außer dass die eMail-Ergänzungsvorschläge bei Eingabe einer Adresse nicht mehr kamen.

    Aber dennoch kein Senden und absolut leere Fenster im Adressbuch.


    Aber noch was getestet:

    Adressen anlegen geht nicht

    Neues Adressbuch anlegen - Abfrage nach Namen kommt, ich gebe "Test" ein -> es erscheint aber nichts im Fenster.

    Nochmal ein neues Adressbuch "Test" anlegen -> es kommt die Warnung, dass Test schon existiert - aber es erscheint immer nocht nichts im Fenster.

  • und alle Adressbuch *.sqlite in das neue Test-Profil kopiert:

    es funktioniert alles planmäßig!

    Sowohl Senden, als auch die Anzeige der Adressbücher ...

  • Wie hoch ist für dich der Aufwand, nun das neue Profil komplett neu einzurichten (Adressbücher sind ja jetzt schon anscheinend erfolgreich kopiert), sodass du wieder normal arbeiten kannst? Ich weiß nicht, ob wir den Kniff finden, das kaputte Profil wieder hinzukriegen.


    Parallel dazu würde ich dich bitten, das kaputte Profil (oder eine Kopie davon) soweit zu reduzieren (alle E-Mail-Knoten und Passwörter entfernen), sodass es keine sensitiven Daten mehr enthält und du es mir zusenden kannst, damit ich das hier auseinandernehmen kann, um das eigentliche Problem zu identifizieren, falls das möglich sein sollte. (Ich bin Thunderbird / MZLA Entwickler)