IMAP und Schlagwörter

  • Hallo zusammen,
    es gab schon ein paar Beiträge zu dem Thema, leider wurde nirgends abschließend beantwortet, wo und wie die Schlagwörter (Tags) an den Mails gespeichert werden. Offenbar schon auf dem Server und hoffentlich nicht in den Indexdateien.
    Weiß jemand genaueres?
    Wir hier in der Firma eine ganze Weile in einem gemeinsamen IMAP-Ordner damit gearbeitet, hatten eigene Schlagwörter definiert, und heute waren nun (fast) alle weg. Ich bin begeistert...
    Ich hoffe mal, daß Komprimieren und Reindizieren nicht schadet...?
    War es das Update auf 2.0.0.16? Noch haben nicht alle die aktuelle Version.
    Hat jemand eine Idee?
    Gruß, m.

  • Hi muzel, guten Abend!


    Ich habe jetzt mal kurz eine rumprobiert und eine Testmail verschlagwortet und das wieder retourniert und dabei jeweils die *.msf in den Editor geladen und dann verglichen...Zahlenwust seinesgleichen :aerger:
    Aber unter 8E oder 8F scheinen Tags markiert zu werden, Tags aus der Liste nach dem 5 Eintrag namentlich, davor scheinbar mit Kennziffer.
    Ich habe leider keine Zeit mehr das jetzt genau zu testen.
    Die Änderung wurde jeweils erst nach einem Reindex sichtbar.
    Sollte man sich mal mit etwas Zeit vornehmen.
    So, ich habe jetzt noch Kundentermine und wünsche einen schönen Abend!

  • Danke rum,
    wie gesagt, wenn die Tags nur in den Indexdateien stecken würden, hätte es nie funktionieren können. Hat es aber. Einer hat sein Schlagwort gesetzt, und alle haben es gesehen. Es gibt also ein Flag in der Mailbox, dokumtiert oder nicht...
    Was mir Sorgen macht, sind Bugzilla-Einträge wie dieser:
    https://bugzilla.mozilla.org/show_bug.cgi?id=392510
    Und, es scheint vom Mailserver abzuhängen, ob es funktioniert. Wenn es ein undokumentiertes Feature ist, kann es sich auch mal unverhofft, z.B. bei einem Update der Serversoftware, in Luft auflösen.
    Vielleicht sollte man die Finger von den Tags lassen, jedenfalls als Werkzeug auf einem IMAP-Server.
    Gruß, muzel

  • Hi muzel, guten Morgen.


    Ich werde, falls mich mein von sporadischen, allzheimerähnlichen Anfällen geprägter Schaltkasten nicht daran hindert, später mal einen Test auf einem wenig genutzten 1&1 Konto machen.

  • Test1:
    Ich habe eine paar Mails an eines meiner Konten geschickt und sie in TB nach dem Abholen dann mit einem Schlagwort versehen.
    Dann habe ich TB mit mein Testprofil gestartet und dort sowohl dieses bisher da nicht vorhandene Konto angelegt, als auch Schlagwörter angelegt, so dass in beiden Profilvarianten gleiche Bedingungen vorliegen.
    Tja, nach dem Abrufen mit dem zweiten Profil weiß TB allerdings nichts von den Schlagworten.
    Wenn ich aber im ersten Profil die Mails von einem IMAP per kopieren oder verschieben in ein anderes befördere, sind die Schlagwörter weiterhin vorhanden... :gruebel:


    *ähem, muss ich das jetzt verstehen...?*

  • Hallo,
    eins ist aber sicher: wird die *.msf gelöscht, sind auch die Schlagwörter weg. Das hatte ich gestern für einen anderen Thread getestet. Die werden meines Erachtens nur intern als Schlagwörter gekennzeichnet.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Nun, mrb, diese Aussage hat leider Blümchens Charakter

    Zitat


    eins ist aber sicher:

    denn das ist alles relativ, das mit dem sicher...


    Also, auf Grund deiner Aussage nun Test 2, und jetzt wird es interessant:


    - ich erhalte eine Benachrichtiguns Mail aus dem Forum, die wird automatisch verschlagwortet und ist dann grün markiert.
    - ich setze TB offline und deaktiviere den Filter
    - ich beende TB und lösche die msf im Profil
    - ich starte TB, gehe online und rufe ab


    die Mail wird abgeholt und ist jetzt immer noch verschlagwortet... und, jetzt kommst gleich mehrfach:


    - eine neu eingehende Mail wird nicht verschlagwortet, der Filter ist also wirklich deaktiviert


    was mich zu einem weiteren Test animiert:


    - ich gehe so vor wie oben, jedoch nach (!) dem Offline schalten entferne ich das Schlagwort und beende dann erst TB... beim Abruf ist sie verschlagwortet :mrgreen:


    Und wenn ich jetzt die Ergebnisse von Test 1 und Test 2 zusammenfasse, verstehe ich gar nichts mehr.


    Laut Test 1 kann der Tag eigentlich nicht auf dem Server sein, sonst hätte die Mail im Testprofil ebenfalls verschlagwortet sein müssen.
    Laut Test 2 muss der Tag eigentlich doch auf dem Server sein, sonst hätte die Mail nach dem Löschen der msf nicht mehr verschlagwortet sein können.



    *während dem davon Schleichen vor sich hin sinnierend, warum, weshalb, wofür und ob überhaupt er Schlagworte braucht*

  • Weißt du was? Ich glaube, mich trifft der Schlag. Darum der Wörter genug.


    Ich vermute irgendwo einen Bug, denn dieses Verhalten kann nicht im Voraus beim Programmieren berücksichtigt worden sein. Es gibt ja auch keinen Anhalt in der Mail selbst auf ein Schlagwort oder doch?
    Falls nein, muss es noch ein weiteres Zusammenspiel zwischen msf und anderen Dateien geben.
    Hier hört dann aber mein detektivischer Wissensdurst auf. ;) 
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ohne momentan bei Schlagworten noch so richtig durchzublicken: Als man das Feature eingebaut hat, habe ich mit mscott und Bienvenue in mehreren Bugs "herumgekämpft", da mir die Schlagworte teilweise immer wieder abhanden gekommen sind. Dabei stellte sich heraus, dass meine IMAP-Postfächer bei Hosteurope leider die Schlagworte verlieren. Bei web.de / Freemail dagegen ging es ohne Probleme.

    Gruß
    Thunder


    Keine Forenhilfe per Konversation! - Danke für Euer Engagement und Eure Geduld!

  • Hallo zusammen,
    ich denke, wir können das Thema abschließen, weil die Lösung zwar interessant wäre, aber für mich zu spät käme.
    Danke und Gruß, muzel

  • Tach Gemeinde,


    ich kann auch noch eine nette Annekdote hinzufügen.
    Folgende Konfiguration 5 User mit eigenen Postfächen, 1 IMAP Postfach auf das alle zugreifen. ( bei 1 und 1)
    TB Version Version 2.0.0.21 (20090302)
    In diesem Fach soll mit Schlagwörtern gearbeitet werden.
    Also bei allen die bestehenden gelöscht und neu angelegt.
    Wenn ein User eine Email mit Schalgwort versieht , benennt jedes Thunderbird der einzelnen User das Schlagwort nach eigenem Gutdünken wieder um :-) nach ca 2 min. Und zwar nutzt er die default namen der Schalgworte die bei Erstinstallation verwendet wurden.... wunder wunder obwohl diese glöscht sind....


    Frage : Wie wichtig ist die Nummerierung 1- 9 in den default Schalgworten?
    Kann ich erst "eigene " kreieren bei Anzahl über 10 ?
    Ich weiß Fragen über Fragen:-)


    Gruss Der Jelzin

  • Ich hole den uralt-Thread nochmals hoch ...


    Einfaches Szenario:


    Client 1 vergibt ein neues Schlagwort
    Client 2 sieht das Schlagwort nicht


    Beide Konten natürlich als IMAP eingebunden. Wo soll die Fehlersuche beginnen?

  • Das muss ich leider nochmal hoch schieben ... hat denn niemand das gleiche Problem?

  • Dabei stellte sich heraus, dass meine IMAP-Postfächer bei Hosteurope leider die Schlagworte verlieren. Bei web.de / Freemail dagegen ging es ohne Probleme.

    Vielleicht hängt es wirklich am Server. Ich habe es gerade für ein GMX-Konto ausprobiert. Dort funktioniert es ebenfalls. Setzen oder Löschen eines Schlagwortes auf dem einen Client zeigt sich dann auch auf den anderen.

  • Hallo!


    Ein kurzer Test mit Thunderbird 44 Beta zeigt mir, dass es weiterhin wie "damals" ist.


    1) Die 5 Standard-Schlagwörter werden direkt im anderen Client bei IMAP-Konten angezeigt.
    2) Ein selbst vergebenes, neues Schlagwort, wird in den anderen Clients an den betreffenden Mails nur gezeigt, wenn ich dieses (Buchstaben-identische) Schlagwort in den anderen Clients auch definiert habe. Die Reihenfolge der Definition spielt bei mir dabei keine Rolle


    Getestet habe ich auf die Schnelle mit GMX, Web.de, Gmail, Hosteurope und meinem eigenen Server, auf dem Dovecot als IMAP-Server läuft.

    Gruß
    Thunder


    Keine Forenhilfe per Konversation! - Danke für Euer Engagement und Eure Geduld!