Profil-Ordner wird nicht erkannt


  • Nach einem Datenverlust habe ich den Profil-Ordner (auf den die profiles.ini zeigt) wiederhergestellt. Thunderbird erkennt ihn aber wohl nicht und verhält sich (ohne Fehlermeldung), als wäre er leer (bietet an, eine neue E-Mail-Adresse anzulegen). Woran kann das liegen?


    Es läuft die Version Icedove 31.3.0 auf Debian 8.

  • Hallo switzel,


    TB erkennt nicht per se, dass dort ein Profilordner liegt. Die Profiles.ini muss auf diesen Ordner verweisen. TB hat nun einen neuen Profilordner angelegt und der ist natürlich leer.


    Du hast zwei Möglichkeiten: Entweder bearbeitest Du die profiles.ini, so dass sie auf den alten Profilordner verweist oder Du änderst den Namen des alten Profilordners in den Namen des neuen (der natürlich dann gelöscht werden oder anders heißen muss).


    Gruß

    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 64 Bit / Thunderbird 32 Bit / Firefox 64 Bit

  • Hallo,

    Nach einem Datenverlust habe ich den Profil-Ordner (auf den die profiles.ini zeigt) wiederhergestellt.

    Das ist eine sehr vage Beschreibung, die man vielseitig interpretieren kann.

    Wenn Thunderbird sich derzeit beim Start verhält wie bei einer Erstinstallation und dazu auffordert, ein Konto zu erstellen, bedeutet das, dass er zwar ein Profil vorfindet, dieses Profil aber noch jungfräulich ist (d. h. es wurde noch kein Konto erstellt) oder eine korrupte prefs.js Datei enthält.


    War das Thunderbird-Profil vom Datenverlust betroffen?

    Hattest du eine Sicherungskopie des Thunderbird-Profils?

    Wurde ein völlig neues Profil erstellt?

    Kannst du genau beschreiben, wie du "den Profilordner wiederhergestellt" hast?



    Gruß

    Mapenzi

  • Hallo,


    in Ergänzung zu slengfe und Mapenzi: wurde das Profil wirklich in den angegebenen Ordner kopiert oder möglicherweise in einen Unterordner davon o.ä.? Das passiert hin und wieder ...


    MfG

    Drachen

  • Hallo,


    Die Situation ist die folgende: die profiles.ini zeigt auf einen bestimmten Ordner, die Daten in dem Ordner wurden gelöscht, die Daten in dem Ordner wurden wiederhergestellt. Die profiles.ini zeigt immer noch auf den Ordner, der jetzt nach meine Wahrnehmung im Ursprungszustand ist, aber Firefox tut so als wäre er leer.


    Zitat

    War das Thunderbird-Profil vom Datenverlust betroffen?


    Nein.


    Zitat

    Hattest du eine Sicherungskopie des Thunderbird-Profils?


    Der profiles.ini? Nein, die könnte ich ja zur Not selbst wieder schreiben.


    Zitat

    Wurde ein völlig neues Profil erstellt?

    Nein.


    Zitat

    Kannst du genau beschreiben, wie du "den Profilordner wiederhergestellt" hast?

    Wenn A der Pfad zum Profilordner ist und B der Pfad mit dem Backup mit


    Code
    1. cp -ar A B


    Gruß,

    Stefan

  • Hallo,

    Zitat

    Hattest du eine Sicherungskopie des Thunderbird-Profils?

    Der profiles.ini? Nein, die könnte ich ja zur Not selbst wieder schreiben.


    Mapenzi meint sicher nicht die profiles.ini sondern den kompletten Profilordner.

    Dieser enthält ja die profiles.ini schon von sich aus.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • die Daten in dem Ordner wurden gelöscht, die Daten in dem Ordner wurden wiederhergestellt.

    Ich nehme einfach mal an, bei dem "Ordner" handelt es sich um den Profilordner "xxxxxxxx.default" (oder ähnlich).

    Also gingen die Daten im Profilordner verloren und du hast sie wieder hinein kopiert. Woher, das wissen wir nicht, da Du uns aber immer noch nicht verraten hast, ob du eine Sicherung des Profilordners "xxxxxxxx.default" oder des kompletten Ordners "thunderbird" hast. Wir wissen auch nicht, ob du POP- oder IMAP-Konten eingerichtet hattest.

    Wenn du nur IMAP benutzt hast, dann würde ich sagen, richte deine Konten wieder als IMAP ein und danach solltest du alle deine Ordner und Nachrichten wieder finden.

    Wenn A der Pfad zum Profilordner ist und B der Pfad mit dem Backup mit

    cp -ar A B

    Leider verstehe ich nicht, was das bedeuten soll.


    Fall du POP benutzt hast: damit wir einen Schritt weiter kommen, solltest du möglichst screenshots mit dem Inhalt deines aktuellen Profilordners einstellen.

  • Hallo Mapenzi,


    Leider verstehe ich nicht, was das bedeuten soll.


    zum besseren Verständnis: cp(1) - Linux manual page.


    Gruß

    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • Danke für den Link, Feuerdrache.

    Für mich bleibt das trotzdem weiterhin graue Theorie, und ich glaube, jetzt müsst ihr Linux-Männer mal übernehmen ;)

    Jetzt sehe ich auch noch, dass es sich um eine alte Version von Icedove handelt. Da bin ich draußen...

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Mapenzi ()

  • Soweit ich sehe, hat nichts davon etwas mit dem Problem zu tun, aber der Vollständigkeit halber hier also das volle Setup. Innerhalb des Benutzerverzeichnisses /home/user gibt es einen Unterordner .icedove (bzw. nach Update .thunderbird) mit einer Datei profiles.ini in der Folgendes steht:


    [General]

    StartWithLastProfile=1


    [Profile0]

    Name=default

    IsRelative=0

    Path=/home/user/external/mail


    Der Pfad /home/user/external ist der Mountpoint einer Daten-Partition. Der Datenverlust geschah auf dieser Partition. Der Ordner /home/user/.icedove war davon nicht betroffen und hat aller Wahrscheinlichkeit nach schon länger keinen Schreibzugriff erfahren. Der Ordner /home/user/external/mail ist derjenige der verloren gegangen ist und (nach meinem Dafürhalten) identisch wieder hergestellt wurde.

  • Ich hänge mich hiermal ran, da ich ähnliche Probleme habe/hatte.

    Nach dem letzten update auf 52.4.0 unter Debia (der Übergang von Icedove zu Thunderbird ist doch schon ein Jahr alt?) lief gar nichts mehr.


    Die überhaus nutzlose Meldung Another instance of thunderbird is aready running stoppte jeden Versuch, das Programm zu starten. Erst das Löschen des Profilordners erlaubte wieder den Start, natürlich ohne meine Accounts und emails ...


    Es stellte sich heraus, das der Profilordner im home-Verzeichnis liegen MUSS! Alle Versuche scheiterten, den Ordner woanders abzulegen. Pfadangaben in der profile.ini wurden ignoriert. Dieses Problem tauchte im Internet immer wieder seit einiger Zeit sporadisch auf.


    Damit sollte es erstmal klappen:

    1) den Profilordner an das voreingestellte Verzeichnis kopieren: /home/user/.thunderbird

    2) in der profiles.ini: IsRelative=1 und als Pfad NUR den Dateinamen des Profils angeben


    Für mich ist die Sache allerdings gegessen, das Programm ist unbrauchbar gemacht worden.


    Gruß

    Andresz