Option zum Speichern des Passworts fehlt

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 60.7.1 portabel
    • Betriebssystem + Version: Windows 7
    • Kontenart (POP / IMAP): POP
    • Postfach-Anbieter (z.B. GMX): GMX
    • Eingesetzte Antiviren-Software: 360 Total Security Premium
    • Firewall (Betriebssystem-intern/Externe Software): intern
    • Router-Modellbezeichnung (bei Sende-Problemen): Fritz!Box 7490


    Nach der Änderung des Passworts beim Postfachanbieter GMX muss jedes Mal das neue Passwort eingegeben werde. Die Option zum Abspeichern erscheint nicht.


    Die Suche im Internet nach Abhilfe war fruchtlos.


    Was tun?, sprach Zeus. Und hofft, im diesem Kreise eine Antwort zu finden.


    :)


    RW

  • graba

    Approved the thread.
  • Hi,

    wie sieht denn die Dialogbox zur Passworteingabe aus? Da sollte doch ein Häkchen bei "Speichern im Passwortmanager" gesetzt werden können?

    Ist vielleicht noch das alte Passwort gespeichert (bzw. die Passwörter, für Senden und Empfangen)?

    Gruß, muzel

  • "Speichern im Passwortmanager" kommt nicht vor. Nur "Geben Sie Ihr Passwort für ... auf ... ein:".


    Wenn das alte Passwort noch gespeichert ist, wo ist es gespeichert? Es gibt nur noch den Eintrag im Postausgangsserver, doch da ist kein Passwort.


    Ich bin völlig ratlos, nachdem Thunderbird jetzt bestimmt zehn Jahre reibungslos funktioniert hat.


    :)


    RW

  • Der Tipp mit dem Umbenennen der Passwortdatenbank ist mir nicht neu. Für mich würde er das Problem jedoch nicht lösen, da ich mehrere Mail-Accounts habe, genau genommen eine ganze Menge. Mit einer frischen Datenbank müsste ich alle Anmeldedaten wieder parat haben. Doch das ist bei mindestens einem Konto, bei dem bei einem russischen Anbieter, nicht der Fall.


    Bevor ich mich da also bewusst aussperre, lasse ich's so, wie es ist – händisches Eingeben eines Passworts –, und hoffe auf die richtige Lösung. Denn die muss es geben, nur bin ich nicht informiert genug, um zum Beispiel in der Konfiguration irgendwelche Werte zu verändern.


    :)


    RW

  • Hallo,


    guck mal

    Extras - Einstellungen - Sicherheit - Passwärter - Gespeicherte Passwörter - Passwörter anzeigen - mit 'Ja' quittieren


    Viel Glück

    Herbert

  • Herbert


    Bingo, das isses. Da ist das Passwort für das russische Mailkonto!


    Jetzt die Passwortdatenbank erneuern, und alles läuft wieder wie die vielen Jahre vorher.


    Danke für diesen Tipp zum besten Mail-Programm ever.


    :)


    RW

  • @all


    Pech. Da wird keine neue signons.sqlite angelegt, stattdessen eine Datei namens


    .startup-incomplete


    mit 0 Byte Größe.


    Und am Verhalten von Thunderbird ändert sich nichts. Nur das ursprünglich geänderte Passwort hat es vergessen. Alle anderen sind noch da.


    Die Passwörter müssen woanders abgelegt sein. Doch wofür ist dann die signons.sqlite?


    Wer weiß jetzt noch weiter?


    :)


    RW

  • Hallo,

    Die Passwörter müssen woanders abgelegt sein. Doch wofür ist dann die signons.sqlite?

    Sie werden in der Tat seit einigen Jahren in einer anderen Datei gespeichert, nämlich in "logins.json" !

    Die Datei signons.sqlite ist schon lange nicht mehr aktuell, auch wenn sie heute noch als Relikt in älteren Profilen zu finden ist.
    Beim Ubergang von signons.sqlite zu logins.json wurde im Konfig-Editor die neue Einstellung "signon.importedFromSqlite" geschaffen, deren Wert automatisch auf "true" wechselte, wenn der Import der PW aus der alten Datei abgeschlossen wurde.



    Du kannst jetzt folgendes versuchen:

    • zeige den Profilordner an und beende TB,

    • benenne die Datei logins.json um in logins.json-old,

    • mache eine Sicherungskopie der Datei prefs.js, dann öffne das Original der Datei und in der Zeile user_pref("signon.importedFromSqlite", true); ersetze true" durch false; speichere die Änderung.


    Starte TB wieder und überprüfe, ob im Profil eine neue Datei logins.json angelegt worden ist. Wahrscheinlich wird TB wieder melden, dass das (inzwischen geänderte) Passwort des GMX-Kontos nicht richtig ist. Wenn wieder keine Option zum Speichern des neuen Passworts erscheint, gehe in Extars > Einstellungen > Sicherheit > Passwörter > Gespeicherte PW > PW anzeigen, mache einen Doppelklick auf das alte Passwort und füge das neue Passwort ein.


    Gruß

  • @Mapenzi


    Das hört sich sehr sachverständig an und verspricht den Ausweg aus meiner vertrackten Lage. Am Wochenende werde ich Zeit haben, das nachzuvollziehen.


    Bis zur Erfolgsmeldung dir und den anderen Thunderbird-freunden ein schönes we.


    :)


    RW

  • Am Wochenende werde ich Zeit haben, das nachzuvollziehen.

    Der von mir vorgeschlagene Workaround kann natürlich nur dann gelingen, wenn sich die alte Datei signons.sqlite noch in deinem Profilordner befindet.

    Ebenfalls ein schönes W-E.

  • Mapenzi


    Ich habe alles nach deiner Anweisung gemacht. Die Abfrage, ob das Passwort gespeichert werden soll, erscheint immer noch nicht. Dennoch klappt jetzt alles (Vielen Dank dafür!) bis auf ein Konto, das unter Extras > Einstellungen > Sicherheit > Passwörter > Gespeicherte PW fehlt.


    Wie kann ich die passenden Zeilen dort einfügen?


    :)


    RW

  • Dennoch klappt jetzt alles (Vielen Dank dafür!) bis auf ein Konto, das unter Extras > Einstellungen > Sicherheit > Passwörter > Gespeicherte PW fehlt.

    Das ist doch die selbe Situation wie du sie im ersten Beitrag geschildert hast, dann war die von mir vorgeschlagene Manipulation also völlig umsonst.


    Wenn du in den Einstellungen > Sicherheit den Passwort-Manager öffnest und die Passwörter einblendest, dann hast siehst du ungefähr das folgende Fenster:



    Wird denn das GMX-Konto, für das du das PW geändert hast, in dieser Liste überhaupt nicht angezeigt oder fehlt nur das Passwort, weil bei der Abfrage kein Kästchen zum Speichern des PW angezeigt wird?

    Ein Passwort ändern im Passwort-Manager ist kein Problem, aber eine "Webseite" bzw. einen Benutzernamen dort neu hinein zu zaubern geht nicht.


    Also stehen wir offenbar wieder vor dem selben Problem wie zu Anfang. Hast du denn schon überprüft im Konfigurations-Editor (Einstellungen > Erweitert > Allgemein), ob der Wert der Einstellung "signon.rememberSignons" auf "true" steht? Falls der Wert "false" ist, wird die Checkbox nicht angezeigt.


    Ich habe eben noch diesen MozillaZine KB Artikel http://kb.mozillazine.org/Pass…embered_%28Thunderbird%29 gefunden. Im Absatz No checkbox to remember passwords wird empfohlen, bei trotz "signon.rememberSignons" = "true" fehlender Checkbox die drei Dateien logins.json, key4.db und cert9.db zu entfernen und TB neu zu starten.

  • @Mapenzi


    Das war's.


    Nämlich im Konfigurations-Editor (Einstellungen > Erweitert > Allgemein) den Wert der Einstellung "signon.rememberSignons" auf "true" zu setzen, damit die Checkbox wieder angezeigt wird. Vielleicht hätte damit schon nach meinem ersten Posting alles wieder geklappt. Vielleicht war es aber besser zu warten, bis du empfehlen konntest, zusätzlich die drei Dateien logins.json, key4.db und cert9.db zu entfernen und danach TB neu zu starten.


    Jetzt läuft alles wieder flüssig. Und ich habe wieder die volle Thunderbird-Freude, die ich schon so viele Jahre schätze.


    Danke.


    :)


    RW

  • Das war's.

    Nämlich im Konfigurations-Editor (Einstellungen > Erweitert > Allgemein) den Wert der Einstellung "signon.rememberSignons" auf "true" zu setzen, damit die Checkbox wieder angezeigt wird.


    Das wäre vermutlich von Anfang an die richtige und die einfachste Lösung gewesen.

    Ich war erst nach mehrtägiger Abwesenheit in dein Thema eingestiegen und hatte aus unerfindlichen Gründen die ganze Zeit geglaubt (obwohl die entsprechende Frage noch von niemanden gestellt worden war), dass der Wert der Einstellung signon.rememberSignons bei dir auf true steht, so wie es standardmäßig der Fall ist, wenn ein Thunderbird-Profil erstellt wird.


    Na schön, dass das Kästchen wieder da ist und damit auch dein Problem gelöst ist. Und danke für die Rückmeldung!! :)

  • @Mapenzi


    Nach ein paar Durchläufen – ich sagte schon, dass ich eine Menge Mail-Accounts habe – funktioniert alles wie am Schnürchen. Dieses Problem scheint endgültig gelöst zu sein, und ein anderes habe ich mit Thunderbird nie gehabt. Also nochmal vielen Dank für deine Hilfe.


    Dass du nicht gleich mit dem richtigen Tipp zur Stelle sein konntest, hat mich nicht umgebracht. Bei der Gelegenheit habe ich meine Kenntnisse vertieft, Texte über ein Kurzkommando abzurufen.


    Daneben habe ich immerhin ein bisschen über Thunderbird gelernt. Ich sehe das also positiv.


    Nochmals danke.


    :)


    RW

  • Dass die genannte Option auf "false" steht, kann eine Folge von ursprünglich importierten Einstellungen aus Outlook bzw. früher Outlook Express sein.


    Übrigens hilft in diesem Fall auch mein Add-on "Abrufen/Senden-Schaltfläche", womit man die genannte Option wieder anzeigen lassen kann.