Thunderbird 68.x Mac / Befehle im Thunderbird-Menü funktionieren nicht

    Hallo Micha, Hallo Mapenzi


    danke für die Aufklärung, aber den Begriff "Hamburger"-Menü habe ich noch nie gehört.


    Quote

    Hamburger-Button ist ein Spitzwort für den AppMenu-Button, der sich in der Regel rechts irgend wo in der Hauptsymbolleiste befindet:


    im „Hamburger“-Menü funktioniert der Befehl „Einstellungen“ auch mehrfach.


    Quote

    Desgleichen wiederhole ich meine Frage, ob die entsprechenden Tastenkürzel (siehe oben) ebenfalls nicht reagieren. Man kann nämlich das Thunderbird-Menü praktisch völlig beiseite lassen, indem man Tastenkürzel und/oder das AppMenu benutzt.


    Die Tastaturkürzel funktionieren nur nach dem Neustart von Thunderbird genau 1x, dann reagieren sie nicht mehr.


    Quote

    Wenn du das Thunderbird-Menü anzeigst und mit dem Mauszeiger über die einzelnen Befehle gleitest, werden diese blau (oder mit einer anderen von dir gewählten Farbe) hinterlegt wie in meinem folgenden Screenshot oder tut sich auch da nichts?


    Ja, die Befehle werden beim Drüberfahren Blau eingefärbt.


    Quote

    Wenn du dagegen mit der Version 68.3.1 arbeiten willst, kann ich dir weiterhin helfen, das Problem zu untersuchen.


    Ich habe natürlich schon ein Interesse immer mit der aktuellsten Version zu arbeiten, zumal ich Thunderbird wohl schon wenigstens 20 Jahre als zuverlässiges Programm kenne.


    Viele Grüße Peter

  • im „Hamburger“-Menü funktioniert der Befehl „Einstellungen“ auch mehrfach.

    ... ja natürlich, einmal global für den TB und einmal für die Konteneinstellungen, einfach mal einen Mausklick drauf.


    Gruß Micha


    Mein Mailclient ist der portable TB mit der derzeit aktuellsten Version :bindafuer:

  • Die Tastaturkürzel funktionieren nur nach dem Neustart von Thunderbird genau 1x, dann reagieren sie nicht mehr.

    Es kommt vielleicht darauf an, um welche Befehle es sich handelt. Wenn du ⌘ + Q drückst, dann funktioniert das eben ein Mal, da TB dann beendet wird. Wenn du ⌘ + Komma drückst, werden die Einstellungen (von TB) in einem Tab geöffnet. Wenn du später erneut ⌘ + Komma drückst wieder, wird kein neues Tab geöffnet, sondern TB wechselt vom gerade aktiven Tab in den Tab "Einstellungen". Und wenn du auf das Menü "Thunderbird" > "Über Thunderbird" klickst, passiert gar nichts?

    Mir ist das nach wie vor schleierhaft, und ich bitte dich, den Test in einem neuen Profil zu machen. Sonst können wir noch Wochen lang so weiter diskutieren.

    Hallo Mapenzi,


    ich habe jetzt nach der von Dir vorgeschlagenen Beschreibung ein neues Konto angelegt und zwar nicht über das Terminal, sondern der im Kapitel 4 beschriebenen Weise für Thunderbird ab Version 52.


    Mit dem neuen Profil funktionieren alle Befehle im "Thunderbird"-Menü, auch mehrfach, so wie es sein soll.


    Wie geht es nun weiter ?


    Viele Grüße Peter

  • Hallo ihr beide,


    bei mir funktioniert Im alten, offenbar fehlerhaften Profil bei Benutzung des "Hamburger-Menü" alles normal.

    ⌘ + Q funktioniert dort auch. ⌘ + , : keine Reaktion.

    Nach Erstellung eines neuen Profils funktioniert alles normal.

    Der Fehler liegt also offenbar irgendwo im Update auf 68.3.1, anscheinend wird da unter bestimmten Bedingungen eine Datei im Profilordner zerschossen.

    Hallo Donnerstag,


    es könnte natürlich auch sein, dass das Problem im "Mail"-Ordner liegt, deshalb warte ich noch, was Mapenzi mir rät, wie es weiter gehen soll.


    Viele Grüße Peter

  • Wie geht es nun weiter ?

    Richte eines deiner POP-Konten ein (das Standard-Konto?), ohne in seinen Server-Einstellungen die Standard-Einstellung der 14-Tage-Frist des Belassens auf dem Server zu ändern. Damit kannst du vorerst die selben Mails nochmal in deinem derzeitigen Standard-Profil abrufen.

    Teste das Menü erneut nach Einrichten des Kontos.


    Wenn alles OK ist, versuche eines der bisher von dir benutzten Add-ons zu installieren und teste erneut die Menüs. Installiere nur Add-ons, die mit der Version TB 68.* kompatibel sind.

    Wenn sich der Fehler nicht wiederholt, könnte man die anderen Konten einrichten und danach bei beendetem TB die verschiedenen Kontenordner wie "pop.xxx.xx", "pop.xxx-1.xx", "pop.yyy.xx", ... usw. aus dem Ordner "Mail" des alten Profilordners in den Ordner "Mail" des neuen Profilordners kopieren.

    Solltest du auch in den Lokalen Ordnern Nachrichten gespeichert haben, müsste natürlich auch der Ordner "Local Folders" aus dem Ordner "Mail" des alten Profilordners in den Ordner Mail des neuen Profilordners kopiert werden.


    Desgleichen würde man die Adressbuch-Dateien abook.mab, history.mab, falls vorhanden auch impab.mab, abook-1.mab, .. usw. aus dem alten Profilordner in den neuen Profilordner übertragen.


    Am Ende sollte das neue Profil die selben Konten, Ordner, Nachrichten, Adressbücher, Kalender (falls Lightning genutzt wird), Filter, ... usw. wie das alte Profil enthalten, und du könntest dann ausschließlich mit dem neuen Profil arbeiten.

    Hallo Mapenzi,


    ich glaube ich habe es geschafft. All meine Mails der letzten 10 Jahre sind im neuen Profil.

    Im "Thunderbird"-Menü funktioniert alles wie es sein soll.

    Alle Befehle sowie die Tastaturkürzel funktionieren, auch mehrfach.


    Soweit war ich ja schon einmal, habe aber damals nicht den Profil-Manager benutzt um ein neues Konto anzulegen.

    Dann schauen wir mal ob es so bleibt.


    Dir möchte ich meinen ganz herzlichen Dank aussprechen, für Deine Kompetenz und Geduld !!!


    Viele Grüße Peter

  • Soweit war ich ja schon einmal,

    Wahrscheinlich, aber ohne ein wirklich neues jungfräuliches Profil erstellt zu haben. Denn sonst hätte sich der Fehler ja nicht wiederholt.

    Man sollte in solchen Fällen wirklich strikte Test-Protokolle benutzen, deine 50%-Methode ist einfach nicht nachprüfbar, so verführerisch einfach sie auf den ersten Blick auch sein mag.

    All meine Mails der letzten 10 Jahre sind im neuen Profil.

    Das ging ja flott :)

    Wenn dein altes Profil ebenfalls 10 Jahre alt ist, würde mich nicht überraschen, dass jetzt ein Fehler aufgetreten ist, insbesondere nach einem größeren Update wie dem auf TB 68.*.


    Lösche dein altes Profil noch nicht, oder wenn, dann lösche nur das Profil (im Profil-Manager) und nicht den zugehörigen Profilordner. Es könnte durchaus sein, dass dir in den nächsten Tagen noch auffällt, dass irgend etwas fehlt.

    Ich denke an solche Dinge wie die Trainingsdaten des TB Junkfilters (Datei training.dat), selbst erstellte Adressbücher (abook-x.mab), Kalender (Ordner calendar-data), ....


    Dann weiterhin ein angenehmes Arbeiten mit dem "neuen" Thunderbird!

  • Dann werd ich das auch mal versuchen.

    Frage: Nach der Erstellung des neuen Profils, der Einrichtung der Konten und dem darauf folgenden Kopieren der alten Konten-Ordner in den neuen Mail-Ordner "zusammenführen" oder "ersetzen" der Dateien wählen?

    Wenn ich die Konten-Ordner aus dem alten in das neu erstellte Profil kopiere, sind da ja schon die Konten-Ordner meiner ebenfalls neu eingerichteten Konten drin. Die waren bei einem ersten Test gestern auch teilweise anders automatisch benannt, obwohl die Server-Daten dieselben sind.

    Ist es dann sinnvoller, die neuen Konten umzubenennen mit dem Namen der alten und dann durch die alten Konten zu ersetzen? Oder lieber den neuen Konten-Namen beizubehalten und nur die Inhalte der Konten reinzukopieren, wobei die bereits darin befindlichen Dateien wie xxx.msf, Inbox etc. ja auch ersetzt oder vorher gelöscht werden müßten?

  • Nach der Erstellung des neuen Profils, der Einrichtung der Konten und dem darauf folgenden Kopieren der alten Konten-Ordner in den neuen Mail-Ordner "zusammenführen" oder "ersetzen" der Dateien wählen?

    Bei mir gibt es kein "Zusammenführen" der Inhalte von zwei Ordnern mit den selben Namen. Ich habe nur "Ersetzen" oder "Abbrechen".

    Und selbst wenn man z. B. zwei Inbox-Dateien einfach miteinander "verschmelzen" könnte, dann hättest du mehr oder weniger Duplikate, in Abhängigkeit von der eingestellten Verweildauer von schon abgerufenen Mails auf dem Server. Aber meines Erachtens ist ein Zusammenführender alten und neuen Kontenordner nicht nötig (siehe unten), wenn du nicht mehrere Wochen zum Erstellen des neuen Profils brauchst..

    Wenn ich die Konten-Ordner aus dem alten in das neu erstellte Profil kopiere, sind da ja schon die Konten-Ordner meiner ebenfalls neu eingerichteten Konten drin.

    Ich würde bei beendetem TB die neu erstellten Kontenordner vom Typ "pop.xxx.xx" (oder "securepop.xxx.....) durch die entsprechenden gleichnamigen Kontenordner aus dem alten Profil ersetzen. Das kann natürlich etwas kompliziert werden, wenn du z. B. fünf verschiedene (echte) E-Mailadressen beim selben Postfachanbieter hast. Dann werden fünf verschiedene Kontenordner "pop.gmx.net", "pop.gmx-1.net" , .... bis "pop.gmx-4.net" erstellt, und wenn du die Konten im neuen Profil nicht in der selben Reihenfolge wie im alten Profil erstellt hast, kann es zu Verwechslungen kommen, falls man z. B. den alten Ordner "pop.gmx-2.net" nicht der richtigen E-Mailadresse im neuen Profil zuordnet. Unter Berücksichtigung dieser "Überwachung" kann man also einfach die neuen Kontenordner durch die alten aus dem alten Profil ersetzen. Die wenigen neuen Nachrichten, die du beim Neuerstellen der Konten bereits herunter geladen hast, werden nach dem Austausch der Kontenordner und Neustart von TB erneut herunter geladen, da ich noch nie jemanden gesehen habe, der sofort die Standard-Server-Einstellung des Belassens der Mails auf dem Server deaktiviert hat.


    Denke daran, auch den Ordner "Local Folders" aus dem Ordner "Mail" des alten Profils zu kopieren und in "Mail" des neuen Profils einzusetzen, falls du Nachrichten in deinen Lokalen Ordnern gespeichert hast.

  • Ich habe ein neues Profil erzeugt, meine Konten neu eingerichtet und dann die Inhalte der Ordner des Mail-Ordners übertragen.

    Zunächst funktionierte alles normal. Nach ein paar Neustarts von TB dann der alte Defekt des TB-Menüs.

    Jetzt bin ich ratlos.

    Vielleicht sollte ich mein Profil sichern, TB komplett mit AppCleaner deinstallieren, neu installieren und dann den Inhalt des Mail-Ordners (nur Konten-Ordner mit Mails, deren Einstellungen und Filterregeln, oder gibts da noch unsichtbare Dateien?) in ein neu erstelltes Profil kopieren?

  • Vielleicht sollte ich mein Profil sichern, TB komplett mit AppCleaner deinstallieren, neu installieren und dann den Inhalt des Mail-Ordners (nur Konten-Ordner mit Mails, deren Einstellungen und Filterregeln, oder gibts da noch unsichtbare Dateien?) in ein neu erstelltes Profil kopieren?

    Das hast du doch schon ein Mal gemacht, wie du im ersten Absatz deines Beitrag #34 beschreibst, außer dass du diesmal auch das Programm Thunderbird 68.3.1 deinstallieren und neu installieren willst. Um ein Programm wie Thunderbird zu deinstallieren, braucht man auch kein Zusatzprogramm wie AppCleaner.


    Was du jetzt noch zusätzlich nach Beenden von TB testen kannst:

    die Datei "org.mozilla.thunderbird.plist" in Users/username/Library/Preferences/ (= ~/Library/Preferences/) löschen,

    desgleichen den Thunderbird-Cache löschen, d. h. Ordner "Profiles" in ~/Library/Caches/Thunderbird/

    Danach TB wieder starten.


    Ich verstehe nicht so recht, wozu der ganze Aufwand dienen soll, wenn es sich nur um das kleine Problem der Befehle im Thunderbird-Menü handelt:



    Man kann die selben Befehle durch Tastenkürzel oder über den AppMenu ("Hamburger") Button eingeben.


    Im Profilordner von Thunderbird (unter macOS) gibt es außer .parentlock keine versteckten Dateien.

    Wenn ich versteckte Dateien sichtbar mache, kann ich diese Datei in allen meiner Profile sehen. Sie ist in allen Profilen leer (0 kB), hat also nach meinem Dafürhalten nichts mit deinem Problem zu tun.

  • Ich nehme diesen Faden noch mal auf, da ich gestern eine Benachrichtigung zu dem neuen Bug 1612456 bekommen habe, der ein ähnliches Problem in der Mac-Version von Thunderbird Daily (74.0a1) bei Benutzung eines Master-Passworts beschreibt:

    "About & Preferences windows don't appear (on Mac) when there's a master password and security.prompt_for_master_password_on_startup is set to true"

    Da einer der Teilnehmer der Bug-Diskussion beschreibt, dieses Problem auch bei Benutzern der Version TB 68 beobachtet zu haben, möchte ich Springtime und Donnerstag bitten hier mitzuteilen, ob sie

    a) ein Master-Passwort benutzen

    und

    b) im Konfig-Editor eine Einstellung security.prompt_for_master_password_on_startup mit dem Wert true haben.

    Hallo Mapenzi,


    ich verwende kein Master-Passwort und habe unter "about:config" auch keine Einstellung "security.prompt_for_master_password_on_startup".


    Viele Grüße Peter

  • Hallo Mapenzi,

    schön, daß an dem Problem weitergeforscht wird. Bei mir funktionieren die entsprechenden Befehle im TB-Menü noch immer nicht.

    Die Posts in Bug 1612456 beschreiben das Problem ja ganz gut.


    Zu deinen Fragen:


    Ja, ich benutze ein Master-Passwort

    und

    Ich habe im Konfig-Editor keine Einstellung security.prompt_for_master_password_on_startup gefunden.


    Grüße,

    Donnerstag