Thunderbird 68.x Mac / Befehle im Thunderbird-Menü funktionieren nicht

  • Hallo zusammen,


    ich habe nun schon mehrere Versionen von Thunderbird 68.x installiert, gestern gerade Version 68.3.1.

    Bei allen Versionen 68.x funktionieren die Befehle im Thunderbirds-Menü nicht.

    Die Befehle werden dargestellt, sind auch nicht ausgegraut , funktionieren aber nicht.


    Aktuell läuft bei mir noch Thunderbird 60.9.1 (64-Bit). Hier funktionieren alle Befehle.


    Was läuft da schief ?


    iMac Retina, 27", i7

    macOS 10.13.6 High Sierra

    Kontenart (POP)

    Eingesetzte Antiviren-Software: AVIRA

    Firewall: AVM FRITZ!Box 7490


    Viele Grüße Peter

  • graba

    Set the Label from 60.* to 68.*
  • Hi,


    sieht das aus wie bei mir?


    Wenn ja, kannst du -nach vorheriger Sicherung- und nach dem Upgrade auf die neuste, verfügbare Version und vor dem start von TB mal die global-messages-db.sqlite in deinem Profil löschen. Hat zumindest bei mir erstmal funktioniert.

  • Hallo,


    um welche Menüs und um welche "Befehle" handelt es sich?

    Hast du TB schon mal im abgesicherten Modus gestartet?

    Unter macOS: die Alt (Option) Taste gedrückt halten und gleichzeitig TB starten.


    Gruß

  • Hallo Markus 87,


    nein das sieht nicht so aus wie bei Dir.

    Das Löschen der Datei "global-messages-db.sqlite" hat auch nicht den gewünschten Effekt gebracht.


    Viele Grüße Peter

  • Hallo Mapenzi,


    Es handelt sich um alle Befehle des Thunderbird-Menü:

    Über Thunderbird

    Einstellungen

    Thunderbird ausblenden

    Andere Ausblenden

    Alle einblenden

    Thunderbird beenden


    Das Starten im abgesicherten Modus bringt leider auch keine Änderung an dem Verhalten.


    Viele Grüße Peter

  • Hallo zusammen,


    ich habe es gerade hinbekommen, dass das Menü "Thunderbird" in TB 68.3.1 wieder normal funktioniert.


    In dem Verzeichnis „User > Library > Thunderbird > Profiles“ habe ich sämtliche Dateien gelöscht mit Ausnahme des „Mail“-Ordners.


    Dennoch danke für Eure Hilfe.


    Viele Grüße Peter

  • In dem Verzeichnis „User > Library > Thunderbird > Profiles“ habe ich sämtliche Dateien gelöscht mit Ausnahme des „Mail“-Ordners.

    Dann hast du praktisch ein neues Profil erstellt, was meistens funktioniert, wenn man die Ursache eines Fehlers nicht finden kann.

    Schön, dass du das Problem auf diese Weise selber lösen konntest.


    Gruß

  • Ich hab genau das selbe Problem wie Peter.

    Würde es aber gerne lösen, ohne alle Dateien zu löschen, sondern nur die, die offenbar nach dem Update von 60.7.2 auf 68.3.1 dafür sorgen, dass die Schaltflächen im Thunderbird-Dropdown-Menü nicht mehr reagieren.

    Weiß jemand von euch, welche Datei im Profil-Ordner dafür zuständig ist?

    Wenn ich ein komplett neues Profil erstelle, funktioniert alles. Offenbar verursachen irgendwelche veralteten oder nicht funktionierenden Dateien im bisherigen Profil-Ordner das Problem.

    Wenn ich im alten Profil-Ordner alles außer dem Mail-Ordner lösche, verliere ich doch vermutlich Filterregeln oder Dateien, die für den richtigen Zugriff auf Mails, Ordnerstrukturen, Anhänge oder das Funktionieren der bisherigen Ordnerstruktur sorgen?

    Grüße


    MacBook (Retina, 12-inch, 2017)

    10.14.6 Mojave

  • Ich hab genau das selbe Problem wie Peter.

    Würde es aber gerne lösen, ohne alle Dateien zu löschen,

    ... versuche bitte den TB im abgesicherten Modus zu starten ob dort dein Problem auftritt, wenn ja, ist ein inkompatibles AddOn oder Theme dafür verantwortlich.

    Gruß Micha


    Mein produktiver Mailclient ist der portable TB mit der derzeit aktuellsten Version.

    Ansonsten zu Testzwecken diverse portable TB in den Versionen 68.* , 78.* und 83.*

  • Das Problem tritt - genau wie bei Peter - auch im abgesicherten Modus auf.

    Sämtliche Add-Ons habe ich vorher deinstalliert und es sind nur die mitgelieferten Themes (Standart = aktiv, Light, Dark) installiert.


    Gibt es nicht eine Möglichkeit, Mails, Filterregeln und Einstellungen in ein frisches Profil zu migrieren ohne die ganzen nicht mehr verwendeten Dateien z.B. aus alten Programmversionen mitzuschleppen?

  • ich habe es gerade hinbekommen, dass das Menü "Thunderbird" in TB 68.3.1 wieder normal funktioniert.

    In dem Verzeichnis „User > Library > Thunderbird > Profiles“ habe ich sämtliche Dateien gelöscht mit Ausnahme des „Mail“-Ordners.

    Das hat bei mir nicht funktioniert.

    Danach hat Thunderbird knapp 40 Dateien neu erstellt aber meine Mails nicht mehr gefunden.

  • Danach hat Thunderbird knapp 40 Dateien neu erstellt aber meine Mails nicht mehr gefunden.

    Du bist sehr unvorsichtig vorgegangen, indem du blindlings die sehr riskante Methode von Springtime kopiert hast. Das sollte nur jemand machen, der sich sehr gut mit dem Thunderbird-Profil auskennt.

    Als du deinen Profilordner geleert hast, hast du vermutlich die darin befindlichen Ordner und Dateien - bis auf den Ordner "Mail" - in den Papierkorb des Mac verschoben. Wenn dieser inzwischen nicht geleert wurde, solltest du zunächst alle diese Dateien und Ordner aus dem Papierkorb zurück holen und in einen eigens auf dem Desktop erstellten Ordner verschieben für den Fall, dass man doch noch eine wichtige Datei braucht, z. B. Adressbuch-Dateien.


    Damit man dir beim Wiederherstellen deiner alten Ordner und Nachrichten helfen kann, musst du außerdem angeben, ob deine Konten bisher als POP- oder IMAP-Konten parametriert waren (bzw. bestimmte als POP, andere als IMAP) und ob du diese Konten schon wieder nach dem gleichen Protokoll wie zuvor erstellt hast.

  • Ich hatte den Profil-Ordner vorher gesichert und habe alles wieder in den ursprünglichen Zustand gebracht.

    Es waren alles POP-Konten.

    Danke für die Warnung.

    Warum das Vorgehen bei Springtime zu einer Lösung geführt hat, bei mir aber nicht, weiß ich immer noch nicht.

  • Nach wie vor wüßte ich gern, welche Datei im Profil-Ordner die Menü-Leiste kontrolliert. Dann könnte ich sie ersetzen.

  • Ich hatte den Profil-Ordner vorher gesichert und habe alles wieder in den ursprünglichen Zustand gebracht.

    OK, das ist immer eine gute Vorsichtsmaßnahme. Aber davon wusste ich natürlich nichts, deswegen hatte ich das Wort "unvorsichtig" benutzt, das ich natürlich hiermit zurücknehme :)

    Warum das Vorgehen bei Springtime zu einer Lösung geführt hat, bei mir aber nicht, weiß ich immer noch nicht.

    Er hat alles in seinem Thunderbird-Profilordner gelöscht bis auf den Ordner "Mail", in dem sich die Kontenordner "pop.xxx.xx" mit den Nachrichtendateien seiner POP-Konten befinden.

    Dann hat er TB neu gestartet, der natürlich wie bei einer Erstinstallation zur Einrichtung eines Kontos auffordert.

    Er hat alle seine Konten wieder als POP-Konten neu eingerichtet und anschließend jedes Konto über die Konten-Einstellungen > Kontenname > Server-Einstellungen > Nachrichtenspeicher > Ordner wählen ... mit dem entsprechenden alten Kontenordner "pop.xxx.xx" verknüpft (oder vielleicht auch statt dessen seine Kontenordner im Ordner "Mail" umnummeriert).


    Dass die Methode von Springtime bei dir nicht funktionierte, liegt vermutlich daran, dass du nach der Neueinrichtung deiner Konten diese nicht mit den ursprünglichen Kontenordnern "pop.xxx.xx" neu verknüpft hast.

    Springtime hat praktisch ein neues Profil in der "Hülle" des alten Profilordners erstellt, nachdem er diesen leer geräumt hatte bis auf den wichtigen Ordner "Mail".

    Nach wie vor wüßte ich gern, welche Datei im Profil-Ordner die Menü-Leiste kontrolliert. Dann könnte ich sie ersetzen.

    Ich weiß es nicht, in welcher Datei das Thunderbird-Dropdown-Menü gespeichert wird. Ich war auch noch nie mit diesem Problem konfrontiert.


    Ich gehe davon aus, dass die Tasten-Kombination ⌘ + Q bei dir noch funktioniert zum Beenden von Thunderbird. Sonst kannst du auch auf den AppMenü (Hamburger) Button > Beenden klicken.
    Du könntest noch die folgenden Versuche machen, bevor man an das Erstellen eines neuen Profils gehen müsste.
    Den Profilordner anzeigen, dann TB beenden:

    • die Datei panacea.dat löschen, TB neu starten und das Thunderbird-Menü testen. TB erstellt die Datei neu. Wenn kein Erfolg, TB beenden und wieder in den Profilordner gehen.

    • die Dateien session.json und sessionCheckpoints.json auf den Desktop verschieben, TB neu starten und das Thunderbird-Menü testen. Wenn kein Erfolg, können die beiden verschobenen Dateien zurück in den Profilordner geschoben werden.

    • den selben Test wie zuvor mit Verschieben der Datei xulstore.json machen, bei Misserfolg selbige wieder einsetzen.


    EDIT:

    wenn bislang keine Maßnahme zum Erfolg geführt hat, kannst du noch probeweise nacheinander folgende Dateien aus dem Profilordner entfernen und TB neu starten:

    permissions.sqlite

    pkcs11.txt

    revocations.txt

    Edited once, last by Mapenzi ().

  • Nach wie vor wüßte ich gern, welche Datei im Profil-Ordner die Menü-Leiste kontrolliert. Dann könnte ich sie ersetzen.

    Hallo Donnerstag,


    Es gibt eine Methode um rauszufinden welche Datei der Übeltäter ist.

    Diese wird auch 50%-Methode genannt.


    Mache eine Sicherungskopie Deines Thunderbird-Profilordners.


    Beende Thunderbird.

    Lösche dann 50% der Dateien des Thunderbird-Profilordners mit Ausnahme des Ordners „Mail“.

    Starte Thunderbird neu.


    Funktionieren, dann die Befehle im Thunderbirds-Menü wieder, dann war die schuldige Datei bei den zuvor gelöschten Dateien.


    Beende Thunderbird.

    Lösche dann erneut 50% der vorherigen 50% der Dateien des TB-Profilordners mit Ausnahme des Ordners „Mail“.

    Starte Thunderbird neu.


    Auf diese Weise kannst Du herausfinden, welche Datei die Schuldige war.


    Ist zwar ein wenig mühsam, aber ich kenne keine schnellere Methode.


    Viele Grüße Peter

  • Hallo Peter

    Auf diese Weise kannst Du herausfinden, welche Datei die Schuldige war.

    Schade, dass du diese Methode nicht auf deinen Fall angewendet hast, sonst hätten wir vielleicht schon die schuldige Datei :)

    Mich hätte auch interessiert, ob die gleichen Menü-Befehle "Einstellungen" und "Beenden" auch im sogenannten "Hamburger"-Menü blockiert waren und/oder ob die entsprechenden Tastenkürzel ⌘ + Komma und ⌘ + Q ebenfalls nicht funktionierten.

  • Hallo Mapenzi,


    Was ist das „Hamburger“-Menü ???


    Alle Tastaturbefehle im Thunderbird-Menü Versionen 68.x funktionierten ebenfalls nicht.


    Nun hat sich bei mir aber eine neue Situation ergeben. Seit heute funktioniert mein Thunderbird 68.3.1, was das Thunderbird-Menü anbelangt, schon wieder nicht mehr.


    Daraufhin habe ich versucht die 50%-Methode anzuwenden. Das Funktioniert in diesem Fall leider nicht, weil egal welche 50% ich in den Müll ziehe, Thunderbird immer ein neues Konto erstellen will, das ist zu mühsam.


    Zwischen Weihnachten und Neujahr habe ich bei meinem System ein Upgrade auf „macOS 10.14 Mojave“ gemacht. Danach funktionierte Thunderbird ebenso einwandfrei wie zuvor unter macOS 10.13 High Sierra, bis heute.


    Ich habe für meine Situation aber zumindest einen Workaround gefunden:


    Wenn ich Thunderbird starte und sogleich die Einstellungen öffne, komme ich an die Einstellung ran, aber nur ein einziges einmal. Mache ich nach dem Start von Thunderbird irgend etwas anderes im Programm, kann ich die Einstellungen nicht mehr öffnen.


    Der Workaround sieht so aus:


    Thunderbird starten.

    Einstellungen öffnen, die dann als Tab dargestellt werden. Diesen Tab lasse ich offen. Danach kann ich Mails empfangen und senden, und komme via Tab immer wieder an die Einstellungen ran.


    Für mich sieht das insgesamt so aus, dass dies sehr wahrscheinlich nichts mit irgendwelchen „Preferences“ zu tun hat, sondern einen Bug darstellt.


    Ich habe, wie gesagt früher schon mehrere Versuche gemacht, die Versionen 68.x zu benutzen und bin immer wieder zu Thunderbird 60.9.1 (64-Bit) zurück gekehrt, das dann einwandfrei lief.


    Viele Grüße und Alles Gute für das Neue Jahr wünscht Peter

  • Quote

    Was ist das „Hamburger“-Menü ???


    ... wird allgemein in den Foren so genannt, der Weg zu den Einstellungen


    Gruß Micha


    Mein produktiver Mailclient ist der portable TB mit der derzeit aktuellsten Version.

    Ansonsten zu Testzwecken diverse portable TB in den Versionen 68.* , 78.* und 83.*

  • Hallo Peter,

    Was ist das „Hamburger“-Menü ???

    Hamburger-Button ist ein Spitzwort für den AppMenu-Button, der sich in der Regel rechts irgend wo in der Hauptsymbolleiste befindet:



    Hier muss ich sofort fragen, ob die Befehle des Thunderbird-Menüs im AppMenu aktiv sind oder ob sie dort ebenso wenig funktionieren?

    Desgleichen wiederhole ich meine Frage, ob die entsprechenden Tastenkürzel (siehe oben) ebenfalls nicht reagieren. Man kann nämlich das Thunderbird-Menü praktisch völlig beiseite lassen, indem man Tastenkürzel und/oder das AppMenu benutzt.


    Wenn du das Thunderbird-Menü anzeigst und mit dem Mauszeiger über die einzelnen Befehle gleitest, werden diese blau (oder mit einer anderen von dir gewählten Farbe) hinterlegt wie in meinem folgenden Screenshot oder tut sich auch da nichts?


    Daraufhin habe ich versucht die 50%-Methode anzuwenden. Das Funktioniert in diesem Fall leider nicht, weil egal welche 50% ich in den Müll ziehe, Thunderbird immer ein neues Konto erstellen will, das ist zu mühsam.

    Das ist mir unverständlich, es sei denn du hast jedes Mal die Datei prefs.js entfernt. Denn diese Datei enthält sämtliche Konten-Einstellungen, und wenn man sie entfernt (oder wenn sie korrupt ist, was nicht selten vorkommt), fordert TB beim Start zum Einrichten eines Kontos auf. Bei deiner 50% Methode müsste also prefs.js mindestens in einem Test erhalten geblieben sein.


    Ich benutze ebenfalls Mojave und kann dein (oder euer beider) Problem mit TB 68.3.1 weder in meinem Arbeitsprofil noch in drei anderen Testprofilen nachvollziehen. Ich habe bisher auch keinen entsprechenden Bug-Report gefunden.


    Ich glaube, statt weitere willkürliche "50% Tests" zu machen, sollten wir zu den gewohnten Basis-Tests zurück kehren:

    das sind in solchen Fällen der Test im abgesicherten Modus von Thunderbird und vor allem der Test in einem neuen Profil.

    Der Test in einem neuen Profil bedeutet, dass tatsächlich ein neues, jungfräuliches Profil erstellt wird, in dem zunächst ohne Add-ons und ohne jeglichen Import aus einem andern Profilordner getestet wird, ob das Problem reproduziert werden kann.


    Wenn du jetzt bei der Version 60.9.1 bleiben willst, ist das deine Entscheidung und ich brauche mich mit dem Fall nicht mehr beschäftigen. Dass du in der Version 68.3.1 völlig ohne das Thunderbird-Menü arbeiten kannst, habe ich oben schon gesagt.
    Wenn du dagegen mit der Version 68.3.1 arbeiten willst, kann ich dir weiterhin helfen, das Problem zu untersuchen.

    Dazu müsstest du ein neues Profil erstellen, wobei du die folgende Anleitung benutzen kannst:

    Profil-Manager - Profile verwalten, erstellen und löschen


    In diesem neuen Profil brauchst du zunächst nicht mal ein Konto zu erstellen. Es genügt, den Konten-Assistenten abzuwürgen und sofort das Thunderbird-Menü zu testen. Wenn der selbe Fehler in diesem Profil auftritt, bin ich bereit, einen entsprechenden Bug bei Bugzilla@Mozilla zu melden.

    Wenn der Fehler in einem jungfräulichen Profil reproduzierbar ist, wäre es wahrscheinlich auch günstig, als Beweis einen Screencast des nicht reagierenden Thunderbird-Menüs zu machen.


    Auch dir alles Gute im Neuen Jahr!