Fritzbox scheint IMAP-Zugriff zu blockieren

  • Hallo zusammen,



    ich hoffe mit meinem Problem hier richtig zu sein. Seit einiger Zeit kann ich bei einem meiner Email-Konten von Arcor keine Mails mehr per IMAP abrufen. Ich habe sämtliche empfohlenen Einstellungen ausprobiert und nichts klappt. Andere Mailkonten machen keine Probleme und auch der Versand mittels SMTP klappt mit diesem Konto, nur IMAP bricht immer wegen einer Zeitüberschreitung ab.


    Das Problem muss in meinem Netzwerk liegen, denn per Mobilfunk (Hotspot übers Handy) klappt der Zugriff problemlos und von diversen PC's in meinem Netzwerk nicht. An meinem Setup habe ich keine bewussten Änderungen durchgeführt, die dieses Problem erklären könnten. Als ich versucht habe den Fehler zu lokalisieren, habe ich mich zuerst direkt per LAN mit der Fritzbox verbunden, mit dem gleichen Ergebnis. Als ich mich dann direkt mit dem Endgerät meines Glasfaseranbieters verbunden habe, klappte es plötzlich, daher habe ich die Fritzbox im Verdacht.



    Mein Setup:

    • Thunderbird 78.14.0
    • Ubiquiti Switch
    • Fritzbox 7580
    • Genexis Fibertwist


    Da ich bei der Fritzbox kein Problem feststellen kann bin ich am Ende meiner Ideen angekommen. Habt ihr eine Idee, woran das liegen könnte?


    Gruß

    Arne

  • Thunder

    Approved the thread.
  • Ich verstehe: Über die Fritzbox geht es nicht. wenn der PC über mobilen Hotspot mit dem Netz verbunden ist, klappt es. In diesem Fall kontrolliere genau, was du an der Fritzbox alles blockst. Da das Problem nur auf diese eine Konto beschränkt zu sein scheint, prüfe auch Besonderheiten von Arcor. Extras Passwort, wenn man aus einem anderem Netz kommt?

    Unser Verein. Unsere DNA.

  • Hallo Arne,


    man kann denke ich davon ausgehen, dass Du hier (ComputerBase-Forum) auch in der gleichen Angelegenheit um Rat fragst.


    Da sind ja einige Ansätze dabei. Hat aber alles nichts mehr mit Thunderbird zu tun.


    Dort ist die Rede von einem Pi in Deinem Netzwerk. Nicht etwa mit Pi-Hole?


    An der Fritz!Box wird es jedenfalls eher nicht liegen, denn deren Mittel und Möglichkeiten zur Filterung von Ports sind doch arg limitiert. Da gibt es eigentlich nur ein paar vorkonfigurierte Einträge, die man dann aktivieren oder deaktivieren kann - IMAP ist nicht dabei. Wenn Du dann auch gerade sowieso nichts an der Konfiguration der FB geändert hast, es bis Datum x ging und ab da nicht mehr, ist die Fritz!Box mMn raus.


    Gruß

    Sehvornix

  • Im Forum von ComputerBase gibt es zusätzliche Informationen. Dort ist es m.E. auch besser aufgehoben. Guter Fund, Sehvornix .

    Da gibt es eigentlich nur ein paar vorkonfigurierte Einträge, die man dann aktivieren oder deaktivieren kann

    Dann ist das vielleicht abhängig vom Modell. Bei meiner schon etwas betagten 7490 kann ich eigene Einträge hinzufügen. Anyway, wenn Port 993 für dasselbe FB-Benutzerprofil über die FB bei den anderen Providern erreichbar ist, wird der Port dort nicht blockiert sein.

    Ausschließen lassen sich auch der Thunderbird selbst und Arcor, weil der Abruf klappt, wenn die FB umgangen wird. Entweder über mobilen Hotspot oder durch direktes Verbinden mit dem Endgerät des GF-Providers. Irgendeine Rolle spielt die FB demnach. Ich habe keinen Glasfaseranschluss. Somit auch kein solches Endgerät. Etwas verwundert bin ich darüber, dass dieses Endgerät bereits einen Router zur Verfügung stellt. Ansonsten könnte man sich nicht direkt verbinden. Ich leite daraus ab, es gibt zwei Router im Netz. Da kann man einiges falsch machen. Bei ComputerBase hat auch bereits jemand nach kaskadierenden Routern gefragt. Dem ist die veränderte IP der FB aufgefallen. Warum aber blockiert das Konstrukt nur einen Anbieter? Und warum erst seit einiger Zeit? Da muss es doch eine Änderung gegeben haben? Mir ein Rätsel. Das macht die Sache aber sehr interessant.

    Unser Verein. Unsere DNA.

  • Hi Altstadt,


    //OT

    Du meinst das hier?


    Probiere es mal aus. Ich schaue hier auch in eine 7490. 'Bearbeiten' führt zu


    und der passende Bereich sollte dann 'Globale Filtereinstellungen' sein, nur da fehlt dann die Funktion zum Hinzufügen.


    Bei erneuter Suche finde ich noch immer keine offizielle Beschreibung, wie das gehen soll. Inoffiziell kann oder konnte man mit Mods und per Telnet in die Konfiguration der FBs eingreifen. Auch in das Regelwerk der Firewall. Möglich, dass das noch immer geht, aber solange der OP nichts von solchen Eingriffen schreibt, kann ich mir die FB als Ursache einfach nicht vorstellen.


    Gruß

    Sehvornix

  • Hi,


    ja, der Beitrag ist von mir, da ich eben nicht wirklich weiß wo das Problem sitzt. Thunderbird schließe ich auf Fälle aus, ebenso den Mailanbieter, sonst würde es mit meinen Clients nie klappen. Auch die Fritzbox kann es eigentlich nicht sein, da dort ja wenn, dann ganze Ports blockiert werden und nicht einzelne Server. Mich irritiert eben nur das Verhalten mit und ohne Fritzbox dazwischen.


    Das Gerät meines Anbieters hat einen DHCP-Server integriert, daher ist die direkte Verbindung möglich. Eine bewusste Änderung an der gesamten Konfiguration habe ich nicht vorgenommen, aber manchmal übersieht man ja doch mal was, daher habe ich die Hoffnung, dass jemand eine Idee hat, wie sich die Sache noch besser eingrenzen lässt. Der Experte in Sachen Netzwerke bin ich nämlich nicht.


    Gruß
    Arne

  • Schau bitte mal in Thunderbird und in der Fritz!Box, dass bei beiden die Option "DNS over HTTPS" bzw. "DNS over TLS" deaktiviert ist. Siehe dazu in diesem Beitrag:


  • und der passende Bereich sollte dann 'Globale Filtereinstellungen' sein

    Der passende Bereich ist unter Netzwerkanwendungen.

    dass bei beiden die Option "DNS over HTTPS" bzw. "DNS over TLS" deaktiviert ist.

    Cool. Passt zwar nicht ganz zu

    An meinem Setup habe ich keine bewussten Änderungen durchgeführt,

    aber technisch wäre das eine Erklärung. :thumbup:

    Unser Verein. Unsere DNA.

  • Schau bitte mal in Thunderbird und in der Fritz!Box, dass bei beiden die Option "DNS over HTTPS" bzw. "DNS over TLS" deaktiviert ist. Siehe dazu in diesem Beitrag:

    Die Option ist sowohl in Thunderbird als auch der Fritzbox deaktiviert.

  • … aber technisch wäre das eine Erklärung.

    Aber nicht in Verbindung mit:

    und auch der Versand mittels SMTP klappt mit diesem Konto, nur IMAP bricht immer wegen einer Zeitüberschreitung ab.

    Warum sollte die DNS-Auflösung mit «imap.arcor.de» nicht funktionieren, obwohl sie ja offensichtlich mit «mail.arcor.de» kein Problem darstellt …?


    Die entscheidende Frage bei solchen Problemen ist immer:

    «Was war die letzte Aktion, bevor es nicht mehr funktionierte?»

  • Das Gerät meines Anbieters hat einen DHCP-Server integriert, daher ist die direkte Verbindung möglich.

    Ein DHCP-Server bringt dich nicht ins Internet. Wenn man zwei Netze miteinander verbinden will, hier das Internet und dein Heimnetz, dann braucht man einen Router. Sieht sehr danach aus, als hättest du zwei Router. Der Punkt kam auch bei ComputerBase. Bist bisher nicht darauf eingegangen.

    Die Frage nach dem pi-hole ist auch noch nicht beantwortet. Wenn du eines hast, dann hättest du sogar noch einen DNS-Proxy. Auch dort mal nachsehen, ob "DNS over HTTPS" bzw. "DNS over TLS" aktiviert ist. Auch nachsehen, ob das pi-hole in der Fritzbox als DNS-Server eingetragen ist oder nicht. Also, ob die Fritzbox das DNS kontaktiert oder das pi-hole.


    Aber nicht in Verbindung mit:

    Doch, natürlich. Zwei verschiedene Server (IMAP, SMPT), eventuell sogar ein dritter für OAuth, zwei verschiedene DNS-Server. Im Idealfall sollte es ein alles oder nichts sein. In der Praxis ist es das aber nicht immer. Siehe dir einfach nur das von Thunder verlinkte Beispiel an.

    Unser Verein. Unsere DNA.

  • Die entscheidende Frage bei solchen Problemen ist immer:

    «Was war die letzte Aktion, bevor es nicht mehr funktionierte?»

    Absolut richtig. Leider kann ich mich an keine bewusste Aktion erinnern, die für dieses Problem verantwortlich ist. Trotzdem kann es sehr gut ein, dass ich dies durch eine scheinbar harmlose Einstellungsänderung irgendwann ausgelöst habe. Ich weiß nur nicht welche und wo.


    Ein DHCP-Server bringt dich nicht ins Internet. Wenn man zwei Netze miteinander verbinden will, hier das Internet und dein Heimnetz, dann braucht man einen Router. Sieht sehr danach aus, als hättest du zwei Router.

    Danke für die Erläuterung. Ich behaupte nein, zumindest finde ich keinen Hinweis darauf, dass das Endgerät vor meiner Fritzbox ein Router ist. Laut deiner Erläuterung aber viellkeicht doch. Hier die Anschlussbeispiele meines Anbieters, an die ich mich gehalten habe: https://services.vereinigte-st…928-1949640301.1632089765


    Die Frage nach dem pi-hole ist auch noch nicht beantwortet. Wenn du eines hast, dann hättest du sogar noch einen DNS-Proxy.

    Ich habe und hatte noch nie pi-hole im Einsatz. Meine Pi's betreiben die Software für Heimautomation, IPTV, etc. aber keinen DNS-Proxy oder ähnliches. Sie sind aber meine einzigen Geräte mit Unix im Netzwerk (außer Smartphones), deswegen habe ich die entsprechenden Befehle darauf ausgeführt.

  • Als ich versucht habe den Fehler zu lokalisieren, habe ich mich zuerst direkt per LAN mit der Fritzbox verbunden, mit dem gleichen Ergebnis. Als ich mich dann direkt mit dem Endgerät meines Glasfaseranbieters verbunden habe, klappte es plötzlich, daher habe ich die Fritzbox im Verdacht.

    Wenn das Ergebnis reproduzierbar ist, bleibt nach meiner Erfahrung auch nur die FB als Ursache übrig und ich schlage folgendes vor:

    • mache Screenshots von den einzelnen Konfigurationsseiten der FB
    • speichere die Konfiguration der FB, um sie bei Bedarf wieder einlesen zu können
    • setze die FB auf «Werkseinstellungen» zurück
    • konfiguriere die Grundeinstellungen anhand der Screenshots neu und teste den IMAP Zugang

    Vielleicht fällt dir dabei ein, was du vor dem Auftreten des Problems geändert hast …

  • Wenn das Ergebnis reproduzierbar ist, bleibt nach meiner Erfahrung auch nur die FB als Ursache übrig

    Leider würde ich die Fritzbox mittlerweile ausschließen. Auch bei Werkseinstellungen klappte es nicht. Ich habe nur die absolut notwendigsten Sachen eingestellt, um ins Internet zu kommen.

  • Auch bei Werkseinstellungen klappte es nicht. Ich habe nur die absolut notwendigsten Sachen eingestellt, um ins Internet zu kommen.

    Wenn nur IMAP bei Arcor nicht funktioniert, andere Anwendungen und Protokolle schon, könntest du noch einen Test mit einem anderen Freemail-Anbieter und IMAP machen. Ansonsten fällt mir dazu im Moment nichts mehr ein. Die Hinweise von AVM hast du vermutlich schon gelesen:

    FRITZ!Box für Betrieb am Glasfaseranschluss einrichten | FRITZ!Box 7580
    Sie wollen die FRITZ!Box an einem Glasfaseranschluss einrichten? ✔ Mit dieser Anleitung geht das ganz einfach.
    avm.de

    Internetzugang über anderes Modem nicht möglich | FRITZ!Box 7580
    Einige oder alle mit der FRITZ!Box verbundenen Geräte können nicht auf das Internet zugreifen, wenn die FRITZ!Box die Internetverbindung über ein externes…
    avm.de

    FRITZ!Box für Betrieb mit anderem Router einrichten | FRITZ!Box 7580
    Sie wollen die FRITZ!Box an einem anderen Router einsetzen und die vorhandene Internetverbindung nutzen? ✓ So richten Sie die FRITZ!Box dafür ein.
    avm.de

    https://images-eu.ssl-images-amazon.com/images/I/B1C0fqCxupS.pdf

  • Hallo Arne,


    aus meiner Sicht lässt sich das bisher Gesagte so zusammenfassen: keine Verbindung zum IMAP Server via Port 993 (SSL) an dem Glasfaseranschluss.


    Das es bei direktem Anschluss an dieses Genexis Fibertwist funktioniert hat (ist das reproduzierbar?), ändert eigentlich erst mal nichts an meiner These.


    Vergleiche doch bitte mal die bezogenen IP-Parameter, die die Fritz!Box an dem Genexis bekommt und von dem Notebook (?) direkt am Genexis. Gibt es da Unterschiede bei der erhaltenen IP-Adresse, den DNS und dem zugewiesenen Gateway oder bei der Netzmaske?


    Dein letzter geposteter traceroute in #12 bei ComputerBase zeigt, dass die Pakete bis ins Backbone von Arcor gehen, aber eben nicht weiter. Die 88.79.13.225 gehört bereits zur Infrastruktur von Arcor. Allerdings zeigen sich absolut unterirdische Latzenzen (fünfstellige ms).


    Wenn ich hier so einen tracert absende, sieht das so aus:

    Viel weniger Hops und ziemlich niedrige Latenz und außerdem antwortet imap.arcor.de auch (imap.arcor.de = imap.vodafonemail.de).


    Daher lautet meine These aktuell, dass Dein Glasfaseranschluss-Anbieter und Arcor ein Problem miteinander haben, wenn die Anfrage von einem System hinter der Fritz!Box kommt. Eventuell betrifft es auch gar nicht spezifisch IMAP / SSL / Port 993, sondern die gesamte Kommunikation mit imap.arcor.de.


    smtp.arcor.de ist ein anderer Server (=andere Ziel-IP) und mit dem funktioniert die Kommunikation ja, soweit ich das Deinen Ausführungen entnehmen konnte.


    Kennst Du vielleicht noch jemanden in Deiner Nachbarschaft, der auch den selben Anschlussanbieter und Glasfaser hat? Wäre es möglich, von dem anderen Anschluss aus einen Test auf Abrufbarkeit der Mails über IMAP mit Deinem Konto durchzuführen?


    Gruß

    Sehvornix

    Edited once, last by Sehvornix ().

  • Dein letzter geposteter traceroute in #12 bei ComputerBase zeigt, dass die Pakete bis ins Backbone von Arcor gehen, aber eben nicht weiter. Die 88.79.13.225 gehört bereits zur Infrastruktur von Arcor. Allerdings zeigen sich absolut unterirdische Latzenzen (fünfstellige ms).

    Kann es sein, daß du den Punkt übersehen hast? Bei mir sieht es ähnlich aus:

    6 FFMGW4.arcor-ip.net (80.81.193.117) 25.840 ms 53.367 ms 22.353 ms

    7 188.111.217.241 (188.111.217.241) 22.743 ms 23.069 ms 188.111.217.237 (188.111.217.237) 22.737 ms

    8 88.79.13.225 (88.79.13.225) 22.503 ms 22.182 ms 22.308 ms

    9 * * *

    Hinter 88.79.13.225 geht es bei mir auch nicht weiter.

  • Mit 'sudo traceroute -4 -I imap.vodafonemail.de' komme ich auch bis zum Ziel:

    6 FFMGW4.arcor-ip.net (80.81.193.117) 26.056 ms 22.182 ms 21.739 ms

    7 188.111.217.241 (188.111.217.241) 22.582 ms 22.578 ms 23.075 ms

    8 88.79.13.225 (88.79.13.225) 22.328 ms 22.300 ms 22.264 ms

    9 2.207.150.230 (2.207.150.230) 22.336 ms 22.356 ms 22.378 ms

  • Ich behaupte nein, zumindest finde ich keinen Hinweis darauf, dass das Endgerät vor meiner Fritzbox ein Router ist.

    Doch, doch. Zumindest mal so weit, dass er die Verbindung zum Internet herstellt. Das steht auch in der Anleitung. Sie empfehlen die FB. Es geht aber auch ohne. Damit ist klar, der Kollegen von der Base hatte eine gute Nase. Du hast zwei kaskadierende Router. Das ist für mich immer noch eine mögliche Quelle des Übels.

    Weitere Analytik kann habe ich dazu nicht anzubieten. Die bisherigen Ansätze, führen irgendwann zu einem Widerspruch. Oder zu einem Punkt, der bisher nicht erklärbar ist. Warum betrifft es nur einen Provider und dort auch nur den IMAP-Server? Warum klappt alles, wenn du die FB rausnimmst?

    Hast du es mal mit einem anderen Mailprogramm versucht? Ja, ja, ich weiß. Der Thunderbird funktioniert, wenn man die FB umgeht. Hatte den ja selbst schon ausgeschlossen. Nur, hier passt irgendwie gar nichts. Deshalb würde ich das ruhig mal testen.

    Noch was. Besuche mal einer der Seiten, die einem die IP usw. anzeigt. Gibt es dabei einen Unterschied, ob du an der FB hängst oder direkt am Fibertwist?

    Und noch einer. Dein Switch, ist der managebar? Geh mal mit deinem Rechner direkt auf einen freien LAN-Port der FB, ohne Switch dazwischen.

    Unser Verein. Unsere DNA.