GMail Konto kann in Tb nicht eingerichtet werden- Abbruch nach Freigabe bei GMail

  • Thunderbird-Version 91.12.0
    • Betriebssystem + Version Windows 10
    • Kontenart IMAP
    • Postfachanbieter GMail
    • Eingesetzte Antivirensoftware Avira
    • Firewall Avira Security

    Hallo zusammen,


    wahrscheinlich stelle ich mich zu blöd an, aber ich komme bei der Einrichtung meines GMail Kontos auf Thunderbird nicht weiter.


    Ich gebe alles ein und melde mich über IMAP an. Anschließend geht das Fenster auf, dass ich mich bei GMAIL anmelden soll. Bekomme dann auf meinem Smartphone eine Meldung, ob ich mich gerade anmelden will. Klicke auf ja. Anschließend geht das Fenster auf mit Zulassen auf die Zugriffsrechte von TB. Klicke auf Zulassen...


    Dann kommt aber das



    und es geht nicht weiter.

    IMAP ist in Gmail aktiviert.

    Das Passwort passt. Ich konnte mich ja schließlich bei GMAIL anmelden und bestätigen.

    Kann mir jemand helfen? Vielen Dank

    Grüße Max

  • edvoldi

    Approved the thread.
  • Das Passwort passt. Ich konnte mich ja schließlich bei GMAIL anmelden und bestätigen.

    1. Wenn du als Authentifizierungsmethode 'Passwort, normal' eingestellt hast, mußt du das bei Google generierte 'App-Passwort' verwenden, Das Passwort für den Webzugang funktioniert in TB nicht mehr! Bedingung für das Generieren des App-Passworts ist die 'Bestätigung in zwei Schritten' bei Google.


    2. Wenn du als Authentifizierungsmethode 'OAuth2' gewählt hast, mußt du Cookies und Javascript in TB zulassen.


    3. Stelle sicher, daß sich dein AV-Programm nicht in die Verbindung TB → GMail als 'MITM' 'einklinkt' – im Zweifel deinstallieren.

    Edited once, last by Veteran ().

  • Thunderbird-Version: 91.12.0 (32-Bit)

    • Betriebssystem + Version: Windows 7

    • Kontenart: POP3

    • Postfachanbieter: GMail

    • Eingesetzte Antivirensoftware: Bitdefender

    • Firewall: Bitdefender


    Hallo zusammen,

    ich habe schon seit Wochen das gleiche Problem, das MaxMicha oben geschildert hat. Einziger Unterschied: Ich möchte ein GMail-Konto als POP3 in Thunderbird einrichten (Authentifizierungsmethode OAuth2).

    Ich habe mir schon alle möglichen Threads zu Problemen zwischen Thunderbird + GMail durchgelesen und wirklich alles (!!!), das empfohlen wurde, durchgeführt, u.a.

    - in TB werden Cookies akzeptiert

    - in TB ist Javascript zugelassen

    - Virenscanner/Firewall zeitweise ausgeschaltet


    Es scheitert immer an der gleichen Stelle:

    Beim Einrichten des Gmail Kontos in Thunderbird öffnet sich das Popup-Fenster, in dem man sich in den Google-Account einloggen und den Zugriff der App auf das Gmail-Konto zulassen muss. Der Login scheint zu funktionieren. Auf der nächsten Seite stimme ich zu, dass Thunderbird auf das GMail-Konto zugreifen darf. Anschließend kommt die Meldung:

    "Anmeldung auf dem Server fehlgeschlagen. Eventuell sind Konfiguration, Benutzername oder Passwort nicht korrekt."


    Variante 2:

    Ich habe es irgendwie geschafft das GMail-Konto ohne erstmalige Passwortprüfung in TB manuell einzurichten. Als Authentifizierungsmethode ist OAuth2 eingestellt. Jedesmal, wenn ich Mails abrufen möchte, passiert das gleiche: Popup-Fenster (OAuth2) öffnet sich, ich logge mich ein und stimme dem App-Zugriff zu. Dann schließt sich das Fenster und nichts passiert. Beim nächsten Versuch Mails abzurufen öffnet sich das Popup wieder und das Spiel beginnt von vorne. Zugleich sendet Google jedesmal an mein GMail Konto eine E-Mail mit Hinweis, dass es einen verdächtigen Login-Versuch auf das Konto gegeben habe. Dieser wurde ausgelöst durch meinen Versuch die Mails mit Thunderbird abzurufen.


    Testweise habe ich auch schon eine portable Version von Thunderbird ausprobiert und versucht darin mein GMail-Konto anzulegen. Mit genau dem gleichen Problem.


    Interessant ist auch, dass ich für E-Mail-Checks das kleine Programm POP Peeper (Esumsoft) verwende, das von Google ebenfalls als unsichere Third-party App eingestuft wird. Darin hat die Einrichtung des GMail-Kontos über OAuth2 problemlos funktioniert. Auch der Mailcheck damit läuft reibungslos. Bei der ersten Einrichtung des GMail Kontos öffnete sich ebenfalls das Popup-Fenster, in dem ich mich in den Google-Account einloggen und den Zugriff der App auf das Gmail-Konto zulassen musste. Das hat auf Anhieb problemlos funktioniert und Pop Peeper wird nun auch in den Sicherheitseinstellungen meines Google-Accounts als Third-party App mit Accountzugriff gelistet (Security >> Third-party apps with account access). Thunderbird taucht in dieser Liste nicht auf.


    Also entweder blockiert Google gezielt die App Thunderbird. Oder Thunderbird hat einen Bug, so dass sich bei dem sich öffnenden OAuth2-Popup-Fenster die Einstellungen nie gespeichert werden.

  • Anschließend kommt die Meldung:

    "Anmeldung auf dem Server fehlgeschlagen. Eventuell sind Konfiguration, Benutzername oder Passwort nicht korrekt."

    Hast du noch gespeicherte Zugangsdaten für GMail in TB? Falls ja – löschen.

    'Einstellungen → Datenschtz & Sicherheit → Passwörter → Gespeicherte Passwörter …'


    Ansonsten mit einem neuen Profil versuchen.

  • Hast du noch gespeicherte Zugangsdaten für GMail in TB? Falls ja – löschen.

    'Einstellungen → Datenschtz & Sicherheit → Passwörter → Gespeicherte Passwörter …'

    Es waren keine Zugangsdaten für Google/GMail gespeichert.


    Ansonsten mit einem neuen Profil versuchen.

    Habe ich eben auch mal ausprobiert. Neues Thunderbird-Profil erstellt. Einstellungen geprüft (Cookies erlaubt, Javascript aktiviert).

    Beim Einrichten des GMail-Kontos trat leider wieder das oben beschriebene Problem auf:

    "Anmeldung auf dem Server fehlgeschlagen. Eventuell sind Konfiguration, Benutzername oder Passwort nicht korrekt."

  • Einstellungen geprüft (Cookies erlaubt, Javascript aktiviert).

    Mal doof gefragt: Hast Du in einem neuen Profil diesbezüglich Änderungen an den Einstellungen gemacht bzw. "machen müssen"? Wenn ja, dann hast Du vermutlich eine der Einstellungen fehlinterpretiert. Die Default-Einstellungen sind nämlich vollkommen okay.

  • Mal doof gefragt: Hast Du in einem neuen Profil diesbezüglich Änderungen an den Einstellungen gemacht bzw. "machen müssen"? Wenn ja, dann hast Du vermutlich eine der Einstellungen fehlinterpretiert. Die Default-Einstellungen sind nämlich vollkommen okay.

    Nein, ich musste nichts ändern. Wie Du richtig schreibst, sind die Default-Einstellungen bereits genau so wie sie sein sollen. Ich habe das nur zusätzlich erwähnt, um klar zu machen, dass ich nicht einfach dies und das ausprobiere, sondern mir schon meine Gedanken mache.

    Wenn ich im Popup-Fenster Thunderbird für den Zugriff auf meinen GMail Account die Freigabe erteile, dann sollte das ja irgendwo gespeichert werden. Aber das scheint nicht zu geschehen. Hier liegt meiner Ansicht nach das Problem.

    Edited once, last by KR4FTW3RK ().

  • Eine Frage zu OAuth2: Das Popup-Fenster, in dem man sich bei GMail einloggt und die Autorisierung durchführt, öffnet sich dieses in einem Thunderbird-eigenen Browserfenster oder öffnet es sich in dem im System eingestellten Standard-Webbrowser?

  • öffnet sich dieses in einem Thunderbird-eigenen Browserfenster

    Ja, sonst würde es technisch gar nicht funktionieren, da der externe Browser die Daten gar nicht zurück geben könnte.

  • Betriebssystem + Version: Windows 7

    Schon mal dran gedacht, das Win7 nicht mehr up-to-date ist und gewechselt gehört?


    • Eingesetzte Antivirensoftware: Bitdefender

    • Firewall: Bitdefender

    Also mit nem unsicherem OS unterwegs, dann ein Fremdprodukt hernehmen damit die Sicherheit paßt?! Irgendwie inkonsequent... mal ohne den Bitdefender probiert? Und das bedeutet auch ohne die FW. FW ist übrigens sooooo 2000er...


    Grüße dErzOnk

  • Danke schön, Thunder!


    Ich habe mal einen Sreenshot des Popup-Fensters gemacht. Kann mir bitte jemand bestätigen, dass die in rot unterstrichenen Angaben wie angezeigt korrekt sind, damit die Autorisierung funktioniert? Die Angaben werden von Thunderbird im Popup-Fenster vorgegeben. Meines Wissens habe ich keine Möglichkeit sie irgendwie zu ändern.



    Ich klicke dann immer unten auf den Button "Zulassen" und das Popup-Fenster schließt sich. Daraufhin erscheint dann im Fenster mit der (versuchten) Kontoeinrichtung die bekannte Fehlermeldung "Anmeldung auf dem Server fehlgeschlagen. (...)":

  • War klar, dass wieder jemand mit so einem Blödsinn daherkommt.

    Erklär mir bitte was genau mein Betriebssystem mit dem oben geschilderten Problem mit Thunderbird + GMail-Einrichtung zu tun hat. Und erklär mir bitte, warum ich GMail in der Software Pop Peeper (Beschreibung: siehe oben), die auf dem gleichen veralteten Betriebssystem läuft, problemlos einrichten konnte.

  • War klar, dass wieder jemand mit so einem Blödsinn daherkommt.

    Was soll denn "Blödsinn" sein? Das der Support für Win7 abgelaufen ist oder das FW und AV von Drittanbietern Probleme bereiten können und für Tests probehalber mal deaktiviert werden sollten?


    Mir ist deine Sicherheit egal, nur ist ein Win7 am Netz gegenüber Anderen assozial...


    Hier deine Daten bestätigt aber check mal warum bei Dir keine Daten nach "https://accounts.google.com/signin/oauth/legacy/consent?" kommen...


  • KR4FTW3RK Bitte erstelle in Zukunft einen eigenen Thread - schon aus Rücksicht auf den Themenersteller. Dies steht auch in den Nutzungsbedingungen des Forums, die du bei der Registrierung für das Forum akzeptiert hast. Probleme sind oft nur auf den ersten Blick gleich, unterscheiden sich aber dann in Wirklichkeit. Du selbst hast bereits einen Unterschied angegeben - du verwendest POP3, nicht IMAP wie der Themenersteller. Threads können auch sehr lang werden und du möchtest dich doch nicht durch Beiträge wühlen müssen, die mit deinem Problem nichts zu tun haben - und, so hoffe ich, das auch nicht dem Themenersteller zumuten. Du kannst aber gerne auf Beiträge eines anderen Threads verlinken.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Kann mir bitte jemand bestätigen, dass die in rot unterstrichenen Angaben wie angezeigt korrekt sind, damit die Autorisierung funktioniert

    Die Daten sind korrekt. Damit funktioniert es bei mir problemlos.

  • Was soll denn "Blödsinn" sein? Das der Support für Win7 abgelaufen ist oder das FW und AV von Drittanbietern Probleme bereiten können und für Tests probehalber mal deaktiviert werden sollten?

    Ich habe oben (in meinem ersten Beitrag) ja geschrieben, dass ich auch AV/FW zwischenzeitlich abgeschaltet habe, um auszuschließen, dass die Software irgendwas blockiert. Das hattest Du einscheinend überlesen.

    Weil das Problem auch bei deaktivierter AV/FW auftritt kann ich ausschließen, dass Bitdefender der Verursacher des Problems ist. Bevor ich auf Bitdefender umgestiegen bin, hatte ich übrigens die AV/FW eines anderen Anbieters installiert. Auch damals hat schon die Einrichtung von GMail unter Thunderbird nicht funktioniert. Antivirus/Firewall sind also definitiv nicht Ursache dieses Problems!

    Mir ist deine Sicherheit egal, nur ist ein Win7 am Netz gegenüber Anderen assozial...

    Echt jetzt? So einen Blödsinn musst Du jedem erzählen, der eigentlich ein ganz anderes Problem hat und nur nebenbei darauf hinweist, dass er Win7 verwendet? Ich habe mich hier angemeldet, weil ich mir Hilfe bei meinem Problem mit Thunderbird + GMail erhofft habe und nicht, weil ich eine Betriebssystem-Beratung brauche. Aber ok, ich habs zur Kenntnis genommen.

    Hier deine Daten bestätigt aber check mal warum bei Dir keine Daten nach "https://accounts.google.com/signin/oauth/legacy/consent?" kommen...

    Das liegt daran, dass ich in meinem Screenshot den Teil, der hinter "https://accounts.google.com/signin/oauth/legacy/consent?" kommt, entfernt habe. Danke für die Bestätigung, dass die Angaben im Popup-Fenster richtig sind.


    Nochmal:

    Die Fehlermeldung

    "Anmeldung auf dem Server fehlgeschlagen. Eventuell sind Konfiguration, Benutzername oder Passwort nicht korrekt."

    verstehe ich überhaupt nicht. Denn die Login-Daten, mit denen ich mich während des OAuth2-Vorgangs bei Google einloge, sind auf jeden Fall richtig. MaxMicha schildert oben genau das gleiche Problem. Der Login bei Google/GMail funktioniert, aber die Freigabe/Authentifizierung wird - warum auch immer - nicht gespeichert. Darum öffnet sich das Oauth2-Popup immer wieder aufs Neue.

  • KR4FTW3RK Bitte erstelle in Zukunft einen eigenen Thread - schon aus Rücksicht auf den Themenersteller. Dies steht auch in den Nutzungsbedingungen des Forums, die du bei der Registrierung für das Forum akzeptiert hast. Probleme sind oft nur auf den ersten Blick gleich, unterscheiden sich aber dann in Wirklichkeit. Du selbst hast bereits einen Unterschied angegeben - du verwendest POP3, nicht IMAP wie der Themenersteller. Threads können auch sehr lang werden und du möchtest dich doch nicht durch Beiträge wühlen müssen, die mit deinem Problem nichts zu tun haben - und, so hoffe ich, das auch nicht dem Themenersteller zumuten. Du kannst aber gerne auf Beiträge eines anderen Threads verlinken.

    In Ordnung. Das ist nachvollziehbar, und zukünftig werde ich für meine Probleme einen eigenen Thread erstellen. Wenn ihr mögt, könnt ihr meinen Thread auch abtrennen. Ich würde dann meinen ersten Beitrag editieren und als Referenz auf den Thread von MaxMicha verlinken.


    Wenn ich einen neuen Thread erstellt hätte, hätte allerdings sicher irgendwer darauf hingewiesen, dass es zu diesem Thema schon andere Threads wie diesen hier gibt. Es macht übrigens auch keinen Unterschied, ob ich versuche das GMail-Konto als POP3 oder IMAP einzurichten. In beiden Fällen funktioniert es leider nicht.

  • hätte allerdings sicher irgendwer darauf hingewiesen, dass es zu diesem Thema schon andere Threads wie diesen hier gibt.

    Damit ist aber nicht gemeint, dass du dich an jenen Thread anhängen sollst, sondern du ihn durchlesen solltest, ob du nicht schon vielleicht ein Lösung findest. Es ist überhaupt kein Drama, wenn du, wie gewünscht, einen neuen Thread eröffnest und es gibt schon einen anderen Thread, der aber vielleicht auch nur ein ähnliches Problem behandelt. Der Hinweis auf einen vorhandenen Thread ist dennoch gut.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Ich habe es jetzt aufgegeben mein GMail-Konto in Thunderbird mit OAuth2 einzurichten und es stattdessen mit der oben von Veteran beschriebenen alternativen Methode mit Zwei-Faktor-Authentifizierung + App-Passwort gemacht. Vielleicht ist das ja auch für Dich eine mögliche Lösung, MaxMicha ?


    Generell nervt die Zwei-Faktor-Authentifizierung zwar ein bisschen, aber immerhin kann ich jetzt auch von GMail wieder meine E-Mails auf den Rechner runterladen und in Thunderbird beantworten und archivieren.


    Die Option App-Passwort wird von Google leider erst nach Aktivierung der Zwei-Faktor-Authentifizierung angeboten. Übrigens hat auch mit aktivierter Zwei-Faktor-Authentifizierung die OAuth2-Methode bei mir nicht funktioniert. Technisch kenne ich mich mit OAuth2 nur oberflächlich aus, vermute aber, dass das Problem bei mir irgendwo in der Kommunikation mit dem Authorisierungsserver und der Erzeugung oder Speicherung des Access Tokens liegt. Bei Pop Peeper habe ich den Speicherort des Access und des Refresh Tokens gefunden (in der poppeeper.ini). Bei Thunderbird werden beide vermutlich im Profilordner in der Datei prefs.js gespeichert (sofern die Einrichtung mittels OAuth2 funktioniert).


    Herzlichen Dank nochmal an Euch alle dafür, dass ihr Euch die Zeit genommen habt eine mögliche Lösung für das Problem mit OAuth2 zu finden! :)


    MaxMicha, ich wünsche Dir sehr, dass Du auch eine Lösung findest. Es tut mir leid, dass ich mich hier einfach angehängt habe.