Beiträge von mclaren

    Heute ist mir endlich eingefallen woran es liegen könnte und es hat sich bestätigt. Ich hab damals firejail installiert, ein Sandbox System. Ich hab es nun für testzwecke entfernt und siehe da, ich kann endlich enigmail wieder nutzen mit Thunderbird. Problemursache somit endlich gefunden ...

    Hallo,


    hab erst jetzt wieder Zeit gehabt mich damit zu befassen.

    also ich hab von einem Schlüssel eine *.asc Datei die ich von einem Backup habe und somit valide sein muss.


    Ich hab nun folgendes probiert enigmail Addon im Thunderbird entfernt .gnupg Ordner umbenannt .thunderbird umbenannt und dann gpg2 --list-secret-keys - es kommt die Meldung


    gpg: keybox '/home/firespark/.gnupg/pubring.kbx' created

    gpg: /home/firespark/.gnupg/trustdb.gpg: trustdb created



    Dann den vorhanden key importiert gpg2 --allow-secret-key-import --import gpg-secret-key-gmx.asc - es wird die passphrase abgefragt


    gpg: key F039DD7C: public key "mclaren <meinemail@gmx.at>" imported

    gpg: key F039DD7C: secret key imported

    gpg: Total number processed: 3

    gpg: imported: 1

    gpg: secret keys read: 3

    gpg: secret keys imported: 2


    Dann hab ich sudo apt-get install enigmail .... Der Key wird im Keymanager angezeigt ... aber erneut die fehlermeldung mit missing passphrase im thunderbird ....


    Warum? Was passt da noch immer nicht zusammen?

    Wenn du den Ordner inklusive der Rechte kopiert hast, könnte das erklären, weshalb du keine Schreibrechte mehr hattest. Du warst nicht mehr der Eigentümer.

    Ich hab nachdem neu aufsetzen den *.gnupg Ordner umbenannt und die vorherige Kopie des Ordner *gnupg von der externen auf den Laptop kopiert und ich konnte die Verschlüsselung auch ohne Probleme nutzen. Das Problem das es nicht mehr funktioniert kam plötzlich letzte Woche auf. (Problem mit Berechtigung)


    Zitat

    Ja, der Verdacht hat sich bestätigt. Ich weiß die Details nicht mehr aus dem Kopf. Die Struktur, in der Schlüssel gespeichert werden, hat sich jedoch meines Wissens mit einer der 2.x-Versionen geändert.

    Du könntest dich entweder dazu einlesen, hier auf weitere Hinweise von anderen warten oder gleich tabula rasa machen und GnuPG inklusive Enigmail neu einrichten.

    Auf Basis dieser Information bin ich nun auf etwas gestoßen.

    Unter https://wiki.ubuntuusers.de/Thunderbird/Enigmail/ wird erläutert, dass es zu dem Problemen kommen kann, wenn


    Enigmail mittels des Thunderbird Add-ons-Manager installiert wurde, denn dann fehlen die Abhängigkeiten und es kommt zu Fehlern wie: "Privater Schlüssel kann nicht gefunden werden."

    Zitat
    Zitat
    Ich hab daraufhin dass Addon im Thunderbird gelöscht und nun über sudo apt-get install enigmail gnupg-doc installiert.


    Allerdings steh ich nun an wie ich weiter vorgehen soll. Hast du noch einen Tipp diesbzgl?


    Hier wird erläutert, dass es ansich kein Problem ist wenn gpg und gpg2 glz. installiert ist, sondern wird sogar empfohlen. Aber auch hier hatte jemand das Problem, dass die privatkeys dann nicht in gpg2 übernommen wurden, wie bei mir nun scheinbar.

    Ich hab den Fehler gemacht und die Keys nie extra extrahiert, sondern immer nur den ganzen Ordner kopiert :/


    Hier steht https://superuser.com/question…ompatible-with-each-other

    GnuPG 2.1 stores private keys in another file. Your private keys are stored in GnuPG 1.4's secring.gpg, which is not queried by GnuPG 2.1. Copy them to GnuPG 2.1 through gpg --export-secret-keys [key-id] | gpg2 --import


    gpg --export-secret-keys zeigt mir zwei private Keys von einer E-Mail Adresse angezeigt - den neuen Schlüssel den ich nach dem neu aufsetzen generierte habe für eine neue email adresse seh ich hier nicht. Wenn ich den oben genannten import durchführe bekomm ich im Thunderbird schlussendlich wieder die Meldung, dass die Passphrase fehlt ...

    Ich hab ursprünglich die info mit uname -a entnommen und nun festgestellt dass das wohl nicht die ideale ist um die aktuelle Version zu erfahren. Ic h habe


    cat /etc/lsb-release

    DISTRIB_ID=Ubuntu

    DISTRIB_RELEASE=16.04

    DISTRIB_CODENAME=xenial

    DISTRIB_DESCRIPTION="Ubuntu 16.04.5 LTS"


    Wobei es eigentlich ein Lubuntu ist, das geht hier auch nicht hervor ...


    Scheinbar hab ich tatsächlich zwei pgp Versionen?!


    user@rechner:~$ which gpg2

    /usr/bin/gpg2

    user@rechner:~$ which gpg

    /usr/bin/gpg


    Ich hab den Rechner vor etwa 4 Wochen aufgesetzt und damals den Ordner *.gnupg vom Backup übernommen. Da gab es auch keine Probleme. Ich hatte davor ein aktuelles 16.04.* System und jetzt auch. Warum es plötzlich zu dem Fehler/ Änderungen der Berechtigungen bei dem Ordner kam, ist mir bisher absolut nicht verständlich.

    Einen neuen Test bzgl. den Schlüssel mach ich heute am Abend, danke für deine Inputs!

    Hallo,


    danke für deine Rückmeldung1

    Ich habe über die graphische im thunderbird über Enigmail alle public Keys exportiert


    - beim Versuch auch die privat zu exportieren kam die Meldung es gäbe keine. Ich hab dann über die Konsole mit

    Code
    1. gpg2 --list-secret-keys

    alle meine privaten Keys angezeigt bekommen und dann über die Konsole einzeln exportiert mit


    Code
    1. gpg2 -a --output gpg-secret-key.asc --export-secret-keys <optional Schlüssel-ID oder Name>


    Dann hab ich den Ordner *.gnupg umbenannt und Thunderbird neu gestartet. Der Ordner wurde wieder angelegt und ich hab dann über das Enigmail Addon im Thunderbird mittels Key Manager die public und private Keys importiert ... Jedesmal wurde mir angezeigt, dass erfolgreich importiert wurde.

    nun schreibt mir Thunderbird beim Versuch die bereits verschlüsselten Nachrichten zu entschlüsseln, dass der passende Key nicht vorhanden ist.


    Code
    1. Enigmail Security Info
    2. Error - no matching secret key found to decrypt message
    3. Note: The message is encrypted for the following User ID's / Keys:
    4. 0x71B658A920DEXXXX (name <abc@cde.at>)


    Sollte im Ordner "private-keys-v1.d" unter .gnupg etwas drin sein? Gibt es noch weitere Tipps?

    Log 3/3

    Log 2/3

    Log 1/3

    Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 60.0 64 Bit
    • Betriebssystem + Version: 16.04.1-Lubuntu
    • Kontenart (POP / IMAP): IMAP
    • Postfachanbieter (z.B. GMX): GMX
    • PGP-Software / PGP-Version: 2.0.8 Enigmail
    • Eingesetzte Antivirensoftware: none
    • Firewall (Betriebssystem-intern/Externe Software): none


    Hallo,


    aus welchen Grud auch immer waren meine Berechtigungen des Ordners *.gnupg falsch gesetzt - das hab ich mithilfe der angezeigten Fehlermeldung und Hinweise auf div. Foren im Inet behoben. Allerdings zeigt mir Thunderbird nun bei jeder verschlüsselten E-Mail die ich entschlüsseln möchte an, dass die passphrase fehlt. Normalerweise sollte eigentlich das Fenster aufpoppen indem ich diese eingeben kann, wie sonst auch, aber sie kommt nicht. Leider hab ich hierzu bisher keine Lösung online gefunden.


    Konsolenmeldungen

    Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 52.9.1 (64-bit)
    • Betriebssystem + Version: 16.04.2-LUbuntu
    • Kontenart (POP / IMAP): IMAP
    • Postfach-Anbieter (z.B. GMX): GMX
    • Eingesetzte Antiviren-Software: keine
    • Firewall (Betriebssystem-intern/Externe Software): keine
    • Router-Modellbezeichnung (bei Sende-Problemen): kein eigener Router, nur Internetmodem mit Router


    Hallo,


    ich habe mein OS neu installiert. Dann habe ich Thunderbird installiert und meine gespeicherten Schlüssel vom alten Profil mitübernommen.

    Ich kann (un)verschlüsselte E-Mails empfangen, aber ich kann keine E-Mails versenden (es wird kein Fehler angezeigt, wenn ich auf senden klicke tut sich einfach gar nichts). wenn ich das Enigmail Addon deaktiviere, dann kann ich zumindest unverschlüsselt versenden.


    Running Enigmail version 2.0.8 (20180804-1515)

    Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 52.9.1 (64-bit)
    • Betriebssystem + Version: 16.04.2-LUbuntu
    • Kontenart (POP / IMAP): IMAP
    • Postfach-Anbieter (z.B. GMX): GMX
    • Eingesetzte Antiviren-Software: keine
    • Firewall (Betriebssystem-intern/Externe Software): keine
    • Router-Modellbezeichnung (bei Sende-Problemen): kein eigener Router, nur Internetmodem mit Router


    Hallo!


    Ich habe meinen Laptop neuaufgesetzt und wollte ursprünglich mein Thunderbird Profil übernehmen. Allerdings gab es hier Probleme mit den gespeicherten Logindaten. Also hab ich ein neues Profil angelegt und die Konten alle neu eingerichtet. Das Abrufen der E-Mails über IMAP funktioniert, aber SMTP nicht. Ich bekomme keine Fehlermeldung, er tut einfach nichts wenn ich auf senden klicke.


    Hier steht wie smtp eingestellt werden soll https://hilfe.gmx.net/pop-imap…exlink_help_pop-imap_imap


    Anbei meine Thunderbird Einstellung - das senden funktioniert auch bei einem zweiten GMX Konto derzeit nicht. Da keine Fehlermeldung kommt weiß ich nicht was das Problem ist.




    Vielen Dank vorab für Tipps

    Zitat von "rum"


    Btw: afaik wird der Papierkorb nicht indiziert, wozu auch... :rolleyes:


    ok danke. Das kommt wohl auf das Mailablagesystem an obs sinn macht oder nicht, aber das will ich nun gar nicht disktutieren oder in Frage stellen.


    D.h. die Suche durchsucht alle Ornder, exklusive des Trash?

    Hallo,


    ich weiß leider nicht genau was du mit "Danach rechts neben den Spaltenüberschriften auf das kleine Tabellensymbol klicken und Ablageort auswählen." meinst.


    EDIT: Habe nun den Schritt mit global-messages-db.sqlite gemacht, die E-Mail werden nun in der suche nicht mehr angezeigt.
    Das führt mich nun zur nächsten Frage, durchsucht die Suchfunktion ALLE Ordner? Also Posteingang, Trash, Lokale Ordner ider nur bestimmte? Denn ansich lösche ich zwar E-Mail, aber das beschränkt sich eigentlich auf das verschieben in den Trash. Den Trash lösch bzw. bereinige ich nur selten? Wenn wirklich alles durchsucht wird, dann hab ich die nun gesuchte E-Mail wohl tatsächlich vernichtet :/


    EDIT2 Die Mail wurde doch gefunden, scheinbar war der Index vorher noch nicht komplett :)


    Aber ich weiß auch jetzt noch nicht, wie ich den aktuellen Ablageort erkenne.



    EDIT3: ok, nun ist alles geklärt, hab die Spalte location nun aktiviert, bzw. verstanden was du gemeint hast!


    Besten Dank! :)

    Hallo,


    danke für deine Rückmeldung, leider hab ich erst jetzt, nachdem ich gerade wieder genau das gleiche Problem habe, deine Antwort gesehen. Hab wohl die E-Mail Info unabsichtlich deaktiviert gehabt.


    Leider bringt das "Reparieren" nichts. Ich habe das nun bei sämtlichen E-Mail konten/ Ordner durchgeführt. Und wieder habe ich eine E-Mail die ich über die genrelle Suchfunktion suche, die wird mit dann auch als Suchergebnis angezeigt, wenn ich dann draufklicke und die komplette E-Mail sehen sollte, sehe ich nichts ... es ist auch leider nicht aus der Suchergebnis ersichtlich in welchen Ordner die E-Mail liegt, ansonst könnt ich ja zumindest über die normale Navigation hin.


    Hast du/ sonst jemand noch tipps warum die Suchfunktion "bockt"?


    Danke

    Thunderbird-Version: 17.05
    Betriebssystem + Version: Xubuntu 11.10
    Kontenart (POP / IMAP): IMAP
    Postfachanbieter (z.B. GMX): privat


    Hallo,


    folgendes Problem.
    Ich suche in meinen Postfächern eine E-Mail. Ich weiß von wem sie war und den Betreff.
    Theoretisch sollte die E-Mail in einer von drei Ordner liegen, allerdings finde ich sie hier nicht.
    Mit der globalen Suche wird sie dann gefunden, wenn ich das Suchergebnis anklicke, wird mir aber nicht die E-Mail direkt angezeigt, sondern ich erhalte eine Auflistung mit sämtlichen andere E-Mails, die damit nichts zu tun haben.



    Was ist da los?
    Gibt es eine Möglichkeit die E-Mail angezeigt zu bekommen?


    Danke

    Thunderbird-Version: 17.0.2
    Betriebssystem + Version: Xubuntu 11.10
    Lightning-Version: 1.9


    Hallo,


    ich habe mehrere lokale und Netzwerkkalender.
    Wenn ich nun eine E-Mail mit einer Termin Einladung erhalte, erscheint ja eine Box in der man "zusagen, absagen" kann. Wenn ich auf "zusagen" klicke, öffnet sich ein kleines Fenster und fragt mich, in welchen meiner Kalender ich den Termin haben möchte. Nun das Problem, es werden hier nur zwei von meinen 6 Kalendern angezeigt. Warum? Wie bekomme ich die anderen auch in dieses Auswahlfenster?


    LG