ReplyHeader anpassen

  • Wobei Dein Punkt 1) kein Problem gewesen wäre, da Du Dich offensichtlich auf HTML-Mails beziehst; mein "gar nicht" bezog sich auf Punkt 2).


    Ich für meinen Teil bin nun doch wieder zu den TB-RQH zurück. Bei changequote fehlt mir einerseits die Möglichkeit, die Reihenfolge der Headerzeilen anzupassen ohne in der xpi rumzuwurschteln. Zum anderen hat TB-RQH diese nette Funktion, die vier An: Zeilen auf zwei zu reduzieren; das finde ich ganz nett und habe es noch nicht als Standalone-Erweiterung entdeckt.


    Mein Hinweis auf das TB-RQH-Problem mit Reply-To: konnte ich nicht weiter eingrenzen; bei manchen anderen Absendern mit Reply-To funktioniert das Einfügen des modifizierten Headers dann doch. Egal, so kann ich damit auch gut leben.

  • Bin nun auch wieder zu dem TB-RQH zurück. Ist flexibler. Hab aber noch ein Problem:


    quoteHdrHTML.txt:

    Code
    <span style="font-family:Times; font-size:small">
    <hr>
    <!--@S@--><b>Betreff:</b> @S@<!--@S@-->
    <!--@A@--><b>Von:</b> @A@<!--@A@-->
    <!--@R@--><b>An:</b> @R@<!--@R@-->
    <!--@C@--><b>CC:</b> @C@<!--@C@-->
    <!--@D@--><b>Gesendet:</b> @D@<!--@D@-->
    </span>


    Weiß jemand wie ich den Codepage-Wirrwarr im Namen beim CC: vermeiden kann?


    Von: A. Weiß <A.weiss@yxz.com>
    An: <abc@gmx.de>
    CC: "=?iso-8859-1?Q?'A_Wei=DF'?=" <a_b_c@abc.net>
    Gesendet: 19.10.2006 18:08:08 +0200
    Betreff: AW: Test


    Im Kopf des Mailfensters steht der Name und seine Mail korrekt, nur TB-RQH scheint damit Probleme zu haben.



    Danke Tom*

  • Ich hab da noch ein kleines äthetisches Problem...
    Die eine Variante, wo ich mir die beiden Dateien selbst anlegen muss, gefällt mir sehr gut, weil da die Worte wie Betreff etc. fett gedruckt sind. Allerdings gefällt mir da das Datum nicht. Ich hätte gern den Wochentag dabei und die Ergänzung +0100 möchte ich nicht mit angezeigt haben.
    Bei dieser 2. Variante, wo der Thunderbird das sozusagen selbst macht, ist zwar das +0100 nicht mehr dabei, allerdings fehlt noch der Wochentag und die Wörter vorn sind nicht fettgedruckt.
    Gibt es für dieses "schwerwiegende" Problem eine Lösung?:roll:


    Vielen Dank für eure Hilfe!

  • Das war mal genau so, wie Du es Dir vorstellst, ist aber in der Erweiterung selber verändert worden, als ein Versionssprung gemacht wurde.
    Schau mal in diesen Thread der Mozillazine.

  • Ich hab da mal auf die Seite geschaut und bin trotzdem noch nicht ganz zufrieden. Erstens sind bei %dow und %mmm die Bezeichnungen in Englisch, zweitens sind sie nur abgekürzt und drittens ist das +0100 immer noch da.
    Ich hatte mal die Version 0.3.1 installiert, aber da hatte ich überhaupt keinen Header mehr :(

  • Habt ihr meine Frage übersehen oder wisst ihr einfach keine Antwort? :roll:

    Quote from "null.plan"

    Ich hab da mal auf die Seite geschaut und bin trotzdem noch nicht ganz zufrieden. Erstens sind bei %dow und %mmm die Bezeichnungen in Englisch, zweitens sind sie nur abgekürzt und drittens ist das +0100 immer noch da.
    Ich hatte mal die Version 0.3.1 installiert, aber da hatte ich überhaupt keinen Header mehr :(

  • Hi, bin der Neue ;)


    erstmal ein GROSSES Dankeschön an dieses tolle Forum und die sehr ausführliche Dokumentation. Das dauert schon ein wenig, das alles durchzuackern :)




    Ich habe nun TB Reset Quote Header Extension 0.4.3 unter TB 1.5.0.9 installiert und es lüppt auch alles. Allerdings gefällt mir das Datum beim antworten nicht.


    Momentan ergibt

    Quote

    %dow, %dd. %mmm %yyyy, %hr:%mn:%ss


    dies

    Quote

    Freitag, 02. Maerz 2007, 18:04:16 +0100


    Wie man sieht, habe ich schon die resetquotehdr.properties bearbeitet und dort deutsche Wochentage und Monate ausgeschrieben reingeschmissen. Ich denke, anders geht das nicht.


    Nun meine Probs:


    1.
    Problem mit ä in März. Speichere ich in der resetquotehdr.properties Maerz ab, geht es, wie man sieht. Mit März gehts aber nicht. Irgendwelche Ideen?


    [EDIT]:
    Punkt 1 erledigt. Man muss statt mit ANSI zB mit UTF-8 kodieren. Das geht ganz leicht zB mit dem Notepad++ in der Menüleiste unter Format. Abspeichern, fertig.
    [/EDIT]


    2.
    Wie bekomme ich das +0100 am Schluss des Datums raus?



    Mic

  • Quote from "Miccovin"

    ... Wie bekomme ich das +0100 am Schluss des Datums raus? ...


    Könnte mit Deiner Zeitzonen - Einstellung unter Windows zusammenhängen.

  • hm, gerade mal rumgesucht, aber auch nichts gefunden, wo ich das einstellen könnte. Uhrzeit schon, klar. Aber das +0100 - keine Ahnung.


    Bin mit WinXP SP2 Pro unterwegs.



    Übrigens wird die Uhrzeit richtig angezeigt. Wenn die Email um 09:41 ankam, steht auch 09:41 im Antwort-Header und nicht 08:41, wie das +0100 vielleicht suggeriert. Auch deshalb würde ich das gerne entfernen, weil es zu Missverständnissen führen kann.

  • hm, ok, danke. Ich hatte das zwar schon gesehn, aber so verstanden, dass man das gar nicht bearbeiten kann - und das Beispiel auf der Homepage ist eher abschreckend. Aber man kanns im Grunde zufällig genauso einstellen, wie ichs haben möchte - nur die Zeilen haben eine andere Reihenfolge, aber das ist nicht schlimm.


    Sieht bei mir jetzt so aus:

    Quote

    -------- Original Message --------
    Subject: Re:test
    From: Max Mustermann <max.mustermann@gmx.de>
    To: maxine.mustermann@gmx.de
    Date: Donnerstag, 1. März 2007 22:10:44


    (und nach dem Re: fehlt das Leerzeichen, fällt mir grad auf)

  • Huh? War ja auch so gemeint, daß man es nicht bearbeiten kann. Daß Du es jetzt hinbekommen hast überrascht mich.
    Wie sieht denn Dein "Text Quote Header Template" aus?

  • sorry, hab mich wohl missverständlich ausgedrückt. Ich meinte, dass ich es nun mir der anderen Erweiterung Change quote and reply format mache (ist in dem von Dir verlinkten Posting ganz unten verlinkt).

  • ich hab so ne datei angelegt:


    ----- Original Nachricht -----
    <!--@A@-->Von: @A@<!--@A@-->
    <!--@R@-->An: @R@<!--@R@-->
    <!--@D@-->gesendet am: @D@<!--@D@-->
    <!--@S@-->Betreff: @S@<!--@S@-->



    es funkt auch aber es kommt das datum bissl doof:


    gesendet am: 03/07/2007 6:24:10 PM +0100


    wollte eigtl sowas wie


    Donnerstag, 8. März 2007 18:24


    wie müsst ich die zeile da anpassen?

  • ahso ich glaube das ist okay aber ich muss DAS anpassen:


    %mm/%dd/%yyyy %hr:%mn:%ss %ampm


    hab es so geändert:


    %dd.%mm.%yyyy %hr:%mn


    ergebnis:


    gesendet am: 07.03.2007 17:24 +0100


    schön wäre noch der wochentag am anfang und das +0100 weg

  • Geht ganz einfach:


    1. Thunderbird schließen
    2. resetquotehdr.jar suchen
    3. resetquotehdr.jar öffnen -> Ordner "content" -> "resetquotehdr"
    4. content\resetquotehdr\resetquotehdr.js mit einem geeigneten Editor öffnen
    5. Zeile 363 suchen
    6. Vor dtstr += " " + tz zwei // setzen, sodass es so aussieht

    Code
    //dtstr += " " + tz


    7. resetquotehdr.jar speichern und Thunderbird öffnen

  • Quote from "localhost"

    ... ich werde wohl mal dem Hinweis von allblue folgen und "Change quote and reply format" ausprobieren.


    Habe ich jetzt auch gemacht und bin vollauf zufrieden, danke für den Tipp. :-)


    So siehts jetzt bei mir aus:


    Code
    -------- Original Message --------
    Subject: Lorem Ipsum
    From: Name <mail@domain.de>
    To: Name <mail@domain.de>
    Date: 24.07.2007 19:27



    Da lässt sich noch einiges mehr einstellen, Screenshot:



    Beispiele für das Datumsformat:


    Landesspezifisch:

    Code
    Date: Dienstag, 24. Juli 2007 19:28:14


    International:

    Code
    Date: Tue Jul 24 2007 19:28:14 GMT+0200


    Original:

    Code
    Date: tue, 24 jul 2007 19:28:14 +0200
  • Hast Du einen Weg gefunden, die Reihenfolge der Headerzeilen anzupassen? Ich hatte Changequote nämlich nur wieder deinstalliert, weil ich gerne diese Reihenfolge hätte, aber keine Option dazu finden konnte:

    Code
    From: Name <mail@domain.de>
    To: Name <mail@domain.de>
    Date: 24.07.2007 19:27
    Subject: Lorem Ipsum
  • Quote from "Felli"


    Habe ich jetzt auch gemacht und bin vollauf zufrieden, danke für den Tipp. :-)


    So siehts jetzt bei mir aus:


    Code
    -------- Original Message --------
    Subject: Lorem Ipsum
    From: Name <mail@domain.de>
    To: Name <mail@domain.de>


    Komisch. Bei mir ist das nämlich in deutsch.

  • localhost
    Nein, habe ich nicht, ich habe das AddOn allerdings gerade erst zwei Tage in Gebrauch und mir reicht das Format im Moment so wie es ist. :)


    allblue
    Guck mal auf meinen Screenshot, wo da bei mir ein Häkchen gesetzt ist. ;)