Probleme mit Abständen und Farben nach dem Update

  • Thunderbird-Version: 31
    Betriebssystem + Version: Win7 SP1
    Kontenart (POP / IMAP): beides
    Postfachanbieter (z.B. GMX): diverse


    Mit dem Update auf die Version 31 haben sich anscheinend diverse "Darstellungsfehler" eingeschlichen.
    Den Abstand im Baum habe ich schon über die chrome.css versucht zu korrigieren. Aber leider erfolglos, denn TB scheint die Einträge standhaft zu ignorieren. Es sind immer noch weiße Linien in der Baumansicht. Dazu habe ich noch das Problem, dass beim Schreiben einer Mail oben die Felder im Kopf alle in der Hintergrundarbe sind. Nur, wenn man in die Adresse oder den Betreff reingeht, wird das Feld weiß, bis man es wieder verlässt. Ich dachte zuerst, dass die Felder deaktiviert sind, aber durch Probieren habe ich dann herausgefunden, dass da an den Farben gedreht wurde. Wie kann ich die Hintergrundfarbe dieser Felder wieder auf Dauer weiß machen?




    Gruß Thomas

  • Hallo,

    Zitat

    Mit dem Update auf die Version 31 haben sich anscheinend diverse "Darstellungsfehler" eingeschlichen.


    Das kann auch sonst bei Update bes. bei Firefox passieren.
    Wie man die Zeilenabstände wieder hinbekommt habe ich hier beschrieben:
    Beitrag 12


    Zu deiner zweien Frage muss ich erst mein virginales Profil starten, da ich bei meinem laufenden Thunderbird zu viele Änderungen und Add-ons habe.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo Thomas,


    ich verwende im Moment den folgenden Code, um die Felder im Verfassen-Fenster zu ändern:


    Viele Grüße,
    tempuser

    Entwickler des Add-ons Mail Merge (Thunderbird / SeaMonkey) und Mitwirkender des Add-ons Cardbook (Thunderbird)

  • tempuser ,
    meinst du die Abstände der Mailadressen in der Sidebar?
    Oder was genau bewirken die Codes?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    der Code ändert für die Felder "Von", "An" und "Betreff" im Verfassen-Fenster die Hintergrundfarbe auf weiß und fügt Ränder hinzu, sodass die Felder dauerhaft so aussehen wie jetzt bei hover oder focus. (Getestet unter Windows und Linux.)


    Viele Grüße,
    tempuser

    Entwickler des Add-ons Mail Merge (Thunderbird / SeaMonkey) und Mitwirkender des Add-ons Cardbook (Thunderbird)

  • mrb :
    Genau das hatte ich gemacht. Aber TB ignoriert das bei mir anscheinend standhaft. Im Baum sind nach wie vor überall dünne weiße Linien dazwischen. Aber erst, wenn man durchscrollt. Zuerst ist alles einheitlich hell. Wenn man dann aber durch den Baum durchlickt, bzw. durchscrollt, bekommt jeder Eintrag oben und unten einen dünnen weißen Rand.
    Ich hatte den TB beendet, die userChrome.css bearbeitet und dann den TB wieder gestartet.



    tempuser :
    Das hat auf Anhieb geklappt.


    Thomas

  • Hallo Thomas,

    "thomasadd" schrieb:


    Genau das hatte ich gemacht. Aber TB ignoriert das bei mir anscheinend standhaft. Im Baum sind nach wie vor überall dünne weiße Linien dazwischen.


    Ich würde einen Test im abgesicherten Modus machen und überprüfen, ob das Problem mit den weißen Linien im Konten/Ordnerbaum auch dann auftritt.
    Im abgesicherten Modus werden alle Add-ons (auch Dritt-Themen) und jegliche userChrome- und/oder userContent-Einträge deaktiviert.


    Wenn das Problem im abgesicherten Modus verschwindet, muss die Ursache bei einem Add-on oder einem Eintrag in deiner userChrome.css-Datei liegen.
    Vielleicht solltest du mal den augenblicklichen Inhalt deiner userChrome.css-Datei hier einstellen.


    Gruß

  • Im abgesicherten Modus besteht das Problem weiterhin.


    hier die userChrome.js:



    Die Enträge für die Zeilenzwischenräume und die weißen Adressfelder sind nach dem Update auf die 31 hinzugekommen.



    Gruß Thomas

  • "thomasadd" schrieb:

    Im abgesicherten Modus besteht das Problem weiterhin.


    hier die userChrome.js:


    Bist du sicher, dass du diese Codes in einer userChrome.js-Datei benutzt?
    Das erscheint mir doch etwas ungewöhnlich für einen Eintrag in dieser Datei.


    Ich würde die gleichen Codes in eine userChrome.css-Datei einfügen, unter dem folgenden Eintrag, der vor jeglichem css-Code stehen sollte:


    Code
    1. @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");
    2. /* set default namespace to XUL */


    Die userChrome.css-Datei muss in den Ordner "chrome" verschoben werden.
    Dann würde ich die userChrome.js-Datei vorübergehend (oder endgültig) aus dem Ordner "chrome" entfernen und mit der neuen userChrome.css-Datei testen.


    Wahrscheinlich handelt es sich in deinem Fall aber um den Bug 909820 "New Aero list-item hover styling leaves white line behind"
    bzw. Bug 1040792

  • Ich habe deinen o. a. css-Code hier noch mal in einem neuen Profil getestet, er funktioniert hier einwandfrei mit vergrößertem Zeilenabstand.
    Weiße Linien werden auch bei mir nicht erzeugt, wenn ich durch den Ordnerbaum klicke.
    Es könnte sich also um einen der von mir zitierten Bugs handeln.
    Leider fehlen mir andere Ideen zu einer Lösung.


    Gruß

  • "Mapenzi" schrieb:

    Weiße Linien werden auch bei mir nicht erzeugt, wenn ich durch den Ordnerbaum klicke


    Ich habe auch die weißen Linien, sie sind im Standard Thema sehr schlecht zu sehen.


    MfG
    EDV Oldi

  • "edvoldi" schrieb:


    Ich habe auch die weißen Linien, sie sind im Standard Thema sehr schlecht zu sehen.


    Ich hatte vergessen zu erwähnen, dass ich Mac OS X benutze.
    Je nach OS gibt es kleine Unterschiede zwischen den jeweiligen Standard-GUI.

  • Mit diesem Code in der userChrome.css können die weissen Linien entfernt werden:

    Code
    1. treechildren:not(.autocomplete-treebody)::-moz-tree-row {
    2. outline-color: transparent !important;
    3. }


    Jedoch sehen dann die Rahmenlinien zwischen zwei selektierten Zeilen etwas fett aus.

  • Seit dem Update auf 31 finde ich die neue Anordnung der Adressfenster ebenfalls sehr nervig und würde mich um ein ähnliches Design wie bei TB 24 freuen.


    Da es sich wohl um eine Datei handelt, die man ändern muss ( und nicht in den about:config Einstellungen) frage ich, wie finde ich diese Datei und welche ist es genau?


    vielen Dank

  • Hallo,

    "Tacuba" schrieb:

    Seit dem Update auf 31 finde ich die neue Anordnung der Adressfenster ebenfalls sehr nervig und würde mich um ein ähnliches Design wie bei TB 24 freuen.


    Hast du die älteren Beiträge in diesem Faden schon gelesen?
    In seinem Beitrag #3 hat tempuser eine Lösung angegeben.


    Die benötigte Datei heißt "userChrome.css" und wird in einem Text-Editor erstellt.
    Sie muss in einen Ordner "chrome" verschoben werden, der im TB-Profilordner neu zu erstellen ist.
    Den Profilordner finden


    Gruß

  • Win 8.1 64 Bit, Thunderbird 31.1.2, POP- und IMAP-Konten, Provider T-Online, AOL und andere.


    Bedauerlicherweise muß ich mich bezüglich der Farben an diesen Thread anhängen. Wenn ich oben rechts das Menü und dann ein Untermenü öffne, erscheint ein komplett schwarzes Fenster. Erst wenn ich mit der Maus hinein gehe, erscheint der Text schwarz auf weiß. Das gilt auch für die folgenden Untermenüs.


    Als Erweiterung verwende ich Lightning und als Plugin den Sumatra PDF-Browser. Im abgesicherten Modus, also ohne diese Zusätze, zeigt sich das selbe schwarze Bild.


    Klaas