Immer neue Probleme mit den Umlauten

Wenn Sie plötzlich keine E-Mails mehr empfangen können

Bitte lesen Sie die Hinweise zu den beiden derzeit häufigsten Problemursachen!

Hier bitte klicken!

Diese rote Box verschwindet, wenn Sie in der rechten oberen Ecke auf das X klicken.

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 68.4.2
      • Wurde gerade auf eine neue Versionsreihe aktualisiert (bspw. von 60.* auf 68.*): Eigentlich nicht
      • Betriebssystem + Version: Windows 10 Pro
      • Kontenart (POP / IMAP): IMAP
    • Postfach-Anbieter (z.B. GMX): Eigener / Telekom / Yahoo
    • Eingesetzte Antiviren-Software: Keine
    • Firewall (Betriebssystem-intern/Externe Software): Keine
    • Router-Modellbezeichnung (bei Sende-Problemen): Fritzbox 6490


    Langsam verzweifel ich an Thunderbird, leider sind alle Anleitungen die ich zu den Problemen mit den Umlauten gefunden habe veraltet und teilweise gibt es die Einstellmöglichkeit nicht mehr.


    Zunächst hatte ich das Problem, dass alle meine E-Mails bei meinen Freunden nicht gelesen werden konnten, weil die Umlaute üöäß alle umkodiert wurden. Nach zahlreichen Versuchen habe ich dass glaube ich aber mittlerweile gelöst. Ich versteh zwar nicht wie aber nachdem ich ca 20 Seiten aus diesem Forum aufgesucht habe funktioniert dass jetzt wunderbar, ABER


    Sende ich jetzt ein PDF Dokument mit einem Umlaut im Namen ÄÖÜß kommt der Anhang so an:


    UTF-8%+wirre Anzahl an Zahlen, Zeichen hast du nicht gesehen und ohne Dateiendung. Diese PDF Datei kann man zwar runter laden umbenenn und wieder eine Dateiendung anhängen dann kann man sie lesen, aber schön ist diese Lösung nicht.


    Code
    This is a multi-part message in MIME format.
    --------------05C2EC8FF6DC531B16730A12
    Content-Type: text/plain; charset=windows-1252; format=flowed
    Content-Transfer-Encoding: 8bit



    Code
    Content-Type: application/pdf; name="=?UTF-8?B?VMOEw5zDlsOfLnBkZg==?="
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment; filename*=UTF-8''%54%C3%84%C3%9C%C3%96%C3%9F%2E%70%64%66
  • Hallo,

    welches sind deine Einstellungen unter Extras > Einstellungen > Ansicht > Formatierung > Schriftarten > Erweitert ?

    Mich interessieren dabei besonders :

    ganz oben Schriftarten für

    Schriftartenkontrolle

    Textkodierungen

    und die aktivierten/nicht aktivierten Kästchen.

    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ja dass hab ich gelesen, aber ich habe wie oben schon erwähnt mindestens 3 verschiedene Anbieter. Das Resultat sieht leider immer gleich aus. Meinen eigenen Mailserver kann ich definitiv ausschließen, denn senden über Smartphone und direkt aus dem Online Zugang werden richtig übertragen. Daher liegt es meiner Meinung nach direkt an Thunderbird.

  • denn senden über Smartphone und direkt aus dem Online Zugang werden richtig übertragen. Daher liegt es meiner Meinung nach direkt an Thunderbird.

    Es würde ja schon ausreichen, wenn die anderen Clients alles als Quoted Printable kodiert senden. Dann tritt der Fehler nicht auf.


    Es ist meines Erachtens auch ein Irrtum, wenn man denkt, dass nur der sendende und empfangende Mail-Server eine Rolle spielen. Wenn ich die Technik und das Problem richtig verstehe, dann könnte ein problematischer Server auch mitten in der Sende-Kette sein, ohne dass Du es überhaupt wissen kannst. Auch dann würde QP vielleicht Abhilfe schaffen können.


    Hast Du in Thunderbird die entsprechende versteckte Einstellung auf true geschaltet, oder denkst Du es einfach besser zu wissen und willst es erst gar nicht probieren?


    Abschließend sei gesagt, dass Du wahrscheinlich nicht nur ein Problem mit den Umlauten hast, sondern evtl. mehrere, die sich gegenseitig beeinflussen könnten. Und ein Teil des Problems kann natürlich Thunderbird sein, der beispielsweise standardmäßig nicht per QP senden "will", da die Entwickler dies aus Prinzip ablehnen.

  • Hast Du in Thunderbird die entsprechende versteckte Einstellung auf true geschaltet, oder denkst Du es einfach besser zu wissen und willst es erst gar nicht probieren?


    Hab ich umgestellt, hat aber nichts geändert!


    Code
    This is a multi-part message in MIME format.
    --------------0281A8898C246927C3D62A34
    Content-Type: multipart/alternative; boundary="------------CEA3487AABF94412FDB0610C"
    Code
    --------------0281A8898C246927C3D62A34
    Content-Type: application/pdf; name="=?UTF-8?B?VMOEw5zDlsOfLnBkZg==?="
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment; filename*=UTF-8''%54%C3%84%C3%9C%C3%96%C3%9F%2E%70%64%66


    Nur am Rande, da ich wirklich keine Ahnung davon habe, oben stand vor der Änderung auch schon send in MIME Format



  • By the Way: Vielen Dank an Euch, dass Ihr versucht zu helfen. Ist ja auch nicht selbstverständlich. Ich nutze Thunderbird jetzt schon soooo lange und mir ist der Fehler eigentlich nie aufgefallen, weil Thunderbird selbst ja alles richtig darstellt. Erst jetzt wo ich Beruflich viel vom PC verschicke mit PDF Anhängen, wurde mir zugetragen, dass das kein Mensch lesen kann. Ich wollte jetzt nicht extra ein neues E-Mail Programm nutzen, da ich wie gesagt schon immer Thunderbird benutze.

  • In Deinem letzten Screenshot solltest Du meines Erachtens unten beides auf UTF-8 umstellen. Und die Option ganz unten aktivieren. Damit sollte man eigentlich auf der relativ sicheren Seite sein.


    Das PDF in den folgenden Beispielen heißt "Lizenzschlüssel.pdf". Als nur ein einziger Umlaut, der aber mehrere Zeichen im Quellcode erfordert, was so auch okay ist.


    Ich habe hier mal ein Beispiel (Ausschnitt des Quellcodes) in UTF-8 ohne QP:


    Und hier kommt die identische Mail ebenfalls in UTF-8 mit QP aktiviert:


    Die Darstellung sowohl des Inhalts als auch des Anhang-Dateinamens ist bei beiden Varianten beim Empfänger vollkommen korrekt und auch beim Speichern des Anhangs wird der Dateiname korrekt übernommen. Die kryptische Darstellung der filename im Sourcecode der Mail hat also überhaupt nichts (negatives) zu sagen, sondern ist technisch notwendig.

  • Auch dass habe ich jetzt eingestellt.


    Code
    --------------97A08BD5306BD91C55E858F6
    Content-Type: application/pdf; name="=?UTF-8?Q?Lizensschl=c3=bcssel=2epdf?="
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment; filename*0*=UTF-8''%4C%69%7A%65%6E%73%73%63%68%6C%C3%BC%73%73%65%6C%2E%70; filename*1*=%64%66


    Und bei dem Empfänger wird der Anhang genau so angezeigt:

    Code
    UTF-8''%4C%69%7A%65%6E%73%73%63%68%6C%C3%BC%73%73%65%6C%2E%70
  • Hallo,

    ich habe ein Konto bei AOL und Yahoo.

    Ich habe bei beiden niemals Probleme mit der Lesbarkeit von Mails mit Umlauten im Text oder im Dateinamen gehabt.

    Ganz egal, ob ich dabei "quoted printable" oder keins verwendet habe und genauso sollte es sein.

    Dabei sehen die Deklarierungen gleich aus wie bei euch.
    In dieser Mail ist mail.strictly_mime und somit "quoted printable" aktiviert.

    Auch wenn der Quelltext der Mail fast unleserlich wegen der Umlaute ist, konvertiert Thunderbird diese bei mir absolut korrekt.

    Zur Info, die Mail wurde von Yahoo an Yahoo und AOL geschickt. Keine Unterschiede nach Empfang.

    Ich würde daher dringend empfehlen, Thunderbird (ausnahmsweise) neu zu installieren und ein neues Profil zu verwenden. Letzteres zunächst nur testweise und nur mit den kritischen Konten. Hierbei sollten zunächst nur IMAP-Konten verwendet werden.


    Außerdem müsste man genau wissen, welcher Mailklient (oder welche Webseite) mit welcher Einstellung (was "quoted printable" betrifft) vom Empfänger benutzt wird.

    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Edited 2 times, last by mrb ().