Kopie von IMAP auf lokale Ordner: Nur Header werden kopiert, keine Nachrichteninhalte

If you suddenly cannot receive any more emails

Please read the notes on the latest two most common causes of problems!

Please click here!

This red box disappears when you click on the X in the top right corner.

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version (konkrete Versionsnummer:( 68.12.0 (32 Bit)
    • Betriebssystem + Version: Windows 10 Pro 2004 (64 Bit), aktuell gepatcht
    • Kontenart (POP / IMAP): IMAP + Local Folders (und noch diverse POP3-Konten, die aber keine Probleme machen)
    • Postfach-Anbieter (z.B. GMX): eine deutsche Universität
    • Eingesetzte Antiviren-Software: Windows-Bordmittel
    • Firewall (Betriebssystem-intern/Externe Software): Windows-Bordmittel


    Liebe Thunderbirdler,


    ich habe ein Problem mit einem Filter, den ich auf einen IMAP-Ordner (Mail-Account einer deutschen Uni) anwende.


    Der Filter soll folgende Aktionen durchführen:


    ****************

    Alle im Posteingang des IMAP-Accounts eingehenden Nachrichten...

    1. als gelesen markieren

    2. in den Posteingang in Lokale Ordner kopieren

    3. in einen anderen Ordner des IMAP-Accounts verschieben.

    ****************


    1. und 3. funktionieren einwandfrei.


    2. funktioniert leider nicht verlässlich. Es werden zwar immer Kopien der Nachrichten im Posteingangsordner von local folders erstellt. Aber manchmal leider nur die Header, keine Inhalte. Das heißt, die Nachrichten im Posteingang in Lokale Ordner sind "leer".


    Das Problem tritt nicht immer/reproduzierbar, aber dennoch sehr oft auf. Und es scheint vor allem aufzutreten, wenn der Filter auf mehrere Nachrichten gleichzeitig angewendet werden muss (das IMAP-Konto wird nicht automatisch abgerufen, sondern nur manuell). Dann wird z. B. eine Nachricht korrekt (mit Inhalten) kopiert, bei drei Nachrichten fehlen aber die Inhalte.


    Gibt es irgendwelche Ideen dazu?

    Danke und viele Grüße
    Patkul

    PS: Dieser (6 Jahre alte) Thunderbird-Bug klingt sehr ähnlich: https://bugzilla-dev.allizom.org/show_bug.cgi?id=1114050

  • Hallo Patkul,


    zur Ursache habe ich leider keine Idee.


    Zur Eingrenzung oder auch zur Umgehung würde ich das betroffene Konto wohl löschen und anschließend neu anlegen. Dazu würde ich das Konto zunächst 'freistellen' von jeglichen Filtern. Dann über Kontenaktionen das Konto entfernen, mit angehakter Option, auch die Daten zu löschen. Thunderbird 1 x beenden und wieder starten. Dann das betreffende Konto wieder anlegen und schließlich die Filter darauf wieder konfigurieren.


    Da es sich um ein IMAP-Konten handelt, sollte dabei nichts verloren gehen.

    Vielleicht ist das Problem damit dann eliminiert. Jedenfalls, wenn es in den Daten des betroffenen Kontos gelegen hatte.


    Gruß

    Sehvornix

  • Hallo zusammen,


    ich habe mittlerweile vieles probiert, inkl. Sehvornix' Vorschlag. Das Problem besteht weiterhin - und mittlerweile sogar verlässlich reproduzierbar. Wobei ich nicht ganz ausschließen will, dass es das schon immer war.


    Jetzt würde ich das Problem so beschreiben (Thunderbird 78.5.1, 32 bit):


    Ein Filter, den ich auf einen IMAP-Ordner (Mail-Account einer deutschen Uni) anwende, soll folgende Aktionen durchführen:


    ****************

    Alle im Posteingang des IMAP-Accounts eingehenden Nachrichten...

    1. als gelesen markieren

    2. in den Posteingang in Lokale Ordner kopieren

    3. in einen anderen Ordner des IMAP-Accounts verschieben.

    ****************


    1. und 3. funktionieren einwandfrei.


    2. funktioniert NUR für die erste E-Mail. Es werden zwar immer Kopien aller Nachrichten im Posteingangsordner von local folders erstellt. Aber IMMER nur fragmentarisch. Der Header besteht nur aus einem Zeitstempel, das wars (siehe unten). Keine Inhalte, keine Anhänge, die Nachrichten im Posteingang in Lokale Ordner sind "leer". Hier ein Beispiel für den (vollständigen!) Quelltext einer solchen verstümmelten Mail:


    Code
    From - Fri Dec 11 08:32:27 2020
    X-Mozilla-Status: 0001
    X-Mozilla-Status2: 00000000
    X-Mozilla-Keys:                                                                                 


    Es gibt also nicht einmal das "From"- oder "Subject"-Feld im Code. Das E-Mail-Vorschau-Fenster (Nachrichtenbereich) ist dementsprechend komplett leer.


    Aber noch eigenartiger ist: Es scheint durchaus ein paar weitere Header-Daten zu geben, denn in der Ordneransicht sind der Betreff, die Beteiligten und das Datum sichtbar. Diese Daten werden kurioserweise aber nicht angezeigt, wenn ich mir den Quelltext der Mail anzeigen lasse.


    Hat vielleicht mit diesen weitergehenden Infos noch jemand eine Idee?


    Danke und viele Grüße

    Patkul

  • Hallo,

    ich würde zunächst einmal vorschlagen, alle beteiligten Ordner zu reparieren.

    Rechtsklick auf den betr. Ordner->Eigenschaften->Allgemein-> Reparieren


    Was auch sein könnte, dass eine Aktion (je nach Reihenfolge in den Filterregeln) nicht mehr ausgeführt werden kann, wenn etwa das Verschieben an 2. Stelle steht.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Auffällig ist, dass Aktion 1 und 3 IMAP-Aktionen sind. Sprich, hier bekommt der Server das entsprechende Kommando uns führt die Aktion aus. Dazu ist keine Download nötig. Für Aktion 2 schon.

    Das erweckt den Verdacht, dass der Thunderbird evtl. nicht bis zum Abschluss wartet. ich würde daher das Filter für einen Versuch ein zwei aufteilen, die manuell ausgeführt werden.


    Filter 1:

    - als gelesen markieren

    - in den lokalen Ordner kopieren


    danach


    Filter 2:

    - in den anderen IMAP-Ordner verschieben

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)