Zeilenumbruch bei Entwürfe beim Bearbeiten kaputt

If you suddenly cannot receive any more emails

Please read the notes on the latest two most common causes of problems!

Please click here!

This red box disappears when you click on the X in the top right corner.

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 78.7.1
    • Wurde gerade auf eine neue Versionsreihe aktualisiert (alte und neue Version angeben): nein
    • Betriebssystem + Version: Windows 10 x64


    Hallo Gemeinde,


    folgendes Problem was schon ziemlich lange besteht:


    Wenn ich eine E-Mail schreibe und diese in den Entwurf lege schaut es optisch gut aus. Auch beim versenden danach bei mir unter Gesendete und auch beim wirklich beim Empfänger. Wenn ich diese Verfasse macht der mir einen automatischen Zeilenumbruch bei irgendwo 66 Zeichen, was okay ist. Wo kann man das eigentlich einstellen?


    Was jedoch nicht passt, ist dann das erneute Öffnen vom Entwurf. Wenn ich diesen nicht verändere und wieder speichere passiert nichts. Allerdings ist das SEHR verwirrend wenn man da etwas ändern muss, weil man dann irgendwie die Zeilen dann intuitiv zurecht fummelt, auch wenn es gar nicht notwendig ist.


    Siehe:

    https://temp.eyespeak.de/tb_entwurf.jpg

    https://temp.eyespeak.de/tb_verfassen.jpg


    Abgesicherter Modus ohne Addons bringt nichts:

    Jemand Ideen?

  • Hallo c303,


    vorweg, so ein Problem habe ich nicht und wenn es öfter vorkäme, wären mir vermutlich auch ein paar einschlägige Beiträge bekannt. Was hat denn die Suchfunktion für Dein Problem ergeben?


    Der automatische Zeilenumbruch nach ~66 Zeichen (eigentlich sind es 72 Zeichen) deutet für mich erst mal auf eine Einstellung für ausschließlich Text-Mails hin. Keine HTML-Mails. Trifft das zu?


    Falls die Einstellung für Rein-Text-Mails gesetzt ist: Je nach dem, wie man die Einstellungen zum Verfassen von eMails gesetzt hat, wird dieser Umbruch bei 72 Zeichen nicht gleich sichtbar. Ändern kann man das meines Wissens auch nicht. Falls doch, musst Du warten, ob sich noch jemand anderer dazu äußert. Jedenfalls erfolgt der Umbruch bei Rein-Text-Mails erst beim Versenden. Darstellung beim Verfassen ist wie gesagt ggf. anders.


    Generell ist es problematisch, den Zeilenumbruch beim Empfänger schon als Absender festlegen zu wollen. Am besten klappt das immer noch, wenn man gar nicht versucht, den Zeilenumbruch zu steuern, sondern das komplett der Software überlässt. Die ENTER-Taste ist schließlich auch nicht wie bei der Schreibmaschine für den Wagenrücklauf zu einer neuen Zeile gedacht, sondern am PC für einen neuen Absatz.


    Gruß

    Sehvornix


    P.S.: Die Screenshots habe ich mir übrigens nicht angeschaut. Gibt es einen Grund, warum Du die nicht direkt hier in Deinen Beitrag eingefügt hast? So ist das problematisch, da ich für meinen Teil nicht auf solche externen Links klicke und das auch von anderen hier weiß und außerdem werden die Screenshots irgendwann nicht mehr verfügbar sein, was Deinen Beitrag dann nicht mehr nachvollziehbar macht. Im Gegensatz dazu wären die Screenshots wenn hier direkt eingebunden, dauerhaft im Kontext Deines Beitrags nachvollziehbar.

  • Doch, sicher -

    Falls die Einstellung für Rein-Text-Mails gesetzt ist: Je nach dem, wie man die Einstellungen zum Verfassen von eMails gesetzt hat, wird dieser Umbruch bei 72 Zeichen nicht gleich sichtbar. Ändern kann man das meines Wissens auch nicht.

    ==> Unter "Extras/Einstellungen/erweitert/Konfiguration bearbeiten" findet man den Wert mailnews.wraplength für den Zeilenumbruch. Standard ist 72.


    Und mit mail.wrap-long_lines kan man den Umbruch ausschalten .

  • Sie Suche hatte für mich keinen passenden Treffer, deswegen mein Posting.


    Betrifft nur Text Mails.


    mailnews.wraplength ist auf 72 gesetzt, deswegen wundert es mich ja.


    Was passiert denn wenn ihr einfach einen Text als Text E-Mail speichert und im Entwurf anschaut?

    https://www.loremipsum.de/

  • Was passiert denn wenn ihr einfach einen Text als Text E-Mail speichert und im Entwurf anschaut?

    Das:


    Auch beim wiederholten Aufruf und erneuten Abspeichern, ändert sich die Darstellung nicht. Eingestellt ist hier trotz Rein-Text-Mail eine Proportionalschrift. Aber man sieht ja gut, dass beim Verfassen und im Status Entwurf noch nichts bei 72 Zeichen umbrochen wird.


    So kommt es in Outlook an:


    Da Outlook sich hier wieder eine Extrawurst brät, hier noch mal das Ergebnis, wenn der Empfang einer solchen Mail mit Thunderbird erfolgt:


    Hier hatte ich zur besseren Nachvollziehbarkeit die Schriftart außerdem auf 'Feste Breite' geändert. Dabei kommt eine courier-artige Schrift zum Einsatz. Jedenfalls in Thunderbird wird ersichtlich, dass der Umbruch erst mit dem Absenden erfolgt und dann auch beim Empfänger sichtbar ist, wenn sich das Programm an die Vorgabe der Mail hält.


    Dein erster Screenshot zeigt Zeilen mit 72 Zeichen. Woher der Umbruch im zweiten Screenshot bei 60 und 'n Keks Zeichen kommt ... im Moment keine Idee.


    Gruß

    Sehvornix

  • Auch beim wiederholten Aufruf und erneuten Abspeichern, ändert sich die Darstellung nicht. Eingestellt ist hier trotz Rein-Text-Mail eine Proportionalschrift. Aber man sieht ja gut, dass beim Verfassen und im Status Entwurf noch nichts bei 72 Zeichen umbrochen wird.

    Naja - ich hatte noch einen zweiten Parameter erwähnt, mit dem man den Umbruch ausschalten kann, Überprüf den mal bitte.

  • Allerdings ist das SEHR verwirrend wenn man da etwas ändern muss, weil man dann irgendwie die Zeilen dann intuitiv zurecht fummelt, auch wenn es gar nicht notwendig ist.

    Eine Lösung habe ich nicht. Aber ich kann es reproduzieren:

    1. Mehrzeilige Textmail verfassen.
    2. Als Entwurf speichern.
    3. Entwurf bearbeiten, d.h. mittendrin in einer Zeile Text hinzufügen, sodass es zu einem Zeilenumbruch kommt.
    4. Ergebnis: Die nächste Zeile ist nicht korrekt umgebrochen. Wenn man hier den Zeilenumbruch entfernt, setzt es sich das merkwürdige Verhalten auf die nächste Zeile fort.

    Ich könnte mir vorstellen, dass sich HTML-Mails anders verhalten. Hab' ich aber nicht ausprobiert.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Hallo Susanne,

    Aber ich kann es reproduzieren:

    Interessant. Hier bei mir kann ich das mit Deiner 4-Punkte-Anleitung allerdings nicht reproduzieren. Egal wie und wo ich in den Entwurf eine Zeile mit Zeilenumbruch einfüge oder die so geschaffenen Zeilenumbrüche auch wieder entferne, bekomme ich kein anderes als das oben dokumentierte Verhalten. Der Entwurf bleibt ohne Zeilenumbrüche an unerwünschter Stelle und der Umbruch folgt auch weiter fließend der Breite des Verfassen-Fensters.


    Hallo graf.koks,

    Naja - ich hatte noch einen zweiten Parameter erwähnt, mit dem man den Umbruch ausschalten kann, Überprüf den mal bitte.

    Richtet sich Deine Antwort und Prüf-Bitte an mich oder an den TE? Da das Problem bei mir nicht auftritt, kann ich das auch nicht testen. Aber ich hab gedanklich notiert, dass es diese Einstellmöglichkeit gibt. Danke dafür.


    Gruß

    Sehvornix

  • Interessant.

    In der Tat. Ich habe noch etwas festgestellt. Ich kann es nur mit Entwürfen reproduzieren, die ich vor längerer Zeit erstellt habe. Das heißt, mit einer viel älteren Version des Thunderbird. Auch diese alten Entwürfe wurden schon verschlüsselt gespeichert, damals natürlich noch mit GnuPG.

    Vielleicht liegt die Ursache also in einem Bug, der inzwischen behoben wurde oder in der Verschlüsslung.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

    Edited once, last by Susi to visit ().

  • Naja - ich hatte noch einen zweiten Parameter erwähnt, mit dem man den Umbruch ausschalten kann, Überprüf den mal bitte.

    Richtet sich Deine Antwort und Prüf-Bitte an mich oder an den TE? Da das Problem bei mir nicht auftritt, kann ich das auch nicht testen. Aber ich hab gedanklich notiert, dass es diese Einstellmöglichkeit gibt. Danke dafür.


    Gruß

    Sehvornix

    Hallo,

    daß das Problem bei Dir nicht auftritt kann eben mit diesem Schalter zusammenhängen - deshalb der Hinweis an beide...

  • Mit der Version 78.x wird Enigmail nicht mehr benötigt und auch nicht benutzt. GnuPG wird in einigen Sonderfällen benötigt, wie z.B. bei der Benutzung einer Smartcard. Das muss man dann aber explizit einstellen.

    Ich habe heute nochmals in meine Testentwürfe von gestern geschaut. Die wurden ebenfalls verschlüsselt gespeichert, aber eben mit dem integrierten OpenPGP. Das Problem mit den Umbrüchen trat nicht auf.


    Das ist kein Beweis, dass es mit GnuPG zusammenhängt, allenfalls ein Indiz. Jedenfalls kann ich es mit der 78.7.1 (Linux) und der 78.8.0 (Windows) zur Zeit nicht mehr reproduzieren.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Ich meinte ja das integrierte OpenPGP im Thunderbird. Windows 78.8.0 (64-Bit) nutze ich aktuell.


    Nochmals zur Erinnerung;

    Die gespeicherte E-Mail schaut in Ordnung aus. Die dann aber geöffnete E-Mail aus dem Entwurf nicht mehr. Schließt man den Entwurf wieder, schaut es wieder in Ordnung aus, wenn man die Voransicht der gespeicherten E-Mail ansieht.


    Seltsam.


    Das die E-Mail zwangsverschlüsselt gespeichert wird ist zusätzlich ein Problem.