Ändern der Schriftarten

  • Hallo zusammen.


    ich fahre ein WIndows 10 und die aktuelle Thunderbirdversion 78.10 64bit. Ich komme von einer Version aus der fernen Vergangenheit, 52 oder so. Ich hatte die ein paar Jahre erzwungen so alt gehalten, damit ich bestimmte Addons benutzen konnte, aber testweise habe ich gestern die neueste Version ausprobiert und behalte die auch. Trotzdem: Kulturschock :) Ich benutze die englische Version, aber wir können ja alle übersetzen.


    Ich bin gaaaanz alte Schule und hasse alles, was nicht plaintext ist. Ich möchte meine mails in plain-text verfassen. Bei mir sieht das so aus:



    Während die vielen >>> für mich Masochisten einfach grossartig aussehen, tut der Font das aber nicht. Den will ich ändern. Sehr gerne in einen Times New Roman. Und hier fangen für mich die Probleme an. Welche Beschreibungen und Forenratschläge auch immer ich gefunden habe, es geht immer um diesen Tip. Umstellen könne man das bei:


    "Tools -> Options -> Display -> Formatting"


    Dieser Befehlspfad existiert aber nicht. Mag an der Versionsnummer liegen. Wie stellt man das nun um? Ich finde hier keinen Punkt, an dem ich die Schriftarten für Plain text umstellen könnte.


    Für Tipps wäre ich dankbar. Es könnte ja sogar sein, dass es nicht geht bei Plaintext eine Schriftart mit variabler Buchstaben-Größe zu wählen, aber das müsste ich dann auch mal wissen.

  • Go to Best Answer
  • graba

    Approved the thread.
  • Ich bin gaaaanz alte Schule und hasse alles, was nicht plaintext ist.

    Dto. - und als solcher schaue ich mir bei neuen Versionen erst mal «alle» Konfigurationspunkte genau an. Man weiß ja nie, was sie alles geändert haben …

    Ich finde hier keinen Punkt, an dem ich die Schriftarten für Plain text umstellen könnte.

    In der deutschen Version:

    Einstellungen → Allgemein → Sprache & Erscheinungsbild → Erweitert → Schriftartenkontrolle → [ ] Unproportionale Schriftart für Reintext-Nachrichten verwenden


    Falls du die Schriftart änderst, daran denken: Für Lateinisch «und» Andere Schreibweisen!

  • Erstmal danke für die Antwort. Den Punkt hatte ich gesehen, aber meine Änderungen hatten keinen Effekt. So sehen im Moment meine Einstellungen aus.



    Ich weiss nicht was mit dem Eintrag "Proportional" gemeint ist. Da kann ich nur Serif und Sans Serif einstellen. Ansonsten ändert er hier und da die benutzt Fonts, aber nicht wenn ich eine mail verfasse. Kann es sein, dass das die proportionale Schriftart wäre und ich einfach nur keinen Unterschied sehe zwischen Serif und Sans Serif? Ist eine Schriftart wie Times New Roman vielleicht zuviel für Plain Text?

  • Und jetzt habe ich noch ein ganz anderes Problem. Denn wenn ich schreibe, dann habe ich nur eine sehr begrenzte "Breite" des Eingabefeldes. Kann ich schwer beschreiben. Das Bild erklärt es besser.


  • Ich weiss nicht was mit dem Eintrag "Proportional" gemeint ist. Da kann ich nur Serif und Sans Serif einstellen.

    Das bezieht sich auf Schriftarten mit vaiabler Breite, da gibt es welche mit und ohne Serifen.[1] Ich verwende (unter Linux) die Schriftart «Liberation Sans» und «Liberation Mono». Bei «Liberation Serif» sieht man leichte Unschärfen, das möchte ich meinen Augen nicht zumuten.


    Ein Beispiel für Liberation Mono/Serif/Sans, Schriftgröße 28:


    «Times New Roman» ist eine Schrift mit Serifen, da ist die obige Auswahl irrelevant.

    Ansonsten ändert er hier und da die benutzt Fonts, aber nicht wenn ich eine mail verfasse.

    Hast du die Änderungen auch mit «Ok» übernommen?

    Kann es sein, dass das die proportionale Schriftart wäre und ich einfach nur keinen Unterschied sehe zwischen Serif und Sans Serif?

    Richtig - es gibt keinen Unterschied bei dieser Schriftart.

    Ist eine Schriftart wie Times New Roman vielleicht zuviel für Plain Text?

    Nein, höchstens für deine Augen. Je kleiner die Schrift, umso mehr Unschärfe wird sichtbar. Ich habe lange experimentiert, bis ich die für mich optimale Schrift und Einstellung für den Bidschirm gefunden hatte. Es hängt von vielen Faktoren ab (Betrachtungsabstand, Bildschirmabmessungen, native Auflösung, Pixel/inch, usw.), aber das ist ein Kapitel für sich …


    [1] https://de.wikipedia.org/wiki/Liste_von_Schriftarten

  • Und jetzt habe ich noch ein ganz anderes Problem. Denn wenn ich schreibe, dann habe ich nur eine sehr begrenzte "Breite" des Eingabefeldes. Kann ich schwer beschreiben.

    Ist das schon seit dem Umstieg auf die neue Version oder nachdem du mit den Schriftarten experimentiert hast? Schau mal unter:


    Einstellungen → Allgemein → Konfiguration bearbeiten → Suchen: wrap


    Stehen dort alle Schlüssel auf «Default»? Falls nicht, kannst du sie mit Rechtsklick → Zurücksetzen.

  • Nein, ich glaube das hat mit den Änderungen nichts zu tun. Ich meine es war beim ersten Test schon so, aber wer weiss was da an config-leichen in meinem uralten Thunderbird herumlag, die jetzt aus dem Keller kommen. Ich vermute es wird nicht alles durch die Neuinstallation verschwunden sein... ?


    Im Config Editor steht unter Wrap alles im default. Und egal was ich ändere, das Compose-Verhalten bleibt immer gleich. Was mich auch verwirrt: Es sind 40 Zeichen, aber wenn ich in die Zitate gehe und mir da eine hübsch leere Zeile nehme, kann ich auf 80 oder 82 gehen. TB stoppt mich dann nicht beim Tippen.


    Setze ich die Accounteinstellungen auf HTML, dann ist alles so wie es sein soll.


    Was das andere Thema betrifft... ich habe die chrome.css entdeckt. ;) Ich brauche nur noch den passenden Code als Inhalt. Denn ehrlich gesagt... ich gebe hier auf den Font für Plaintext zu ändern. Ich habe alles ausprobiert, ich habe den Font auch entdeckt (irgendwas mit Westernxyz, das kann man unter den Fonts einstellen und per config editor kann ich auch die Grösse ändern. Aber den Font selbst wechseln...? Nein.


    Wenn das nicht klappt, dann wechsle ich einfach zu den HTML-Usern. Was soll's. Danke für die investierte Zeit. Es ist bleibt ungelöst, und nun wandere ich mal zu Euren Freunden in der Code-Abteilung. :)


    /Edit: Ach, alles Quatsch. Ich akzeptiere den Font einfach, was soll's. Aber lösen müsste ich natürlich das Problem mit den 40 Zeichen. Das wäre ein Killer. Dann MÜSSTE ich zu HTML wechseln, wenn ich das nicht repariert bekomme. Soll ich da mal einen anderen Thread für aufmachen?

    Edited once, last by Samunita ().

  • Ich meine es war beim ersten Test schon so, aber wer weiss was da an config-leichen in meinem uralten Thunderbird herumlag, die jetzt aus dem Keller kommen. Ich vermute es wird nicht alles durch die Neuinstallation verschwunden sein... ?

    Ich würde TB erst mal mit deaktivierten Add-ons neu starten und wenn das nichts hilft, mit einem neuen Profil.

    Ich habe alles ausprobiert, ich habe den Font auch entdeckt (irgendwas mit Westernxyz, das kann man unter den Fonts einstellen und per config editor kann ich auch die Grösse ändern. Aber den Font selbst wechseln...? Nein.

    Für die Font-Auswahl und die Größe brauchst du nicht den config editor, das geht alles über Einstellungen. Mein Beispiel mit der Schriftart Liberation sollte nur den Unterschied zwischen «serif» und «sans serif» verdeutlichen. Diese gibt es m. W. nicht unter Linux, genauso wenig wie Times New Roman unter Linux.

    Wenn das nicht klappt, dann wechsle ich einfach zu den HTML-Usern.

    Ich hätte nicht gedacht, daß du so schnell die guten Vorsätze über Bord wirfst … ;)

  • Aber ich komme mit den Einstellungen halt nicht weiter. Nichts, das ich tue, hat irgendeinen Einfluss auf den Plain-Text-Font. Ab irgendeinem Zeitpunkt muss man sagen, dass es dann halt reicht. Woran auch immer es liegen mag. Das waren zuviele Stunden. ;)

    • Best Answer

    Hallo,


    Tools - Options - General - Language & Appearance - Advanced - Monospace - Schriftart festlegen

    Font Control - Häkchen setzen bei

    Allow messages ...

    Use fixed width ...


    mit OK bestätigen


    Eventuell muss der Thunderbird neu gestartet werden!


    Viel Erfolg

    Stylist

  • das verändert bei meinen mails NUR IN DER VORSCHAU die Schriftgrösse. Also wenn ich die mails öffne, dann habe ich wieder die normale Schriftgrösse.


    Meine Einstellungen: Ich sehe die mails in simple html. Ich variiere beim Testen zwischen Schreiben in HTML und Plain Text.


    Irgendwas ist seltsam. Ich habe auch gerade per Teamviewer einen anderen Thunderbird getestet und dabei die 40 Zeichen pro Zeile aktiviert. Wie auch immer ich das gemacht habe. Auch ein erstes Testen beim Verändern der default Schriftgrösse hat funktionert, zwei Minuten später wollte ich das dem User vorführen und es hat nicht mehr geklappt. Änderungen nicht mehr möglich, weil keine Änderung des Settings angenommen wird. Ich GLAUBE das war bei mir auch so...


    Ich könnte echt heulen. Aber das sieht mir langsam schlicht nach einem Bug aus. Nachher mache ich mal einen reset und stelle alles auf default um.

  • Hallo,


    bei allem Respekt, kann es sein, dass Du eine Menge durcheinander bringst!

    Ich möchte meine mails in plain-text verfassen

    Meine Einstellungen: Ich sehe die mails in simple html. Ich variiere beim Testen zwischen Schreiben in HTML und Plain Text.

    Kannst Du Dich auf Reintext-Mails einigen!

    Während die vielen >>> für mich Masochisten einfach grossartig aussehen, tut der Font das aber nicht. Den will ich ändern. Sehr gerne in einen Times New Roman.

    das verändert bei meinen mails NUR IN DER VORSCHAU die Schriftgrösse

    Was möchtest Du denn nun ändern, Schriftart oder Schriftgröße?


    Ich persönlich würde bei Reintext-Mails eine Schriftart wie Consolas verwenden, eine Schriftart mit fester Breite, dies ist übrigens auch die Voreinstellung in einem neuen Profil. Telefonnummern untereinander sind wunderbar angeordnet und gut lesbar.

    Proportionale Schriftarten wie Arial oder Verdana sind den HTML-Mails vorbehalten, die ich aber nur ausnahmsweise bei Antworten verwende.

    Ich könnte echt heulen. Aber das sieht mir langsam schlicht nach einem Bug aus. Nachher mache ich mal einen reset und stelle alles auf default um.

    Starte den Thunderbird mit einem neuen Profil, lege ein IMAP-Konto an und teste!


    Einfach nur durchhalten, es wird schon

    Stylist

  • Bei allem Respekt, aber die Dinge ändern sich, wenn bestimmte Methoden nicht funktionieren. Angefangen hat das mit einem Wunsch nach Plaintext, aber wenn ich nur 40 Zeichen pro Zeile habe und das nicht verändern kann (Tips dazu haben nicht geholfen), dann MUSS ich auf html gehen, ob ich will oder nicht.


    Es ist auch völlig egal, denn ich müsste in der Lage sein, ALL diese Dinge zu tun. Ob ich nun plain text oder html schreibe oder lese, oder in welcher Grösse oder Schriftart, ist ja egal. Ich kann mich ja in 2 Sekunden neu entscheiden und ich weiss auch wo die Knöppe sind. Es klappte halt nicht.


    Ich habe eben Deinen Tip NOCHMAL durchgeführt und diesmal klappt's reibungslos. Bei mails, die ich in html und solchen, die ich in plain text schreibe. Der Fehler lag darin, dass das nicht bei allen mails ersichtlich war. Bei einer ganzen Ladung von Testmails, die ich gestern an mich gesendet hatte, und die ich mir dann nach der Änderung in den Einstellungen angesehen habe, klappte es nämlich NICHT. Die scheinen unveränderbar zu sein. Warum auch immer, hat bestimmt nen Grund. Und nach kurzem Browsen durch mein Archiv sieht es mir ein bisschen so aus, als ob das DIE EINZIGEN mails waren, bei denen sich die Ansicht nicht verändert.


    Ja. Also danke für den Tip. Mein HTML funktioniert jetzt wieder. Hatte es vermutlich auch vorher, aber wenn man nur auf seine fehlerhaften testmails schaut, dann bleibt man halt doof. Von Plain Text hatte ich mich schon vor Deinem Tip verabschiedet, die investierte Zeit reicht. Es ist genug.


    Man hat mir inzwischen auch mitgeteilt, dass meine Träume html mit den Dreiecken zu schreiben nicht realistisch seien. Ich akzeptiere jetzt einfach das Ergebnis und vielleicht hätte ich das von anfang an. Also danke an alle.

  • Hallo Drachen,


    es macht immer wieder Spaß bei solchen Hinweisen! ^^


    Weißt Du, warum diese 'Dreiecke' nicht in einer Klickibunti-Mail verwendet werden können?

    Schriftart: Lucida Handwriting


    Gruß

    Stylist

  • Hallo Stylist,


    nein, weiß ich nicht und habe ich auch nich nicht ernsthaft hinterfragt oder recherchiert.

    Es sind wohl die Mechanismen beim Antworten an sich, also größer-als-Zeichen plus Leerzeichen bei rein-Text und Einrückung und ggf. bunte Linien bei HTML.


    Hat alles seine Vor- und Nachteile und m.E. ist es nicht lohnend, irgendein bestimmtes Verhalten auf Dauer haben zu wollen. Beim Beantworten betrifft es u.a. die Zeilenumbrüche, die bei Rein-Text nie wirklich toll waren - allerspätestens bei der dritten Antwort wird alles wild zerschossen á la

    > > > lange lange Textzeile
    > kurzer Rest
    > > > lange lange textzeile
    > kurzer Rest ...


    Will ich diese Marotte wirklich auch bei HTML-Mails, wo es i.d.R. (je nach Mailclient) immerhin einigermaßen gut klappt mit den autmatischen Umbrüchen? Eher nicht.


    MfG

    Drachen

  • Angefangen hat das mit einem Wunsch nach Plaintext, aber wenn ich nur 40 Zeichen pro Zeile habe und das nicht verändern kann

    Dazu solltest du ggf. ein neues Thema eröffnen. Ich selbst kann dazu wenig beitragen, aber andere hier schon. Das Standardverhalten, so wie ich es kenne, ist so:

    Beim Verfassen wird nach den eingestellten 72 Zeichen automatisch umgebrochen. Das ist kein harter Umbruch, wie man ihn durch Return oder Strg + Return erzeugt. Er betrifft nur die Darstellung im Verfassenfenster. Bei der empfangenen Mail wird dann je nach Fensterbreite umgebrochen.

    Antwortet man auf so eine Mail, dann wird die zitierte Originalmail allerdings nach den 72 Zeichen umgebrochen.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Ja, aber er schreibt ja, dass er das wegen dieses Problems wider Willen müsse. "Muss" sogar in Großbuchstaben. Das scheint ihm also eine rechte Qual zu sein. ;)

    Da wollte ich eine Möglichkeit aufzeigen, dem Zwang zu entkommen.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)