manche An-Adressen in roter Farbe

  • Thunderbird-Version: 24.4
    Betriebssystem + Version: Win XP Pro
    Kontenart (POP / IMAP): IMAP
    Postfachanbieter (z.B. GMX): Intranet


    Manche Empfänger-Adressen werden bei Thunderbird in roter Farbe dargestellt, andere in schwarzer Farbe. Die Adressen sind aber alle im Adressbuch. Wie kommt es zu solch einer Farbgebung? Ich habe gedacht, es hätte damit zu tun, dass die Adressen nicht im Adressbuch sind, nach einer Überprüfung aber festgestellt, dass sie doch drin stehen. Ich habe schon rumgesucht, aber nichts gefunden, was zur Aufklärung helfen könnte. Man sollte ja meinen, dass die Farbgebung einen wichtigen Hinweis darstellt - nur was damit bezweckt wird, weiß ich nicht.


    Martin

  • Hallo Martin


    und willkommen im Thunderbird-Forum!


    Deine Annahme ist richtig, nicht im Adressbuch vorhandene Adressen werden rot angezeigt. Warum das nun aber bei dir auch bei bereits gespeicherten Adressen so ist?
    Sind die wirklich identisch geschrieben? Erhältst du den Adressvorschlag, wenn du anfängst zu tippen?


    Teste mal im Thunderbird-SafeMode (Abgesicherter Modus) (dazu TB mit gedrückter Umschalttaste starten oder in TB=> Hilfe>Mit deaktivierten Addons neu starten) und/Oder erstelle mal mit dem Profilmanager ein neues Profil und teste es dort.

  • Sorry, die Antwort ist mir irgendfwie durch die Lappen gegangen. Also:


    Die Adressen entsprechen dem Adressvorschlag von Thunderbird. Deswegen verwundert es mich ja auch so.


    Die Sache mit dem Thunderbird-SafeMode muss ich mal testen, ich glaube aber, dass gar keine Addons installiert sind, wenn es darum geht. Es handelt sich um eine Installation auf einem Büro-PC, da komme ich nicht immer dran, daher dauert es wohl etwas.


    Wenn ich ein neues Profil erstelle, habe ich doch auch kein Adressbuch, oder? Die Rotfärbung geschieht ja nicht bei allen Adressen, deswegen vermute ich, wird sich das Problem dann nicht so leicht reproduzieren lassen. Mal sehen...

  • Hallo,


    auch ohne Addons bringt der SafeMode ab und an das System wieder ins Reine, ein Versuch schadet ja nicht.
    Ein neues Profil ist natürlich ohne Adressen, aber du kannst die Adressbücher zum Test rein kopieren, es soll ja nur ein Test sein.
    Auch möglich: exportiere die Adressen als ldif, lösche die Adressbuchdateien *.mab im Profil und importiere die Adressen wieder, alternativ kannst du zuvor in TB neue Adressbücher erstellen und die Adressen umkopieren.
    Beide Maßnahmen führen zu einer Neustrukturierung des Adressbuches und sollten zielführend sein.

  • Liebes Forum,


    das Problem habe ich jetzt auch erstmalig mit TB 31.0 (Windows 7 professional, IMAP, 1und1.de.)


    Alle eingegebenen Adressen werden entsprechend den Adressbuch-Einträgen vervollständigt, aber mit roter Schriftfarbe angezeigt. Safe-mode und ein neues Profil haben nichts geändert. Was ist zu tun? Ich hoffe ja, dass es nicht so ist: "It's not a bug, it's a feature!".


    Grüße aus Hamburg


    Heiner

  • Hallo rum


    ich habe das Problem nach dem Update ebenfalls, aber nur bei einigen wenigen Adressen.
    Gerade habe ich es in einem völlig unveränderten Profil mit nur 2 Konten und einem eigenen Adressbuch getestet.
    Einen Fehler in der Adresse halte ich für ausgeschlossen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    ich habe festgestellt, dass eine Adresse rot dargestellt wird, wenn diese doppelt im Adressbuch vorhanden ist. Ich habe diesen Doppeleintrag gelöscht und dann war die Adresse wieder schwarz.

    Viele Grüße


    Michael


    Win 8.1 * 64 & Win 7 * 64 / AV & FW Norton Security 22.12.0.104
    pop.1und1.de:995 SSL/TLS Passwort, normal
    smtp.1und1.de:587 STARTTLS Passwort, normal true

    FRITZ!Box 7490

  • Ich habe inzwischen ein workaround gefunden: in about:config den Eintrag mail.autoComplete.highlightNonMatches auf false einstellen. Dann ist der Eintrag im An:-Feld immer schwarz. Was aber auch den Nachteil hat, dass dann Adressen, die nicht im Adressbuch sind, nicht rot angezeigt werden.


    Gruß Heiner

  • Zitat von "pinkspiti"

    Ich habe inzwischen ein workaround gefunden: in about:config den Eintrag mail.autoComplete.highlightNonMatches auf false einstellen. Dann ist der Eintrag im An:-Feld immer schwarz. Was aber auch den Nachteil hat, dass dann Adressen, die nicht im Adressbuch sind, nicht rot angezeigt werden.


    Hallo pinkspiti,


    bist Du den dem Hinweis von Dinole

    Zitat von "Dinole"

    ich habe festgestellt, dass eine Adresse rot dargestellt wird, wenn diese doppelt im Adressbuch vorhanden ist. Ich habe diesen Doppeleintrag gelöscht und dann war die Adresse wieder schwarz.

    mal nachgegangen?


    Vielleicht ist Dein "workaround" gar nicht erforderlich.


    Gruß
    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • Hallo,
    das mit den doppelten Adressen kann nicht der alleinige Grund sein. Das hatte ich schon überprüft und die doppelten gelöscht und trotzdem bleibt es bei rot. Es muss noch ein weiteres Kriterium dafür geben.
    Ich vermute es hängt mit dem Anzeigenamen zusammen, setze ich nämlich unter "Anzeigenamen" (die anderen Felder darüber sind frei) einen einzigen Namen und mach darunter einen Haken, ist die Adresse später schwarz.
    Hatten wir das Problem nicht schon mal?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    [Vermutung!]
    Der Schlüssel, welcher das "abwürgt", heißt ja: mail.autoComplete.highlightNonMatches.
    Ich lese daraus, wenn bei der Autokomplettierung keine (= Adresseintrag nicht vorhanden) oder keine eindeutige (mehrfach der gleiche Name und/oder die gleiche Adresse) Zuordnung möglich ist, treibt es dem TB die Schamröte ins Gesicht.
    [/Vermutung!]


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo,


    die eingebene Adresse erscheint bei mir auch dann in rot, wenn es zu dieser Adresse nur einen (1) Eintrag in meinen Adressbüchern gibt.


    Gruß Heiner

  • Hallo,
    nach längeren Tests habe ich FOlgendes herausbekommen:
    Es hängt in der Tat mit dem Auto-Vervollständigen zusammen.
    Genauer gesagt, wie ich die Adresse eingebe.
    Beispiel info@phoenix.de
    Tippe ich "phoenix" ein und wähle den angebotenen Vorschlag aus, wird die Adresse rot.
    Tippe ich dagegen "info@" und mache die Auswahl, ist die Adresse schwarz.
    Außerdem muss man bei vorhandenen Namen diesen selbst eintippen und nicht die Mailadresse.
    Das ganze ist auf jeden Fall ein Bug, zu dem es auch schon bug-reports gibt.
    Vielleicht findet ja noch jemand weitere Kriterien.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    deine Tests habe ich bei mir nachvollziehen können. Ich frage mich nur, wie die Änderungen in TB 31 vorgenommenen Änderungen vorher getestet werden.


    Gruß Heiner

  • Hallo,

    Zitat von "pinkspiti"


    Ich frage mich nur, wie die Änderungen in TB 31 vorgenommenen Änderungen vorher getestet werden.


    das grundsätzliche Problem besteht darin, dass zu wenige User sich als Tester zur Verfügung stellen. Deshalb auch immer wieder Aufrufe wie folgender: Beta-Tester für Thunderbird 30 und 31 gesucht

  • Hallo,

    Zitat von "graba"


    das grundsätzliche Problem besteht darin, dass zu wenige User sich als Tester zur Verfügung stellen. Deshalb auch immer wieder Aufrufe wie folgender: Beta-Tester für Thunderbird 30 und 31 gesucht


    Ich muss gestehen, dass ich dieses Problem schon seit einigen Beta-Versionen (so ungefähr ab 28 oder 29 beta) beobachtet habe, aber leider keinen Bug Report erstellt habe. :redface:
    Der wurde inzwischen von einem anderen Nutzer erstellt:
    Bug 1042561 "Addressing autocomplete widget: Typed text in red despite results/matches found if suggestions change by last input".
    Siehe auch What the H*** with TB 31


    Gruß