Ärger ab TB 68.6.0 mit altem Profil

  • Moin,



    mit der automatischen Migration auf TB 68.6.0 war die Anwendung für mich nicht mehr zu gebrauchen:


    • Konten wurden nicht mehr angezeigt
    • Kalender waren nicht mehr sichtbar
    • TB stürzte ab
    • Keine Add-Ons mehr installiert


    Diese "Fehler" traten bei W10 und Ubuntu gleichsam auf. Auch eine Neuinstallation (bei Ubuntu über Paketliste, PPA und manuell) mit anschließendem Rückspielen meines Profils (immerhin 1,3 GB) brachte auf beiden Systemen keine Abhilfe. Witzig war, dass ich die Add-Ons aus meinem Profil nur im Debug-Modus anzufassen brauchte, danach waren sie in der Oberfläche zu sehen, funktionierten sogar. Nach einem Neustart zeigte sich allerdings wieder das alte Fehlerbild.



    In einem weiteren Schritt habe ich dann TB ab 60.9.1 versionsweise (ohne Beta) manuell installiert und mein Profil eingebunden. Alles klappte wunderbar bis zur 68.5.0! Nun habe ich diese Version "geklemmt" (Rechtevergabe beim Update) und warte auf eine Lösung für nachfolgende Versionen.



    Wo steckt der Wurm bei TB 68.6.0?





    Thunderbird-Version: ab 68.6.0

    Wurde gerade auf eine neue Versionsreihe aktualisiert (alte und neue Version angeben): alles vor 68.6.0

    Betriebssystem + Version: Ubuntu 18.04 und W10 Pro

    Kontenart (POP / IMAP): IMAP

    Postfach-Anbieter (z.B. GMX): diverse

    Eingesetzte Antiviren-Software: Defender bei W10

    ...man liest sich...

    /michael/

    • Best Answer

    Schlussbemerkung am 26.04.2020:

    Auf einem separaten Rechner mit Ubuntu 18.04 habe ich TB 68.7.0 über das PPA installiert. Nach etwa zwei Stunden war ich wieder auf dem aktuellen Stand. Danach bin ich mit diesem Profil auf meine anderen Rechner umgezogen. Keine Probleme und keinen Ärger mehr. Tief in meinem Inneren bleibt natürlich die Frage, wie es zu den vorherigen Problemen kommen konnte.


    Bleibt gesund!

    ...man liest sich...

    /michael/

  • Hallo,


    Konten wurden nicht mehr angezeigt
    Kalender waren nicht mehr sichtbar
    TB stürzte ab
    Keine Add-Ons mehr installiert

    Dann hast du vermutlich Thunderbird upgedatet und hattest ein älteres Profil. Das möchte Mozilla mit solchen Maßnahmen verhindern, die ich keinesfalls gutheiße.

    Das Dumme ist, das hier mehrere Ursachen vorkommen können. Eine alleine kann hier nicht immer helfen.

    Im Forum gibt es eine Menge darüber zu lesen. Schau mal nach Thunderbird leer, keine Mails usw.

    Mir selbst hat bei einem ähnlichen Problem - ich sage extra ähnlich und nicht gleich - geholfen, im alten Profil die Datei compatiblity.ini zu löschen und zwar nach dem Schließen von Thunderbird.

    Außerdem kann ein falsches "Sprachpaket" die Ursache sein, welche besonders bei Linux gern vorkommt. Dazu muss Thunderbird bei gedrückter Umschalt-Taste gestartet werden (safe-mode) und das Sprachpaket entfernt werden. Sprachpaket beziehen sich auf Sprache des Gui und sind keine Rechtschreibpakete. Normalerweise ist ein Sprachpaket nicht notwendig, wenn man die deutsche Thunderbird-Version heruntergeladen hat.


    Hier ein paar Links:

    Achtung Nach Update auf Version 68.* öffnet Thunderbird ein fast leeres Fenster 18. Januar 2020


    Nach Update sind sämtliche Kontoeinstellungen verschwunden - keine Panik!


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Moin mrb,


    Deine Worte lesen sich gar nicht so gut ;).

    Vielen Dank für Deinen Tipp mit "compatiblity.ini", die anderen Hilfestellungen aus dem Forum habe ich bereits getestet.

    Scheinbar bin nur ich von diesem Phänomen betroffen, aber Versuch macht klug.

    ...man liest sich...

    /michael/

  • Hallo mrb,


    weder Löschung noch Manipulation der "compatiblity.ini" bringt Abhilfe - schade.

    ...man liest sich...

    /michael/

  • OK. Gehen wir nochmal durch:


    1) Starten bei gedrückter Umschalt-Taste. Gemacht?

    2) Löschen der Datei die Datei "global-messages-db.sqlite" bei beendetem Thunderbird

    3) Einbinden des alten Profils mit Profil-Manager - Profile verwalten, erstellen und löschen

    ohne jedoch ein neues Profil zu erzeugen?

    4)Du bist sicher die richtige Thunderbird Version heruntergeladen zu haben also 64-bit oder 32-bit, je nach vorhandener Version?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    nach manueller Installation von 68.6.0 unter Ubuntu 18.04.4 hier die Ergebnisse:


    Zu 1): Alle Ordnerverzeichnisse sind aufgeblättert. Beim Aufruf eines IMAP-Kontos erfolgt manchmal ein Crash (für mich nicht reproduzierbar).

    Zu 2): Nach Neustart wieder das alte Problem. Allerdings lassen sich die Add-ons aus meinem Profil nicht mehr mit dem Debugger erreichen.

    Zu 3): Ob mit Profil-Manager oder händisch auswählen bringt kein neues Ergebnis. (Ein neues Profil erzeugen, welches meinem alten gleicht, habe ich mir erspart).

    Zu 4): Die 68.06.0 kommt von hier.


    Auch das Löschen von "addonStartup.json.lz4" (wurde in einem Thread zu diesem Thema empfohlen) hilft nicht.


    Nochmals vielen Dank für Deine Unterstützung, möge Ubuntu 20.04 Licht ins Dunkel bringen:).


    Nachtrag von 12:45 Uhr:

    Die ganze Prozedur habe ich auch mit Thunderbird-Portable durchgespielt. Es zeigt sich ab 68.6.0 das gleiche Fehlerbild.

    Nu is genuch!

    ...man liest sich...

    /michael/

    Edited once, last by michritoba: Redaktionelles ().

  • Nachtrag vom 16.04.2020, 11:20 Uhr:

    Auch mit der manuellen Installation von TB 68.7.0 kommt es zu Abstürzen (gefühlt sind es weniger).

    ...man liest sich...

    /michael/

    • Best Answer

    Schlussbemerkung am 26.04.2020:

    Auf einem separaten Rechner mit Ubuntu 18.04 habe ich TB 68.7.0 über das PPA installiert. Nach etwa zwei Stunden war ich wieder auf dem aktuellen Stand. Danach bin ich mit diesem Profil auf meine anderen Rechner umgezogen. Keine Probleme und keinen Ärger mehr. Tief in meinem Inneren bleibt natürlich die Frage, wie es zu den vorherigen Problemen kommen konnte.


    Bleibt gesund!

    ...man liest sich...

    /michael/

    Edited once, last by michritoba: Link eingefügt. ().