Externe Inhalte anzeigen erlaubt - wie rückgängig machen?

  • Thunderbird-Version: 24


    Schönen guten Morgen,


    wenn man bei einer HTML Mail "Externe Inhalte anzeigen" erlaubt hat, so merkt sich TB diese Einstellung für diese eine Mail im Postfach und bei jedem weiteren Öffnen werden die Bilder sofort angezeigt/nachgeladen.


    - Ist es möglich den TB so zu konfigurieren, dass das Einblenden externer Inhalte auch bei der gleichen Mail jedes mal explizit erlaubt werden muss?


    - Lädt TB beim weiteren Öffnen der Mail die Inhalte erneut herunter oder liegen diese nach der ersten Öffnung gecacht vor? Stichwort: Tracking!


    Würde mich über Hilfe sehr freuen. :)

  • Guten Morgen,


    dass müsste hiermit mailnews.message_display.disable_remote_image gehen.


    Ansonsten verstehe ich die Frage nicht, denn wenn du es dauerhaft erlaubst, dann wird das im Kontaktfeld der E-Mailadresse angehakt (das musst du dann ja bewusst machen) und dort kann man den Haken wieder entfernen.
    Wenn du es nicht dauerhaft erlaubst, wird es jedes Mal wieder gefragt.


    Gecached? Hmm, weiß ich nicht, aber probiere es, erlaube das einmalige Nachladen, lösche in den Einstellungen>Erweitert den Cache und teste und dann wäre es schön, wenn du deine Erfahrung mit uns teilst :mrgreen:

  • Hallo rum und graba,


    danke für die Antworten. Leider aber ging es an der Frage vorbei. :-/ Mit besagtem Setting schalte ich die Option ja nur global komplett an oder aus, was aber nicht gewünscht war.


    Es ging auch nie um das dauerhafte erlauben für einen Absender, sondern nur um das erlauben bei einer bestimmten Mail. Sind ja 2 paar Schuhe, dazu muss man auch niemanden ins Adressbuch aufnehmen.


    Beispiel Mail mit HTML Bildinhalten:


    Erlaube ich nun über "Externe Inhalte anzeigen" das Laden der Bilder, so merkt sich Thunderbird 24 dies für diese besagte Mail auch für die Zukunft. Wenn vom gleichen Absender eine neue Mail kommt, müsste ich es dort natürlich neu bestätigen.


    Nun mag es aber Fälle geben, wo man genau dies nicht möchte. Ich erhalte von einem Händler eine Mail mit personalisiertem Angebot und eingebettetem Bildern für dieses Angebot. Diese möchte ich mir nun einmalig anzeigen lassen, mit dem Wissen, dass er mich darüber trackt. Einmal gesehen, würde mir für die Zukunft die Mail mit gesperrtem Bildinhalt reichen.


    Leider aber scheint genau das im Thunderbird nicht zu gehen, somit kann mich bei den einmal erlaubten Mails der Händler nun jedes mal tracken, wenn ich wieder in das Angebot schauen sollte, da die eingebetteten Bilder nicht mehr geblockt werden.


    So wie es scheint, lässt sich dies (leider) auch nicht ändern. Vielleicht in Zukunft mal?


    Viele Grüße


    43vc5vft

  • Hallo 43vc5vft,


    ich habe jetzt mal ein wenig rumprobiert mit Cache-Löschen, Index-reparieren usw. und leider keinen Erfolg, die Mail bleibt mit Bildinhalt.
    Würgaround: kopiere die Mail vor dem Nachladen z.B. in den lokalen Posteingang.
    Die Originalmail bleibt dann Bilderfrei... :rolleyes:


    Oder schalte TB mittels des Lämpchens unten links offline

  • Danke für den Würgarround, Name ist dabei ja leider wirklich Programm. :lol: :confused:


    Kannst du das als Feature-request irgendwie aufnehmen/weiterleiten? Würde ja reichen wenn man die Option per about:config dauerhaft erzwingen könnte, auch bei schon einmal erlaubten Mails. Gerade bei mehreren Angeboten ist es für so manchen Händler durchaus interessant, wie oft sein Angebot betrachtet wird. ;-)

  • Guten Abend,


    - wenn du oben auf das TB-Logo klickst kannst du dich über Weiterentwicklung zu den entsprechenden Sites für Wünsche durchhangeln.
    - wenn du oben auf den Button zu Mozilla Addons klickst, findest du auf der Site ganz unten Links zu Entwicklern

  • Wenn man den Button "Externe Inhalte anzeigen" betätigt, merkt Thunderbird sich das, indem eine .msf-Datei angelegt wird.
    Zu einer Nachricht z.B. im Email-(Unter)-Ordner "Online-Laden-24" wird dann eine Datei "Online-Laden-24.msf" erstellt, die
    sich unterhalb deines lokalen Ordners, wie unter "Konto-Einstellungen/Nachrichtenspeicher/Lokaler Ordner" einzusehen, befindet.


    Diese Datei kannst du einfach löschen, somit vergisst Thunderbird (24.3.0), dass er die enthaltenen Bilder in Zukunft ungefragt wieder laden darf.


    Probiere das aber bitte selbst erst einmal vorsichtig aus
    - vor dem Start von Thunder eine Backup-Kopie deiner Lokalen Ordner-Struktur machen
    (bei Windows i. d. R. %userprofile%\AppData\Roaming\Thunderbird\Profiles\1rgendwas.default)
    - Thunder starten
    - zu einer Email den besagten Button klicken
    - Thunder schließen
    - msf-Datei löschen
    - Thunder starten
    - nachschauen, ob der Button wieder da ist

    Wäre interessant zu wissen, ob in der msf-Datei noch andere Informationen gespeichert werden, vielleicht gibt es dazu noch Erfahrungen und Beiträge hier. Bei mir sind diese Dateien jedenfalls leer (0 KB).


    Gruß

  • Hallo nicksweiss,


    willkommen im Thunderbird-Forum.


    Schön, dass Du gleich mit Deinem ersten Beitrag Hilfestellung gibst.


    Ich fürchte aber fast, da der letzte Beitrag in diesem Faden vom 08.10.2013 stammt, und worauf der Themenersteller 43vc5vft nicht mehr geantwortet hat, dass für diesen bereits sein Problem gelöst ist.


    Trotzdem vielen Dank dafür.


    Gruß
    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • Zitat von "Feuerdrache"

    Hallo nicksweiss,


    Ich fürchte aber fast, da der letzte Beitrag in diesem Faden vom 08.10.2013 stammt, und worauf der Themenersteller 43vc5vft nicht mehr geantwortet hat, dass für diesen bereits sein Problem gelöst ist.


    Na ja, ich hoffe mal, dass von ca. 80 Mio Deutschen noch irgendeiner dasselbe Problem hat.
    Oder sogar 43vc5vft hat ob seines Problems seit dem 08.10. schlaflose Nächte, denen ich jetzt ein Ende bereitet habe, das wäre natürlich der Jackpot.


    Traurig ist allerdings, das die Entwickler von Thunder nicht die Zeit gefunden haben, dieses weitere kleine Datenschutzproblemchen aus der Welt zu schaffen. Eine Option einzubauen, die das abspeichern dieser Option verhindert sollte den Programmierer imho 1 Stunde Arbeit kosten.
    Gruß

  • Hallo,

    Zitat von "nickswiss"


    Traurig ist allerdings, das die Entwickler von Thunder nicht die Zeit gefunden haben, dieses weitere kleine Datenschutzproblemchen aus der Welt zu schaffen. Eine Option einzubauen, die das abspeichern dieser Option verhindert sollte den Programmierer imho 1 Stunde Arbeit kosten.


    traurig ist meiner Meinung nach die extrem "bescheidene" personelle Ausstattung für die Entwicklung von Thunderbird, so dass nur das Wichtigste in Angriff genommen werden kann.

  • Hallo nickswiss


    und willkommen im Thunderbird-Forum!


    Zunächst einmal: ja, du hast damit Recht, dass in der *.msf der Status gespeichert wird und es reicht auch nicht aus, mittels Eigenschaften>Reparieren die Indexdatei *.msf neu ordnen zu lassen, man muss sie im Profil löschen.
    Alternative: man verschiebt die Mail raus aus dem Posteingang und dann wieder rein, dann erhält sie nämlich einen neuen Eintrag in der Indexdatei. :stop: Gerade noch mal probiert: das funktioniert nicht!


    Aber damit

    Zitat von "nickswiss"

    Wenn man den Button "Externe Inhalte anzeigen" betätigt, merkt Thunderbird sich das, indem eine .msf-Datei angelegt wird.
    Zu einer Nachricht z.B. im Email-(Unter)-Ordner "Online-Laden-24" wird dann eine Datei "Online-Laden-24.msf" erstellt

    liegst du nicht richtig. Thunderbird erstellt zu jedem (!) Mailordner eine solche Indexdatei mit dem Ordnernamen und der Endung *.msf.
    Die kann man bei Falschanzeigen meist mit Rechtsklick>Eigenschaften>Index wiederherstellen (bzw. Reparieren) auf den betroffenen Ordner wieder neu sortieren lassen.
    Löscht man sie, wird sie anhand der Maildatei neu erstellt.
    FAQ:Korrupte Indexdateien

  • Hallo,


    gibt es inzwischen eine Lösung zu dem o.g. Problem?


    Inzwischen sind wir bei TB-Version 38.2.0, die Buttons sind etwas anders beschriftet, aber das Grundproblem bleibt...:


    Wenn ich in TB eine E-Mail öffne, über die externe Inhalte nachgeladen werden, bekomme ich eine Meldung:


    "Um Ihre Privatsphäre zu schützen, hat TB das Nachladen externer Inhalte blockiert."


    Das soll auch so sein, da ich unter Einstellungen > Datenschutz das Erlaubnishäkchen nicht gesetzt habe. Wenn ich nun bei einer solchen Nachricht in der o.g. Meldung unter Einstellungen auswähle, daß externe Inhalte in dieser Nachricht angezeigt werden sollen, dann funktioniert auch das.


    TB scheint sich dies aber immer noch zu merken, da beim Öffnen einer einmal so behandelten Nachricht dann für diese Nachricht nie mehr gefragt wird, ob externe Inhalte nachgeladen werden sollen oder nicht.


    Wenn ich das aber bei einer Nachricht gar nicht möchte und versehentlich diesen Punkt bestätigt habe, wie kann ich das dann wieder rückgängig machen?


    Wie kann ich TB die erteilte Erlaubnis zum Nachladen externer Inhalte einer Nachricht wieder entziehen? Wie kann ich TB dazu überreden, mir wieder den Auswahldialog für diese Nachricht anzuzeigen?


    André

  • Hallo,


    ich habe jetzt doch eine Lösung finden können:


    Wenn die Mail mit den nachgeladenen externen Inhalten geöffnet ist, dann wähle ich mit Strg-Shift-J die Fehlerkonsole.


    Dort in die Code-Zeile muss man nur den folgenden, total intuitiven, trivialen und selbsterklärenden Inhalt confused.png eintragen:


    top.opener.setMsgHdrPropertyAndReload("remoteContentPolicy", 0);


    und dann auf 'evaluieren' klicken. Und schwupps - sind die nachgeladenen Bilder wieder weg und die ursprüngliclhe Abfrage ist wie gewünscht wieder da ^^



    André

  • Hallöchen zusammen,


    und wieder lobe ich mir den SeaMonkey! Hier kann ich nämlich auswählen, ob die externen Inhalte nur einmal angezeigt werden. Gab es früher diese Funktion bei Thunderbird nicht auch? Ich glaube mich an sowas erinnern zu können!

  • Hallo André,

    ich habe jetzt doch eine Lösung finden können:

    Die Lösung lässt sich auch in diesem Forum finden.
    Sie wurde schon vor ungefähr einem Jahr hier angegeben ;)


    Gruß


    Mapenzi