Lightning funktioniert nach rebooten nicht mehr

  • Ich habe genau das gleiche Problem, festgestellt bei TB 68.3.1 und Lightning 68.3.1.1 unter Windows 10 Prof..


    Folgendes schuf Abhilfe:

    1. Thunderbird schließen,
    2. Im Thunderbid-Profilordner den Ordner startupCache löschen.

    Danach waren alle Kalender wieder da - sowohl nach einem Neustart des Rechners als auch nach Beenden und Neustarten von Thunderbird.


    Damit ich das aber nicht jedes Mal tun muss, habe ich die Dateien in diesem Ordner gelöscht und den Ordner schreibgeschützt (Ordner-Eigenschaften - Tab "Sicherheit" - Button "Bearbeiten..." - "Authentifizierte Benutzer" markieren - in der Spalte "Verweigern" das Kästchen bei "Schreiben" anhaken - Button "OK")

  • Damit ich das aber nicht jedes Mal tun muss, habe ich die Dateien in diesem Ordner gelöscht und den Ordner schreibgeschützt (Ordner-Eigenschaften - Tab "Sicherheit" - Button "Bearbeiten..." - "Authentifizierte Benutzer" markieren - in der Spalte "Verweigern" das Kästchen bei "Schreiben" anhaken - Button "OK")

    Auch wenn es vordergründig als Workaround funktionieren mag, halte ich dies für keine gute Idee. Thunderbird mag es nicht, wenn er bestimmte Dateien nicht schreiben bzw. darauf zugreifen kann. Schau doch mal, ob Dein Problem vielleicht auch hiervon kommt:

    Nach Übertragen des Profils von Win 7 auf Win 10 startet Thunderbird 68 mit leerem Fenster

  • Hallo Leute,


    ich habe das gleiche Problem. Zunächst an meinem heimischen Win 10 PC. Dort ließ sich das Problem mit der Anleitung von Mozilla („Calendar updates issues with Thunderbird“) lösen. Also zurücksetzen eines Eintrags in der erweiterten Konfig und anschließende Neuinstallation von Lightning.


    Beim meinem Win7 Arbeitsplatz-PC funktioniert das Ganze nicht. Nach einer Neuinstallation von Lightning ist der Kalender wieder da, aber nach einem Reboot ist er wieder weg. Dafür klappt der Trick von Mr. Magpie. Besten Dank dafür.


    Nun bin ich gerade dabei von Win7 auf einen Win10 PC umzusteigen. Dazu wurde Thunderbird neu installiert und wie bei Mozilla beschrieben das Profil vom alten PC übertragen. Die Mails sind alle da, nur das Problem mit dem Kalender besteht weiterhin. Man könnte denken, im Profil ist irgendwo der Wurm drin.


    Um das zu testen habe ich TB wieder deinstalliert und im User-Verzeichnis unter „AppData\Local“ bzw. „AppData\Roaming“ das Verzeichnis „Thunderbird“ gelöscht. Neustart. TB 68.4.1 neu installiert. Im vorhandenen Kalender „Privat“ einen Eintrag für die nächste Woche angelegt. Reboot PC. Und schon ist der Kalender wieder weg. Ordner „startupCache“ gelöscht. Kalender wieder da.


    Also das Problem tritt auch bei einem aktuellen und frisch installieren TB auf. Weiß jemand, ob bei Mozilla der Bug bekannt ist?


    Gruß Paule



    Zur Vollständigkeit für den letzten beschrieben Fall:

    • Thunderbird-Version: 68.4.1 (32-bit)
    • Lightning-Version: wie TB-Version
    • Betriebssystem + Version: Windows 10 (64Bit), Version 1909
    • Google-Kalender mit "Provider for Google-Calendar" (ja/nein): nein
    • Google- oder sonstiger Kalender mit WebDAV / CalDAV (ja/nein/was genau): nein
    • Eingesetzte Antivirensoftware: intern
    • Firewall (Betriebssystem-intern/Externe Software): intern
  • Mit der neuen TB-Version 68.4.2 und Lightning 68.4.2 besteht das Problem unter Windowes 10 Prof. weiterhin - alternativ zu meinem schon genannten Workaround kann man im Profilordner eine schreibgeschützte Datei ".startup-incomplete" erzeugen

  • ...und auch bei Version 68.5.0 (64-bit)

    Da dies anscheinend ein spezifisches Problem von Dir ist wird es sich höchstwahrscheinlich auch nicht durch ein Update ändern. Somit kannst Du darauf verzichten nach jedem Update zu schreiben, dass es nicht geht. Beschäftige Dich lieber intensiver mit der Fehlersuche.

    Am besten erst einmal mit einem sauberen Profil probieren. Falls das geht, nach und nach die Daten des alten Profils übernehmen und die Ursache suchen.

  • Da dies anscheinend ein spezifisches Problem von Dir ist

    ...

    Am besten erst einmal mit einem sauberen Profil probieren.

    Also ich habe das Problem auch nach wie vor. Im Post #25 hatte ich beschrieben, dass der Fehler auch bei einem frisch installierten Thunderbird auftritt. Allerdings kann ich nicht bei jedem Update von Thunderbird jedesmal mein Profil plattmachen um zu testen, ob es ohne Löschen des startupCache funktioniert.

  • Ich hatte das Problem, welches hier beschrieben wird auch. Bei mir hat der Kalender auch nur einmalig funktioniert und war nach einem Neustart des Thunderbird wieder "kaputt". Die beiden Workarounds haben nicht zuverlässig funktioniert (ggf. war ich zu doof oder seperate Fehlerquelle)


    Meine Lösung war jetzt einfach alle Dateien die beim neu hinzufügen von Lightning? geändert werden aus dem Profilordner zu schmeißen. Sicher keine elegante Lösung. Funktioniert aber. Inwiefern das ggf. andere Einstellungen oder Addons beeinträchtigt kann ich nicht sagen, da ich nur dieses eine Addon nutze.


    Entfernt hatte ich folgende Dateien

    (ja die .txt Dateien sind vermutlich nicht die Fehlerquelle aber wie gesagt habe ich einfach geschaut was beim Startup verändert wird und das aus dem Ordner genommen)

    addonStartup.json.lz4

    AlternateServices.txt

    compatibility.ini

    extensions.json

    folderTree.json

    prefs.js

    search.json.mozlz4

    SecurityPreloadState.txt

    session.json

    sessionCheckpoints.json

    SiteSecurityServiceState.txt

    Telemetry.ShutdownTime.txt

    virtualFolders.dat

    xulstore.json

    Nach dem folgenden Neustart wurde angezeigt, dass ein Addon (Lightning) aus Drittquelle hinzugefügt worden ist, dieses aber nicht richtig installiert ist. Installation zugelassen und neugestartet, fertig.


    Seit dem kann ich Thunderbird beliebig oft neustarten und der Kalender funktioniert nach Monaten des rumgezicke endlich wieder wie gewohnt.

  • Ich hänge mich hier auch mal rein, da ich gerade ebenso das Problem plötzlich hatte. Dabei war Thunderbird sogar ganz normal geöffnet und das Notebook kam nur aus dem Ruhezustand zurück. Auch ein Neustart von Thunderbird hat das Problem nicht behoben. Zufällig konnte ich gerade das Update von 68.6 auf 68.7 durchführen und danach waren die Kalender wieder bunt. Ich schätze aber mal, dass es nichts mit dem Update an sich zu tun hatte, sondern dass durch das Update einfach nur der StartupCache gelöscht wurde.

  • Noch eine kurze Rückmeldung von mir zum Thema.

    Da ich mich nun geraume Zeit nicht mehr mit dem Problem befassen konnte, ist es ohne weiteres Zutun seit zwei, drei Wochen (nach einem Update?) verschwunden. Der Kalender ist und bleibt jetzt bunt.


    Die derzeitige Version ist 68.7.0 (32-Bit), Windows 10 pro 1907.

  • Zufällig konnte ich gerade das Update von 68.6 auf 68.7 durchführen und danach waren die Kalender wieder bunt. Ich schätze aber mal, dass es nichts mit dem Update an sich zu tun hatte, sondern dass durch das Update einfach nur der StartupCache gelöscht wurde.

    Ich habe richtig geschätzt: Das Problem trat auch nach dem Update auf 68.7 wieder auf. Aber dank dem Trick von Mr. Magpie konnte ich das Problem wieder beheben (inkl. Schreibschutz, da kann ich also auch mal auf negative Nebeneffekte achten). Bei mir tritt das Problem übrigens in folgender Konstellation auf:


    - Win 10 aus Ruhezustand aufwecken

    - Thunderbird läuft noch und auch der Kalender funktioniert normal.

    - Thunderbird schließen (TB wird nach einiger Laufzeit recht langsam, weshalb ich es jetzt regelmäßig neustarten wollte).

    - Thunderbird starten

    => Kalender kaputt (alles grau und in der Leiste fehlen die Kalender, also genauso wie in diesem Thread beschrieben)