Terminerinnerungen lassen sich nicht schließen

    Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 68.2.1 (64bit)
    • Lightning-Version: 68.2.1
    • Betriebssystem + Version: Ubuntu (64) 18.04.3
    • Google-Kalender mit "Provider for Google-Calendar" (ja/nein): ja aber momentan deaktiviert
    • Google- oder sonstiger Kalender mit WebDAV / CalDAV (ja/nein/was genau): ja, CalDAV mit Synology Diskstation im lokalen Netz
    • Eingesetzte Antivirensoftware: keine
    • Firewall (Betriebssystem-intern/Externe Software): Hardware für Internetzugang im lokalen Netz keine


    Nachdem die Frage vor knapp zwei Jahren bereits schon einmal von HOUDON gestellt und die Diskussion leider etwas unbeherrscht beendet wurde, muss ich die Thematik leider wieder aufgreifen. Es ist immer noch keine Lösung vorhanden.


    Vielleicht noch einmal zur Problematik : ich arbeite auf meinem lokalen PC, auf einem Tablett und zwei Handys (alle unterschiedliche Versionen von Android)

    mit Kalendern und Synchronisation. Dabei kann ich auf den mobilen Endgeräten mittels der App "iCal Import/Export CalDav Pro" (übrigens eine hervorragende APP, die für knapp 5€ auch funktioniert !!!) alle Kalendereinträge vom NAS synchronisieren und bearbeiten. Auf dem lokalen PC kann ich in Thunderbird Erinnerungen an Termine nicht bearbeiten. Das Fenster der Erinnerungen geht auf und die Buttons zum "Schließen" und "Alle Schließen" sind vorhanden - aber sie reagieren nicht.

    Deshalb nun noch einmal die Frage : wie kann man das Ändern ?


    Zweite Frage: warum sind die Termine doppelt vorhanden in der Erinnerung ? Im Kalender sind die Termine definitiv nur einmal vorhanden.


    Ich bin seit Monaten auf der Suche nach einer Lösung. Leider konnte ich bisher nichts finden. Ich habe mich heute gerade deshalb mal in diesem Forum angemeldet und hoffe es hilft. ;)


    Für vernünftige Antworten möchte ich mich schon einmal im Voraus bedanken. Bemerkungen, die nicht zielführend oder hilfreich sind spende ich gern an die Glückskiste.


    Viele Grüße

    Bernd

    Edited once, last by Rosinante ().

    • Best Answer

    Ein Tip für die Richtung der Suche wäre schon ganz schön.

    Alle Kalender abbestellen, Thunderbird beenden.

    Dann im Unterordner calendar-data die Dateien "cache.sqlite" & "deleted.sqlite" löschen.
    Thunderbird wieder starten, Kalender wieder abonnieren und versuchen zu löschen.


    Gruß
    EDV-Oldi

  • graba

    Approved the thread.
    • Thunderbird-Version: 68.2.2 (64-Bit)
    • Lightning-Version: 68.2.2
    • Betriebssystem + Version: Linux Mint 19 Cinnamon (64-bit)
    • Google-Kalender mit "Provider for Google-Calendar" (ja/nein): nein
    • Google- oder sonstiger Kalender mit WebDAV / CalDAV (ja/nein/was genau): nein
    • Eingesetzte Antivirensoftware: ClamTk 5.25
    • Firewall (Betriebssystem-intern/Externe Software): nein

    Ich habe dasselbe Problem mit *einer* Erinnerung zu einem Termin von gestern.


    Die Erinnerung läßt sich nur über die Menüleiste oder über <Rechtsklick - Schließen> vom Bildschirm entfernen, taucht aber mit jeder weiteren Erinnerung auf.


    Änderung/Später erinnern/Termin löschen ist nicht möglich, die Buttons sind wirkungslos.


    Auch den Termin selbst vermag ich nicht zu löschen (Kontext-Menü/Taste Löschen wirkungslos).


    Was kann ich tun?


    Tante Edit: Nun habe ich es geschafft, die eine Erinnerung zu entfernen (ich hab den Termin gelöscht, seitdem schien Ruhe zu sein) und bemerke nun einen anderen Termin, der sich nicht schließen oder später erinnern läßt, also mit dem selben Verhalten (Menüleiste oder <Rechtsklick - Schließen); er kommt nun auch immer wieder.

    Außerdem gibt es eine Aufgabe, die ich zwar editieren kann, soviel ich möchte (Titel, Endzeitpunkt etc.), die Änderungen werden aber nicht übernommen.


    Tante Edit2: Leider hat auch das update auf TB 68.4.1 nix gebracht.

    Ich schreibe jetzt keine 221 Beiträge, aber wenn ich groß bin, lade ich meinen Avatar hoch.

    Edited 3 times, last by mungo: Ergänzung Ergänzung ().

    Hallo mungo,

    vielen Dank für den Hinweis, dass es bei Dir auch nicht funktioniert. Das ist leider nicht wirklich hilfreich :-)

    Offensichtlich scheint das niemanden zu stören, denn sonst wären möglicherweise mehr Anfragen zu dieser Problematik. Natürlich ist das Löschen eines Termins auch eine Option zum Entfernen der Erinnerung. Scheint mir aber nicht der Weisheit letzter Schluss zu sein. Ich warte also weiter; vielleicht findet noch jemand eine Lösung zu dem Thema. Übrigens habe ich auch schon bei Synology gestöbert und - welch Wunder - nichts gefunden. Vielleicht liegt es an den Zugriffsrechten auf der Kalenderdatei ? Ich habe da mal kurz geschnüffelt. Leider nichts gefunden...


    Liebe Grüße

    Rosinante:thumbsup:

  • vielen Dank für den Hinweis, dass es bei Dir auch nicht funktioniert. Das ist leider nicht wirklich hilfreich :-)

    Na, vielleicht bist Du dann nicht mehr so alleine.^^


    Vielleicht liegt es an den Zugriffsrechten auf der Kalenderdatei ? Ich habe da mal kurz geschnüffelt. Leider nichts gefunden...

    Glaube ich eher nicht - bei mir sind sie [user]/[user], und es sind ja auch nur einzelne von einer größeren Menge beim selben Benutzer.



    Seit ich TbSync und Provider für CalDAV & CardDAV zum synchronisieren benutze, habe ich keine Probleme mehr.

    Das kann möglicherweise eine zukünftige Lösung sein.

    Allerdings hilft es leider nicht beim Erkennen des Fehlers, der uns aktuell absurde Erinnerungen (an vergangene Termine) beschert, die weder zu bearbeiten noch zu löschen sind.


    Es ist möglich, daß

    • ein bug in TB existiert
    • wir denselben Fehler gemacht haben
    • unsere Distros denselben Fehler mitbringen

    Ein Tip für die Richtung der Suche wäre schon ganz schön.


    Tante Edit: Ich hab nun mal die global-messages-db.sqlite gelöscht. Mal schauen, ob und was es bringt.

    Ich schreibe jetzt keine 221 Beiträge, aber wenn ich groß bin, lade ich meinen Avatar hoch.

    • Best Answer

    Ein Tip für die Richtung der Suche wäre schon ganz schön.

    Alle Kalender abbestellen, Thunderbird beenden.

    Dann im Unterordner calendar-data die Dateien "cache.sqlite" & "deleted.sqlite" löschen.
    Thunderbird wieder starten, Kalender wieder abonnieren und versuchen zu löschen.


    Gruß
    EDV-Oldi

    • New

    Hallo EDV-Oldi,

    Ich bin auch schon im fortgeschrittenen Alter, aber man lernt ja bekanntlich immer dazu. :-)

    Dein Hinweis mit dem Löschen von den beiden Dateien scheint zumindest eine Änderung zu bewirken. Ich muss das noch ein wenig überprüfen mit "normalen" Terminen. Die Änderung bewirkt zumindest, dass ich nun sehe wer diesen Termin erstellt hat. Das mit dem Ändern bzw. Bearbeiten muss ich noch prüfen...

    VG Rosinante

    :)

    • New

    Hallo Mungo,

    die Datei global-messages-db.sqlite zu Löschen bringt leider gar nichts. Natürlich wird der Suchindex neu aufgebaut, aber mit dem Bearbeiten von den Terminen hat das nix zu tun und bewirkt folglich auch nichts.

    Natürlich ist es möglich, dass wir beide den selben Fehler machen. Deshalb frage ich ja mit meinen Thema in die Runde. Der Hinweis von EDV-Oldi scheint da aus meiner Sicht in die richtige Richtung zu gehen. Ich bin gerade noch am Probieren und Überprüfen...

    Melde mich bestimmt noch einmal zum Thema

    VG Rosinante

  • Bei mir ist mit dem Löschen/Erneuern der global-messages-db.sqlite alles erledigt, soweit ich sehe.


    Bisher konnte ich den einen Termin nicht löschen (gelang nun) und der andere taucht nicht mehr auf.

    Alles gut.

    Ich schreibe jetzt keine 221 Beiträge, aber wenn ich groß bin, lade ich meinen Avatar hoch.

  • Nun taucht der eine, böse Termin doch wieder auf, und zwar in "Termine und Aufgaben" (war ausgeblendet).


    Dann hab ich edvoldis Tip beherzigt:

    Alle Kalender abbestellen, Thunderbird beenden.

    Dann im Unterordner calendar-data die Dateien "cache.sqlite" & "deleted.sqlite" löschen.

    Leider ohne Wirkung, soweit ich sehen kann.

    Der Termin läßt sich nach wie vor weder ändern noch löschen und nervt bloß.:wall:


    Hat vielleicht noch jemand eine Idee?

    Ich schreibe jetzt keine 221 Beiträge, aber wenn ich groß bin, lade ich meinen Avatar hoch.

  • Ich habe nur lokale Kalender.

    Ich schreibe jetzt keine 221 Beiträge, aber wenn ich groß bin, lade ich meinen Avatar hoch.

  • Hallo mungo,

    Starte Thunderbird bitte einmal im Abgesicherter Modus.
    Das dient nur zum testen, und ist keine Lösung des Problems!

    Über: Hilfe>Mit deaktivierten Add-ons neu starten ...


    Oder starte Thunderbird im abgesicherten Modus, indem du gleichzeitig auf die Umschalttaste drückst, während du TB startest.

    Dann wieder normal.
    Wenn der Termin immer noch da ist versuche ihn einmal in einem anderen Kalender zu speichern.


    Gruß
    EDV-Oldi

  • Starte Thunderbird bitte einmal im Abgesicherter Modus.

    [...]

    Dann wieder normal.
    Wenn der Termin immer noch da ist versuche ihn einmal in einem anderen Kalender zu speichern

    Im Abgesicherten Modus taucht das Add-on Lightning natürlich nicht auf.


    Beim Neustart war der Böse Termin immer noch da.

    Ich habe ihn in einen anderen Kalender kopiert, wo ich die Kopie bearbeiten und löschen konnte.


    Der Böse Termin ist allerdings immer noch da und läßt sich weder bearbeiten noch löschen.

    Ich schreibe jetzt keine 221 Beiträge, aber wenn ich groß bin, lade ich meinen Avatar hoch.

  • Ich habe ihn in einen anderen Kalender kopiert, wo ich die Kopie bearbeiten und löschen konnte.

    Nicht kopieren, sondern in einem anderen Kalender verschieben.
    Termin öffnen und ihn dann unter einem anderen Kalender speichern.


    Gruß
    EDV-Oldi

  • Termin öffnen und ihn dann unter einem anderen Kalender speichern.

    Geht nicht: Ich kann zwar Änderungen im Termin vornehmen, sie werden aber nicht gespeichert.

    Ich schreibe jetzt keine 221 Beiträge, aber wenn ich groß bin, lade ich meinen Avatar hoch.

  • Ja dann ist wohl der Termin defekt.
    Du kannst diesen Kalender in eine ics Datei exportieren und versuchen den defekten Termin mit einem Editor Deiner Wahl zu finden und zu löschen.

    Dann den gesamten Kalender löschen und neu anlegen und die veränderte ics Datei wieder importieren.


    Gruß
    EDV-Oldi

  • That did the trick: Termin rausgefummelt und gelöscht, ohne ihn reimportiert - alles gut.

    Danke.


    Die Termine hängen in der *.ics alle direkt zusammen.

    BEGIN/END VTODO markieren eine Aufgabe.


    Hier ist der Böse Termin:

    Hier scheint mir

    X-LIC-ERROR;X-LIC-ERRORTYPE=PARAMETER-VALUE-PARSE-ERROR:Got a VALUE parameter with an illegal type for property: VALUE=DURATION

    entscheidend gewesen zu sein.

    Ich schreibe jetzt keine 221 Beiträge, aber wenn ich groß bin, lade ich meinen Avatar hoch.