Quicktext funktioniert nicht mehr richtig

If you suddenly cannot receive any more emails

Please read the notes on the latest two most common causes of problems!

Please click here!

This red box disappears when you click on the X in the top right corner.

  • Wie kommt er an die prefs.js Dateien? Wenn er die hat, kann er die zwei Dateien erstmal (alphabetisch) sortieren:


    https://textmechanic.com/text-…xt-tools/sort-text-lines/


    und dann die zwei sortierten Dateien durch einen Diff jagen:


    https://www.diffchecker.com/


    John

  • Hallo John,


    aufgrund der Anregung von EDV-Oldi habe ich die beiden prefs.js Dateien verglichen. Leider gibt es da so viele Unterschiede und ihc wieß nicht, welche interessant sein könnten.

    Ich habe dir die Dateien deshalb in einer Konversation zugesandt.

    Im neuen Profil sind alle Addons aus dem alten Profil installiert, die aktuell von Thunderbird 78 akzeptiert werden, im alten Profil waren noch einige Addons deaktiviert (Mail Redirect, ImportExportToolsNG, Addressbooks Synchronizer).

    Alle Emails habe ich mit kopieren des Ordners "Mail" vom alten ins neue Profil übernommen.


    Viele Grüße

    Andreas

  • Bei mir gab es das gleiche Problem - habe jetzt das Enigmail Add-on deaktiviert, und jetzt geht wieder alles. Also: Einstellungen für Quicktext unter Extras -> Add-on-Einstellungen, und auch der Knopf im "Verfassen"-Fenster ist wieder vorhanden.


    Grüße,

    Steffan

  • Ich habe bis jetzt nichts Brauchbares gefunden, warum das mit Enigmail passiert. Wenn Ihr Enigmail wieder aktiviert, ist das dann reproduzierbar? Erscheint irgendwas in der Fehlerkonsole, das erklären könnte, warum Quicktext aussteigt?

  • Hallo,

    ich habe gerade zum testen noch einmal Enigmail 2.2.3 installiert und nach einem Neustart funktionierte Quicktext nicht mehr.
    Nach der deinstallieren von Enigmail und einem Neustart war alles wieder okay.

    Hier eine Auszug aus derFehlerkonsole:

    Gruß
    EDV-Oldi

  • Moin zusammen,


    habe eben in einem bestehenden TB 78.2.2 (jetzt auch nach Update auf 78.3.1) mit funktionierenden Quicktext das AddOn Enigmail neu installiert. Bei mir funktioniert Quicktext mit diesem AddOn einwandfrei. Oder muss ich an Enigmail erst noch was konfigurieren ?

    Gruß Micha


    Mein produktiver Mailclient ist der portable TB mit der derzeit aktuellsten Version.

    Ansonsten in diversen VMs und zu Testzwecken diverse portable TB in den Versionen 78.* und Beta.

  • Bei mir funktioniert Quicktext mit diesem AddOn einwandfrei.

    Auch nach einem Neustart?


    Gruß
    EDV-Oldi

  • Auch nach mehreren Neustarts des TB, nach dem Update des TB auf 78.3.1 war sowieso ein Neustart nötig. Und Enigmail hatte ich in 78.2.2 installiert gehabt. Allerdings benutze ich Quicktext ohne Scripte.

    Gruß Micha


    Mein produktiver Mailclient ist der portable TB mit der derzeit aktuellsten Version.

    Ansonsten in diversen VMs und zu Testzwecken diverse portable TB in den Versionen 78.* und Beta.

  • So ich habe jetzt noch einmal einiges getestet.
    Alle Erweiterungen deaktiviert Neustart, dann nur Enigmail und Quicktext installiert, alles ok.
    Wenn ich Cardbook installiere und zwei Neustarts durchführe verschwindet Quicktext, in der Fehlerkonsole sind ja auch einige Fehler von Cardbook enthalten.

    Teste weiter


    Gruß
    EDV-Oldi

  • Auch ich habe CardBook neu hinzugefügt, mit dem Ergebnis, dass Quicktext immer noch funktioniert und auch konfigurierbar ist.

    Jetzt den TB 5x neu gestartet, immer noch alles OK.

    Gruß Micha


    Mein produktiver Mailclient ist der portable TB mit der derzeit aktuellsten Version.

    Ansonsten in diversen VMs und zu Testzwecken diverse portable TB in den Versionen 78.* und Beta.

  • Irgendwelche Add-ons stören sich wohl gegenseitig, ich weiß im Moment das es Probleme gibt wenn Cardbook und der Identity Chooser aktiv sind. Dann wird der Identity Chooser nicht richtig geladen. Erst nach deaktivieren und wieder aktivieren von Identity Chooser funktioniert dieses Add-on. Der Entwickler weiß auch Bescheid darüber.

    Ich habe bis jetzt verschiedene Kombinationen von Add-ons, wo es mal funktioniert mal nicht.

    Meine Add-ons stehen unten in der Signatur, es wäre interessant zu wissen welche Add-ons die anderen habe wo es auch nicht funktioniert.


    Gruß
    EDV-Oldi

  • edvoldi,


    ich sehe, du hast so einige User-Scripte am Laufen, vielleicht funkt eins davon dazwischen ?

    Ich habe keine User-Scripte und hier sind meine AddOns (womit alles funktioniert):


    Gruß Micha


    Mein produktiver Mailclient ist der portable TB mit der derzeit aktuellsten Version.

    Ansonsten in diversen VMs und zu Testzwecken diverse portable TB in den Versionen 78.* und Beta.

  • ich sehe, du hast so einige User-Scripte am Laufen, vielleicht funkt eins davon dazwischen ?

    Ich glaube kaum das die anderen die auch habe, denn ich habe den Fehler ja nicht gemeldet sondern nur bestätigt.

    Aber ich kann es gerne auch einmal ohne diese testen.


    Gruß
    EDV-Oldi

  • Aber ich kann es gerne auch einmal ohne diese testen.

    Auch ohne jegliche Anpassung habe ich den gleichen Fehler.


    Nachtrag:

    Alle Add-ons gelöscht, dann nur Cardbook, enigmail und Quicktext installiert und der Fehler ist wieder da.

  • Und mit "Quicktext geht nicht" meinst du, das keine Menueintrag im Tools Menu ist, und das keine Quicktext Toolbar im Message Composer auftaucht, richtig?


    Ich hab jetzt auch nur QT, Cardbook und Enigmail an und auch das MasterPasswort. Kein Fehler. *grrr*

  • Und mit "Quicktext geht nicht" meinst du, das keine Menueintrag im Tools Menu ist, und das keine Quicktext Toolbar im Message Composer auftaucht, richtig?

    ja

  • Dank edvoldi und einer kleinen Teamviewer session haben wir jetzt zumindest gesehen, wo das Problem ist und wie man es reproduzieren kann.


    Es muss sowohl Enigmail als auch GnuPG 2.2.19 (ftp://ftp.gnupg.org/gcrypt/bin…g-w32-2.2.19_20191207.exe) installiert sein. Dann fährt Quicktext nicht hoch. Ob auch andere/neuere Versionen von GnuPG das Problem zuverlässig reproduzieren kann ich nicht sagen, mit 2.2.19 "klappts" auf Anhieb.


    Die Stelle, an der sich Quicktext aufhängt ist ein Zugriff auf die local storage:


    Code
    await messenger.storage.local.get();


    Für die hier rumlaufenden Entwickler: Das Promise resolved nie, code execution flow stops.


    So, ham wa das erstmal. Jetzt muss ich rauskriegen, was genau Enigmail macht, dass das schief geht. Das ist ein völlig normaler Zugriff auf die WebExtension storage und Quicktext ist nicht das einzige Add-On, dass das nutzt.

  • Auch wenn ich bei verschiedenen Installationen nicht ein einziges Mal diesen Fehler hatte, möchte ich mich hier einmal dazu äußern.


    Wozu benötigt Ihr noch das enigmail-Add-on?


    Bei Euren Problemen würde ich temporär alle Add-ons außer enigmail 2.2.3 deaktivieren.

    Danach erst einmal die Migration durchführen und anschließend enigmail 2.2.3 deinstallieren.

    Nach einem Neustart von Thunderbird können alle Add-ons wieder aktiviert werden und gut ist.


    Ich habe die Migration auf vier verschiedenen PC´s durchgeführt und keine Probleme gehabt.


        


    Quicktext und Cardbook laufen ohne Probleme.


    Gruß

    Crashandy


    Sorry, ich habe den Beitrag von jobisoft zu spät gesehen und ich verwende natürlich GnuPG v2.2.23.

  • Ich habe Enigmail mal auseinandergenommen und versucht den Fehler zu finden. Meine Ergebnisse habe ich dann dem Entwickler zukommen lassen und er hat diese bestätigt. Es wird also bald eine neue Version von Enigmail geben, die das Problem behebt.

  • - Sorry, ich habe erst jetzt gesehen, dass es auch einen (älteren) Thread zu Problemen unter MacOS gibt. Ich schreibe mein Problem dort hinein. -


    Moin,

    ich hänge mich hier mal an, weil es um Probleme mit Quicktext geht - allerdings habe ich Probleme unter MacOS. Wenn deshalb ein neuer Thread gewünscht wäre, bitte ich vorab um Nachsicht und ggfs. um Abspaltung.


    MacOS 10.14.6 und 10.11.6

    TB: 78.x

    Quicktext 3.3

    Keine weiteren AddOns!


    Mein Problem (erst) seit Version 78.4: Die Menüzeile im Verfassen-Fenster fehlt. Bis TB 78.3 war sie noch da.


    Auf dem MacBook mit OS 10.14.6 gibt es in TB unter Extras die Auswahl Quicktext-Einstellungen und die Shortcuts funktionieren auch beim Verfassen.

    Auf dem MacBook mit OS 10.11.6 gibt es unter Extras nicht einmal mehr die Auswahl :(


    Hat vielleicht jemand eine Idee, woran es liegt und was ich machen kann? Vielen Dank schon einmal für's Lesen und ggfs. Überlegen.